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UNIT-I:  

Introduction to computers: Characteristics and limitations of computer, Block diagram of computer, 

types of computers, uses of computers, computer generations. 

 Number systems: working with binary, octal, decimal and Hexa decimal numbering system. 

 

 UNIT-II: 

 Input and Output devices: Keyboard and mouse, inputting data in other ways, Pointing Devices, 

Handheld Devices, Optical Devices, Audio-Visual Input Devices. 

Output Devices: Monitors, Projectors, Speakers, Printers, Plotters. Types of Software: system 

software, Application software, commercial, open source, domain and free ware software.  

Memories: Primary, Secondary and cache memory. Secondary Storage Devices: Magnetic Tapes, 

Floppy Disks, Hard Disks. Windows basics: Start menu, icons, MSWindows-Desktop, My Computer, 

My Documents, Pictures, Music, Videos, Recycle Bin, and Task Bar - Control Panel. 

 

 Unit –III: 

 Introduction to Adobe photoshop: Getting started with photoshop, creating and saving a document 

in photoshop, page layout and back ground, photoshop program window-title bar, menu bar, option bar, 

image window, image title bar, status bar, ruler, paletts, tool box,screen modes, saving files, reverting 

files, closing files.  

 

 

Unit –IV 

 Images: working with images, image size and resolution, image editing, colour modes and 

adjustments, Zooming & Panning an Image, Rulers, Guides & Grids- Cropping & Straightening an 

Image, image backgrounds, making selections.  

 

Working with tool box: working with pen tool, save and load selection-working with erasers-working 

with text and brushes-Colour manipulations: colour modes- Levels – Curves - Seeing Colour accurately 

- Patch tool – Cropping-Reading your palettes - Dust and scratches- Advanced Retouching- smoothing 

skin 

. 

 

 Unit-V  

Layers: Working with layers- layer styles- opacity-adjustment layers  

Filters: The filter menu, Working with filters- Editing your photo shoot, presentation –how to create 

adds, artstic filter, blur filter, brush store filter, distort filters, noice filters, pixelate filters, light effects, 

difference clouds, sharpen filters, printing. Menus: purpose of menus – new file- open file- print file – 

copying data – cut data- paste data- saving custom shape- working with modes- define brushes.  

 

 

 

Reference Books: 1. Fundamentals of Computers by Reema Thareja from Oxford University Press 2. 

Adobe Photoshop Class Room in a Book by Adobe Creative Team. 3. Photoshop: Beginner's Guide for 

Photoshop - Digital Photography, Photo Editing, Color Grading & Graphic...19 February 2016 by 

David Maxwell. 
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UNIT-1 

 

Introduction to Computers 

 

1. Explain the history of a Computer? 

 

1. The Computer has history of 2000 years. 

 

2. The Calculations was started by counting fingers. 

 

3. The earliest known device to record calculations was the “ABACUS”. 

 

4. It was invented by Chinese. By using this we can calculate additions and subtractions. 

 

5. In 1642 Blaise Pascal developed the real calculator for adding numerical values. It contains 

wheels to perform operations. 

 

6. In 1812, Charles Babbage designed and build a model called Difference Engine. It was 

designed to perform calculations without human interaction. 

 

7. In 1833, Charles Babbage designed Analytical Engine, which has many parts that could be 

found in modern days computers like Arithmetic and logical unit, storage unit. 

 

8. In 1884, Dr.Herman Hollerith used punched cards to process the data gathered from census. 

 

9. During the next forty years from 1900, many more calculating machines were developed. These 

machines are used for Record Keeping and other accounting functions called as accounting 

machine. 

 

10. In 1944, “Howard Aikan” developed MARK-I, first calculating machine used to handle large 

amount of data and complex equations. 

 

11. In 1946, John W Marchly developed ENIAC (Electronic Numerical Integrated Analyzer 

Computer) was an electronic computer sponsored by US Army. 

 

12. The ENIAC was so large which is 10 feet height and 10 feet wide. Its weight was 30 tons and it 

requires 18,000 vacuum tubes. 

 

13. In 1949, John Vaun Newman developed EDSAC ( Electronic Delay Storage Automatic 

Computer), which is more improved than ENIAC. 

 

14. In 1951, UNIVAC ( Universal Computer) was developed by US. It was used in Colombia 

broadcasting system for telecasting the US president election result in 1952. 

 

Definition of Computer: 

 

A Computer is an electronic device which takes data or instructions as input and process the 

data and generates useful information as output with speed and accuracy. 
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2. What are the characteristics and limitations of a computer? 

 

Characteristics of a Computer: 

 

 The following are the main characteristics of a computer. They are 

 

1. Speed 

• A computer perform operations with high speed 

• Computer has the ability to process large volume of data and retrieve the data in fraction 

of seconds. 

• The speed of computer basically measured in nano seconds (10-9), Pico seconds(1012). 

• The Speed of a computer vary from one computer to another computer. 

10-3 - Milliseconds 

10-6 - Microseconds 

10-9  – Nanoseconds 

10-12 – Picoseconds 

 

2. Accuracy 

• Computer is a very accurate device, it can perform each and every calculation with the 

same accuracy. 

• It can execute first and last instructions with same speed. 

• In computer errors can be occurred because of human beings inaccurate data. 

 

3. Versatility 

• Computer is a versatile machine. Versatile means capable of doing many things at a 

time. 

• Computer can perform multiple tasks at a time. 

• Versatility is the quality of being flexible. 

 

4. Diligence 

• Computers never get tired of a repetitive task. 

• If there are millions of instructions to perform then a computer perform the last 

instruction also with the same speed and accuracy as first instruction. 

 

5. Large Storage Capacity 

• A computer has a large storage capacity so it can store huge amount of data. 

• The computer stores a large amount of data and programs in the secondary storage 

space. 

• The data may be text, picture, sound, video etc. 

  

6. No Intelligence Quotient 

• A computer has no intelligence on its own. 

• User has to determine the task, so the computer cannot take decision on its own. 

 

7. Automatic 

• A machine which works itself without any human participation is said to be automatic 

machine. 

• Computers are automatic machines because once it started a job they continue until the 

job is finished. 

• However, computer machines cannot start themselves they have to be instructed. 

 

8. Cost Benefits 

• Computers are considered as short-term investment for achieving long-term gains. 

• Using computers also reduces manpower requirements and leads to an elegant and 

efficient way of performing various tasks. 
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• Computers save time, energy, and money. 

 

Limitations of a Computer: 

A computer can do better than human beings in speed, accuracy, and memory but still it has 

some limitations. They are 

 

1. No Self Intelligence: 

A computer cannot generate information on its own. A computer can follow instructions 

given by human being. 

 

2. No thinking and No decision making: 

A computer cannot think itself. The concept of AI (Artificial Intelligence) shows that 

computer can think but still the concept depend on set of instructions (Programs) provided by 

programmer. 

 

3. Retrieval of Memory: 

A computer can retrieve data very quickly and in a linear technique fashion. Human 

being doesn’t follow this rule. They follow random fashion which a computer can’t. 

 

4. No Feeling: 

A computer can’t meet humans in respect of relations. Human can feel, think and care 

but a computer can’t. 

 

 

3. Explain the Classification/types of Computers? 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

We can classify computers based on three considerations. 

 

1. According to the purpose 

2. According to Logical Technology 

3. According to Speed and Capacity 

 

1. According to Purpose: 

According to the utilization of the computers we can divide them into two categories. 

 

a. General purpose computers 

b. Specific purpose computers 

 

General Purpose Computers: 

 
• These computers are used to design to perform all kinds of jobs or applications. 

• These computers can be used to solve business problems, mathematical problems, 

calculations, accounts, accessing information etc. 
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Ex: Personal Computers 

Specific Purpose Computers: 

 
• These computers are designed to use for special applications or a single job. So, they 

executes specified task quickly and efficiently. 

Ex: Super Computers 

 

2. According to Logical Technology: 

There are three types of technologies are used in computers. They are 

a. Analog Computers 

b. Digital Computers 

c. Hybrid Computers 

 

Analog Computers: 

 
• The input data is not a number, it is a physical quantity like temperature, pressure, speed 

and velocity. 

• The signals are continuous with high speed and output is also continuous. 

 

• Speedometer, which is used to measure speed of cars and bikes. 

 

 

 

 

 

 

 

Digital Computers: 

 
• The input data is represented by numbers in Digital Computers. 

• Digital computers have unlimited accuracy. 

• Digital computer uses two signals 0s and 1s. 

Example: Digital Watch and Digital Camera. 

 

 

 

 

 

Hybrid Computers: 

 
• It is a combination of Analog and Digital computer. 

• These computers can store and process Analog signals as well as Digital signals. 

              Example: MODEM (Modulator – Demodulator) 

 

3. According to speed/capacity: 

According to speed and memory capacity computers are divided into four types. 

 

a. Super Computers: 

i. It is the biggest and fastest computers which are mainly designed for scientific 

applications. 

ii. It has many CPUs which operate parallel to make calculations faster. 

iii. The speed of super computers can be measured in FLOPS(Floating Point Operations 

per second) 

Applications of Super Computer: 

i. Weather Forecasting 

ii. Petroleum exploration and protection 
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iii. Nuclear Research 

iv. Defense 

v. Real Time Applications 

vi. DNA analysis 

Examples: 

A. CRAY-I (First super computer in the World) 

B. PARAM (First Super Computer in India) 

C. PARAM YUVA-II (Latest Super Computer in India) 

D. BLUE GENIE (Fastest Super Computer in World developed by IBM) 

 

b. Mainframe Computers: 

i. These computers are very large and fast computers but smaller than super computers. 

ii. These are very expensive and need very large clean room with air conditioning. 

iii. IBM S/390 mainframe computer can support 50,000 users at the same time. 

iv. There are basically two types of terminals that can be used with mainframe system. 

A. Dumb Terminal: Dumb Terminals consists of only a monitor and a key board 

or mouse. They do not have their own CPU and memory. They use the 

mainframe system’s CPU and memory. 

B. Intelligent Terminal: Intelligent terminals have their own processor and thus 

can perform some processing operations. They do not have their own storage 

space. These are used as servers on the world Wide Web. 

Applications: 

A. Railway Reservation system 

B. Banking applications 

Examples: 

IBM S/390 – developed by IBM and GANESH – Used by Indian Railway 

 

c. Mini Computers: 

i. Mini computers are smaller, cheaper and slower than mainframes. 

ii. Mini computers also known as Mid Range Computers, the capabilities of mini computers 

fall between mainframe and PCs. 

iii. These are widely used in business, education, hospitals, government organizations etc,. 

iv. Mini computers can also be used as servers in a networked environment, and hundreds of 

PCs can be connected to it. 

d. Micro Computers: 

i. Micro computers commonly known as PCs, are very small and cheap. 

ii. The first micro computer was designed by IBM in 1981 and was named as IBM-PC. 

iii. PCs can be classified into the following categories. 

A. Desktop PCs 

B. Laptops 

C. Workstations 

D. Network Computers 

E. Handheld Computers 

 

4. Explain the generations of a Computer? 

 

1. Generation in computer is a step in technology. It provides a framework for growth of the 

computer. 

2. Computers are generally classified into different generations according to the processing 

device used in the computer. 

 

First Generation (1940-1955): 

 

1. First-generation computers used a very large number of vacuum tubes for circuitry and 

magnetic drums for memory. 

2. These computers were so big in size that they often required an entire room to be installed. 
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3. First generation computers were mainly used in scientific purpose. 

4. In addition to a large amount of space, they also needed a lot of electricity and generate lot of 

heat. 

5. First generation computers could be programmed using machine language consisting of only 0s 

and 1s. 

 

Example: UNIVAC -Universal Automatic Computer 

ENIAC -Electronic Numerical Integrator And Calculator 

 

Advantages: 

 

1. They were the fastest calculating devices of their time.  

 

Disadvantages: 

 

1. They consumed a lot of electricity hence they generate lot of heat. 

2. Vacuum tubes used filaments that had limited life. 

3. These computers were frequently down due to hardware failure. 

4. These computers were very expensive. 

 

Second Generation (1956-1963): 

 

1. Second generation computers were manufactured using transistors. 

2. Computers manufactured using transistors were smaller, faster, cheaper and more energy 

efficient and reliable than first generation computers. 

3. Second generation computers were used punched cards as input devices and output was 

generated as printouts. 

4. Second generation computers were programmed using assembly languages which allowed 

programmers to specify instructions in words. 

5. During this time period high-level programming languages such as COBOL, FORTRAN, 

ALGOL were developed. 

Advantages: 

 

1. They consume less electricity and generated less heat when compared to first generation 

computers. 

2. They were faster, cheaper, smaller and more reliable than first generation computers. 

3. These computers had faster primary memory and a larger secondary memory. 

 

Disadvantages: 

1. Since these computers used transistors, this had to be assembled manually. 

2. Commercial production of computers difficult and expensive. 

 

Third Generation (1964-1971): 

 

1. Third generation computers were manufactured using Integrated Circuits(IC). 

2. Several electronic components such as transistors, resistors and capacitors were miniaturized 

and placed on a silicon chip called integrated chip. 

3. Integrated chips were smaller, less expensive, more reliable and faster in operation. 

4. These computers were consumed less power and generated less heat when compared to second 

generation computers. 

5. Third generation computers were the first to implement time sharing operating systems. 

 

Advantages: 

1. They were faster than second generation computers and perform one million instructions per 

second. 

2. They were faster, smaller, cheaper and more reliable. 



                                                                                                                                      
                                                                                                                                   COMPUTER FUNDAMENTALS AND PHOTOSHOP 

8 
 

3. Third generation computers were used in scientific as well as business applications. 

4. Number of high level languages were developed in this generation and time sharing operating 

systems were also developed in this generation. 

Disadvantages: 

1. Third generation computers were very difficult to maintain. 

2. These computers got heated very quickly. 

 

Fourth Generation (1971-1989): 

 

1. Thousands of Integrated Circuits built onto a single silicon chip called microprocessor or Very 

Large Scale IC (VLSI). 

2. INTEL 4004 and INTEL 8-88 micro processors were used in this generation. 

3. Graphical User Interface (GUI), the Mouse, and hand held devices were developed in this 

generation. 

4. Domain specific languages such as SQL and text formatting software were developed in this 

generation. 

5. Structured Oriented Programming Languages were developed and resource sharing is 

implemented in this generation. 

 

Advantages: 

1. Fourth generation computers were smaller, cheaper, faster and more reliable. 

2. They consumed less electricity and generated very less heat. 

3. They had faster and larger primary memory and secondary memory. 

Disadvantages: 

1. Fourth generation computers were not intelligent systems. 

 

Fifth Generation (Present and Beyond): 

 

1. Fifth generation computers are completely based on the new concept of Artificial Intelligence 

(AI). 

2. The aim of fifth generation computers is to develop devices that respond to natural language 

input and are capable of learning and self organization. 

3. Gaming, Expert System, Natural languages, Neural Networks and Robotics are some areas in 

which Artificial Intelligence is using. 

4. In fifth generation parallel processing is introduced. 

5. Use of Artificial Intelligence will make computer intelligent and knowledge based. 

 

5. Explain the Block Diagram of Computer or Logical Organization of Computer?
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A computer is an electronic device that basically performs the following operations. 

1. Input 

2. Store Data 

3. Process Data 

4. Output 

5. Controlling and Coordinating 

 

Input: 

1. Input is the process of entering data and instructions into the computer system. 

2. The data and instructions can be entered by using different input devices such as Key Board, 

Mouse, Scanner and Track Ball etc. 

3. Since computers can understand only binary language it is the responsibility of input device to 

convert the input data into binary codes. 

Output: 

 

1. Output is the information i.e., processed data. 

2. The information is displayed through output devices such as monitor and printer. 

3. It is the responsibility of output device to convert the binary code into human readable 

language before displaying it to the user. 

 

Central Processing Unit: 

 

A simplified structure of CPU contains five parts. They are 

 

1. Control Unit: 

a. The control unit interprets any instruction it received from memory and direct the sequence 

of events necessary to execute. 

b. It also responsible for performing the execution. 

c. Control unit uses system clock, which synchronizes all tasks by sending out electrical 

pulses. 

d. The clock speed of CPU is defined as frequency that a processor executes instructions. 

e. The clock speed is measured in millions of cycles per second or Mega Hertz(MHz) and is 

the main element in determining the speed of the processor. 

 

2. Arithmetic and Logical Unit: 

 

a. The ALU is the part of CPU where actual processing occurs. 

b. All calculations (mathematical) and all comparisons ( logical functions) takes place in this 

unit. 

c. Basic arithmetic functions which an ALU can carry out are addition and subtraction, more 

powerful CPUs can perform multiplication and division. 

d. The logical functions or operations can carry out are greater than (>), less than (<), 

comparison between two numbers etc. 

e. The ALU is made up of devices called GATES that receive one or more inputs based on 

the function that performs and present result. 

 

3. Registry Array: 

a. Registers are temporary memory units that store a computer instruction. 

b. Registers are located in the processor instead of RAM. So data can be accessed and stored 

faster. 

c. CPU uses these registers to handle the process of execution. Registers are a part of CPU but 

cannot be considered as part of memory unit. 

d. A processor contains several types of registers, they are classified according to their 

content. 

a. Data Registers:-Used to hold numeric values such as integers and floating point 

numbers. 
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b. Address Registers:-Used to hold addresses used by the instructions to access memory. 

c. Program Counter:-It contains the address of next instruction to be executed. 

4. System Bus: 

a. The system bus is a collection of wires which carries data communication between major 

components of the computer. 

b. These wires carry information in the form of voltage. 5V at a wire indicates BIT-1 and 0V 

at a wire indicates a BIT-0. 

c. System Bus contains three different groups of wires called as Data Bus, Address Bus, and 

Control Bus. 

a. Address Bus: 
• An Address Bus carries the address of memory location or address of 

device. 

• If a computer uses 8 BITs to represent the address of a location it can 

address up to 256 locations. 

b. Data Bus: 
• A Data Bus carries data to the memory locations or to the input or output 

devices. 

• In a 8 BIT computer the width of the data bus is 8 lines. It can carry only 

8 bits at a time. 

 

c. Control Bus: 
• Control Bus carries control signals used to control overall operations of 

the computer. 

5. Memory Unit or Storage Unit: 

a. Storage is the process of data and instructions permanently in the computer so that they can 

be used for processing. 

b. The computer storage space not only stores the data and programs, it can also store result 

from the various operations and final results of processing. 

c. A computer has two types of storage areas. 

Primary Memory:- 
• It is the storage area that is directly accessed by the CPU. 

• It is used to store the data and parts of programs, intermediate results of processing, 

recently generated results of tasks etc. 

• Primary storage space is very expensive, therefore limited in capacity. 

• Primary Memory also called as Main Memory or Temporary Memory or Volatile 

Memory. Example for Primary Memory is RAM-Random Access Memory. 

Secondary Memory: 
• Secondary Memory is the memory in which data and programs are stored permanently. 

• Secondary Memory is also known as Auxiliary Memory. It is non-volatile memory. 

            Example for Secondary Memory is HDD. 

6.What are the applications or Uses of Computers? 

1. When the first generation computers were developed, they were used in the field of 

mathematics and science. 

2. Today with the advanced technology the cost of computers and the maintenance is reduced. 

3. This gives the way for computer to use in the business and commercial sectors for information 

processing. 

4. The following are the some of the applications of computers. 

a. Word Processing:-Word Processing software enables users to read and write documents. 

b. Internet:-The Internet is a network of networks that connects computers all over the world. 
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c. Digital video or Audio Composition:-Computers make audio or video composition and 

editing very simple. This has drastically reduced the cost of equipment to compose music 

or make a film. 

d. Desktop Publishing:-Desktop Publishing software enables you to create page layouts for 

entire books. 

e. Government:-Computers are used in government organizations to keep records. 

f. Traffic control:-Computers are used by the government for city planning and traffic 

control. 

g. Legal Systems:-Computers are used by lawyers to shorten the time required to conduct 

legal precedent and case research. 

h. Hospitals:-Hospitals use computers to record every information about patients, from the 

time of their admission till their exit. 

i. Weather forecasting 

j. Online banking 

k. Robots 

l. Decision Support System 

m. Expert System 

 

 

Number System 

 

1. What is a Number System and explain the types of Number System? 

 

Number System: 

            

               A set of values used to represent different quantities is known as number system. For 

example a number system can be used to represent a number of students in a class or number of 

viewers watching a TV show. The following are different types of Number Systems. 

1. Binary Number System 

                      Digital computers internally use the binary number system to represent data and 

perform arithmetic calculations. The binary number system is very efficient for computers but not for 

humans. It has only 2 symbols 0 and 1. Hence its base is 2. 

Example:  (110011001)2 

 

2. Octal Number System 

                    Octal Number System is the base 8 number system and uses the symbols 0, 

1,2,3,4,5,6,7. Hence its base is 8. A number written by using these digits is called an octal number. 

Example: (123)8, (256)8, (143)8 

 

3. Decimal Number System 

                    Decimal Number System is very popular among all number system because we 

use decimal numbers everyday. It has 10symbols 0, 1, 2, 3,4,5,6,7,8,9. Hence its base is 10. 

Example:  (14122251)10, (12345)10 

 

4. Hexadecimal Number System 

It is a number system that uses 16 symbols to represent a particular value. The symbols are 

0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F.Hence its base is 16.The symbols A,B,C,D,E,F represent the decimal 

value 10,11,12,13,14,15 respectively. 

Example:  (E4C2251)16, (E35D)16 
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The following are the available number systems. 

 

 Number System  Base  Digits present in Number System 

Decimal 10 0,1,2,3,4,5,6,7,8,9 

Binary 2 0,1 

Octal 8 0,1,2,3,4,5,6,7 

Hexa Decimal 16  0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F 

 

In Hexa-Decimal number System      10 is represented as A 

11 is represented as B 

12 is represented as C 

13 is represented as D 

14 is represented as E 

15 is represented as F. 

 

➢ Converting a Decimal number into Binary: 

 

1. To convert a Decimal number into its equivalent Binary number simply divide decimal number 

by 2 and write down the remainder. 

2. Repeat above step until it cannot be divided by 2. 

3. Then write down the remainders starting from last to first. 

Let us take a decimal number (93)10. 

 

Divide 93 with 2 and write down the remainders. 

Then write down the remainders from bottom to top. 

 

(93)10 = (1011101)2 

 

 

 

 

➢ Converting a Decimal number into Octal: 

1. To convert a decimal number into its equivalent octal number divide the decimal number with 

8 and write down the remainder. 

2. Repeat above step until it cannot be divided by 8. 

3. Then write down the remainders starting from last to first. 

Let us take a decimal number (93)10. 

Divide 93 with 8 and write down the remainders. 

Then write down the remainders from bottom to top. 

(93)10 = (135)8 

 

 

➢ Converting a Decimal Number into Hexa-Decimal: 

1. To convert a decimal number into its equivalent hexa decimal number, divide the decimal 

number with 16 and write down the remainder. 

2. Repeat above step until it cannot be divided by 16. 
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3. Then write down the remainders starting from last to first. If the remainder is above 9 then 

write down its corresponding hexa-decimal code. 

Let us take a decimal number (93)10. 

Divide 93 with 16 and write down the remainders. 

If the remainder is greater than 9 then write the corresponding hexa decimal 

code equivalent to that remainder. 

(93)10 = (5D)16 

 

➢ Converting a Binary Number into Decimal: 

1. To convert a binary number into its equivalent decimal number, take the powers of 2 starting 

from 0 towards MSB from LSB. 

2. Multiply the power of 2 with corresponding BIT and perform addition to get the decimal 

number. 

 

 

 

64X1+32X0+16X1+8X1+4X1+2X0+1X1 64 + 0 + 16 + 

8 + 4 + 0 + 1 = 93 

 

(1011101)2 = (93)10 

 

➢ Converting a Binary Number into Octal: 

1. To convert a binary number into its equivalent octal number split the binary number into three 

bit three bit form from LSB to MSB. 

2. Maximum digit in octal number system is 7. 

3. To represent 7 in binary form 3 bits are sufficient. 

4. Represent each digit in octal number system in three bit. 

5. Write down the corresponding digit of three bit. You can get the octal number. 

 

 

 

 

 

 

(1011101)2 = (135)8 

➢ Converting a Binary Number into Hexa-Decimal: 

1. To convert a binary number into its equivalent hexa-decimal number split the binary number 

into four bit four bit form from LSB to MSB. 

2. Maximum digit in hexa-decimal number system is F(15); 

3. To represent F in binary form 4 bits are sufficient. 

4. Represent each digit in hexa-decimal number system in four bit. 

5. Write down the corresponding digit of four bit. You can get the hexa-decimal number. 

 

 

 

 

 

 

(1011101)2 = (5D)16 
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➢ Converting an Octal Number into Decimal: 

1. To convert an octal number into its equivalent decimal number take powers of 8 starting from 

0 towards left hand side from right hand side. 

2. Multiply the corresponding digit with power of 8 and add. You will get equivalent 

decimal number. 

Let us take an Octal Number (135)8. 

 

 

 

 

 
➢ (135)8 = (93)10.

 

 

➢ Converting an Octal Number into Binary: 

1. To convert an octal number into its equivalent binary number write down the three bit 

representation of each digit of octal number. 

       2. It will directly give the binary number. 

                  Let us take an octal number (135)8. 

 

 

 

 

 

➢ Converting an Octal Number into Hexa-Decimal: 

1. To convert an octal number into its equivalent hexa decimal number convert octal number into 

binary as specified above. 

2. Then split the binary number into four bit four bit representation from LSB to MSB. 

3. Write down the corresponding four bit digit. 

 

 

 

 

 

 

 

 

➢ Converting a Hexa-Decimal number into Decimal: 

1. To convert a Hexa-Decimal number into its equivalent Decimal number take powers of 16 

starting from 0 towards left from right. 

2. Multiply the corresponding digit with power of 16 and add. You will get equivalent decimal 

number. 

Let us take (5D)16. 
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➢ Converting a Hexa-Decimal number into Binary: 

1. To convert a Hexa-Decimal number into its equivalent binary write down the four bit 

representation of each digit in Hexa-decimal. 

2. It will directly give the binary number. 

 

 

 

 

 

 

 

 

➢ Converting a Hexa-Decimal number into Octal: 

1. To convert a Hexa-Decimal number into its equivalent octal, first convert it into binary. 

2. Then split the binary into three bit three bit. 

3. Write the corresponding three bit digit in octal.
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UNIT-II 

INPUT & OUTPUT DEVICES 

 

1. What is an INPUT DEVICE and explain types of input devices? 

1. It is a device in which data and Instructions are entered into computer. 

2. It accepts the instructions and data from user in different form and convert them into the form 

that computer can understand. 

3. After this the input unit supplies the converted instructions and data to CPU for further 

processing. 

 

 

Input Devices 

 

 

 

 Keyboard Pointing                Handheld                  Optical  Audio-Video 

                                             Devices Devices Devices Devices  

 

 

 1. Mouse 1.Lightpen 1.BCR 1.Microphone 

               2. Trackball          2.TouchScreen 2.Scanner 2.Digital Camera 

                3. Touchball         3.Joystick 3.OCR                    3.Web Camera 

 4.OMR 

 5.MICR 

 

Keyboard:    A Key Board is the main input device for the computer. 

1. Using a Key Board, the user can type a document, use key stroke short cuts, access menus, play 

games, and perform other tasks. 

2. Most keyboards have between 80 to 110 keys. 

a. Alphabetic Keys – A to Z 

b. Numerical Keys – 0 to 9 

c. Functional Keys – F1 to F12 

d. Cursor movement Keys - ↑ ↓ ← → 

e. Modifier Keys – Shift, Alt, Ctrl 

f. Special Purpose Keys – Print Screen, Scroll Lock, Pause, Insert, Delete… 

g. Special Keys - +, -, *, ; , ( , ) , [ , ] … 

 

POINTING DEVICES 

A pointing input device enables the users to easily control the movement of the pointer to select 

items on a display screen, to select commands from commands menu, to draw graphics. 

MOUSE: 

1. It is the key input device in Graphical User Interface (GUI).It can be used to handle the pointer 

easily on the screen to perform various functions. 

2. A mouse has two buttons and a scroll wheel. 

3. It can be held in the hand and easily moved without lifting along a hard flat surface to move the 

cursor to the desired location. 

4.  Operations that can be performed using mouse are  

a. Clicking 

b. Double Clicking 

d. Right Clicking 

e.. Scrolling 
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c. Dragging 

TRACKBALL: 

1. A Trackball is a pointing device that is used to control the position of the cursor on the screen. 

2. A Trackball contains two buttons like mouse. 

3. The user rolls the ball to position the cursor at an appropriate place on the screen and then clicks 

one of the buttons to select object or to position the cursor for text entry. 

TOUCH PAD: 

1. A Touchpad is a small flat rectangular stationary pointing device with a sensitive surface of 1.5 

to 2 square inches. 

2. The user has to slide his/her fingertips across the surface of the pad to point to a specific object 

in the screen. 

HANDHELD DEVICES: 

A handheld device is a pocket-size computing device with a display screen and touch input or 

miniature keyboard. 

 

STYLUS/LIGHT PEN: 

1. A Stylus is a pen shaped input device used to enter information or write on the touch screen of a 

handheld device. 

2. It is a small stick that can also be used to draw lines as input to a device. 

 

TOUCH SCREEN: 

1. A Touch screen is a display screen that can identify the occurrence and position of a touch in 

the display region. 

2. The user can touch the screen either by using a finger or a stylus. 

 

JOYSTICK: 

1. A Joystick is a cursor control device widely used in computer games and computer aided 

design. 

2. It consists of a handheld lever that pivots on one end and transmits it coordinates into a 

computer. 

3. A Joystick has one or more push buttons, called switches. The level of a joystick moves in all 

directions to control the movement of the pointer. 

 

OPTICAL DEVICES 

Optical devices are also known as data scanning devices, use light as a source of point for 

detecting, recognizing different objects such as character marks, codes and images. 

 

BCR- BAR CODE READER: 

1. Bar Code Reader is a handheld input device that is used to capture and read information stored 

in barcode. 

2. It consists of a scanner, a decoder, and a cable used to connect the reader to a computer. 

3. Bar Code Readers are cheap, portable and easy to use. 

SCANNER: 

1. A Scanner is a device that capture images, printed text and hand writing from different sources 

such as photographic prints, posters and magazines and convert them into digital images for 

editing and display on computer. 

2. There are two types of scanners. 

a. Handheld Scanners:-light beam moved across the object or image to be scanned from top 

to bottom. 
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b.  Flat bed Scanners:-light beam moved across the object or image to be scanned from left to 

right. 

OCR – OPTICAL CHARACTER RECOGNITION 

1. Optical Character Recognition is the process of converting printed materials into text or word 

processing files that can be easily edited and stored. 

2. Advanced OCR can recognize handwritten text and convert it into computer-readable text files. 

 

OMR – OPTICAL MARK RECOGNITION 

1. Optical Mark Recognition is the process of electronically extracting data from marked fields, 

such as checkboxes and fill-in fields, on printed forms. 

2. The OMR sheet is scanned by the reader to detect the presence of a mark by measuring the 

reflected light levels. 

3. Optical Mark readers work at very high speed. They can read up to 9000 forms per hour. 

 

MICR – MAGNETIC INK CHARACTER READER 

1. Magnetic Ink Character Reader is used to verify the legitimacy of paper documents, especially 

bank cheque. 

2. It consists of magnetic ink printed characters that can be recognized by high speed magnetic 

recognition devices. 

3. MICR is widely used to enhance the security, and minimize the exposure to cheque fraud. 

 

AUDIO-VIDEO INPUT DEVICES 

 

Today, all computers are multimedia-enabled, that is, computers not only allow one to read or 

write text, but also enable the user to record songs, view animated movies etc. 

 

AUDIO INPUT DEVICES 

1. A microphone feeds audio input to the computer. 

2. The audio input must be converted into digital data before being stored in the computer. 

3. To work with microphone a computer must have a sound card 

4. A computer with a microphone and speakers can be used to make telephone calls and video 

calls over internet. 

 

VIDEO INPUT DEVICES 

1. A Digital Camera is a handheld video input device and is a portable device used to capture 

images or videos. 

2. The Digital Camera digitizes images or videos and stores them on a memory card. These data 

can be moved to computer by using a cable. 

3. A Web Camera captures videos that can be transferred via the Internet in real time. These are 

widely used for videoconferencing. 
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OUTPUT DEVICES 

 

2. What is an OUTPUT DEVICE and explain the types of output devices? 

Any device that gives information from a computer can be called an output device. Basically, 

output devices are electromechanical devices that accept digital data from computer and convert them 

into human understandable language. 

 

 
Output Devices 

 

 

Softcopy Hardcopy 
 
 
 

Monitor Projector Speaker Printer Plotter 

  

 

SOFTCOPY DEVICES: 

1. Softcopy devices produce an electronic version of an output. For example a file that is stored on 

a hard disk, CD or pen drive and is displayed on the computer screen. 

2. The output can be viewed only when the computer is on. 

3. The user can easily edit soft copy output. 

4. Searching for data in a softcopy is easy and fast. 

5. Electronic distribution of materials as a softcopy is cheaper. It can be done easily and quickly. 

 

MONITORS 

1. A monitor is a softcopy output device used to display video and graphics information generated 

by the computer through the video card. 

2. Computer monitors are similar to television screens but they display information with a much 

higher quality. 

3. Monitors can be in three variants. 

a. Cathode Ray Tube – CRT 

b. Liquid Crystal Display – LCD 

c. Plasma 

CRT MONITOR 

1. CRT monitors works by firing charged electrons at a phosphorus film. 

2. When electrons hit the phosphor coated screen, they glow, thereby enabling the user to see the 

output. 

Advantages: 

a. CRT monitors provides images of good quality. 

b. CRT monitors are cheap when compared to LCD and Plasma. 

c. The images are clear when you try to view in any angle. 

Disadvantages: 

a. CRT monitors occupy a large space on desk. 

b. They are bigger in size, weight and therefore difficult to move from one place to another 

when compared with other type of monitors. 

c. CRT monitors consume very high electric power. 

LCD MONITOR 

1. An LCD monitor is a thin, flat electronic visual display unit that uses light modulating 

properties of liquid crystals, which do not emit light directly. 
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2. LCD screens are used in a wide range of applications ranging from computer monitors, 

televisions, instrument panels, air craft cockpit displays etc. 

Advantages: 

a. LCD monitors are very compact and lightweight. 

b. They consume less power and there is a little or no flicker of images. 

c. They can be made in almost any size or shape. 

d. They cause less eye fatigue. 

             Disadvantages: 

a. They are more expensive than CRTs. 

b. Images are not very clear when tried to view from an angle. 

 

PLASMA: 

1. These monitors are thin and flat monitors widely used in television and computers. 

2. The plasma display contains two glass plates that have hundreds or thousands of tiny 

cells filled with xenon and neon gases. 

Advantages 

a. Very bright images are formed which look good from almost every angle. 

b. These monitors are not heavy and are easily portable. 

Disadvantages 

a. These monitors are very expensive. 

b. They consume much power. 

 

PROJECTORS: 

1. A projector is a device that takes an image from a video source and projects it onto a screen or 

another surface. 

2. Projectors allow users to change or adjust some features of the image such as brightness 

sharpness and color settings similar to the features available in standard television. 

3. Projectors can be broadly divided into two categories depending on the technology they use. 

a. LCD projector 

b. Digital Light Processing (DLP) projectors 

 

SPEAKERS: 

1. Speakers were developed in different sizes and shapes, and with different powers and sound 

quality. 

2. The user can enjoy music, movie, or a game, and the voice will be spread through the entire 

room. 

3. Headphones are used when user wants loud sound without disturbing others. 

4. Headsets are widely used in call centers and other telephonic-intensive jobs, and personal use 

on computer. 

 

HARDCOPY DEVICES 

1. Hard copy devices produce a physical form of output. For example, the content of a file printed 

on a paper is of hardcopy output. 

2. A computer is not needed to see the output. 

3. Hardcopy output can be easily distributed to people who do not have a computer. 

4. Searching for data in hardcopy is a difficult job.



                                                                                                                                      
                                                                                                                                   COMPUTER FUNDAMENTALS AND PHOTOSHOP 

21 
 

 

PRINTERS: 

1. A printer is a device that takes the text and graphics information obtained from a computer and 

prints it on to paper. 

2. Color printouts are needed for presentations, maps, and other pages where color is part of the 

information. 

3. Resolution of a printer means the sharpness of text and images rendered on paper. It is usually 

expressed in dots per inch (dpi). 

4. Speed of printer refers to the number of pages that are printed in one minute. 

5. Memory of a printer enhances the speed of printing.

         

       

 

 

                                                        Impact 

                                                      Printers 

                                   

                                Dot matrix      Daisy                                                             

                                                         Wheel 

 

 

Printers 

 

                      Non-Impact 

                            Printers 

              

Line        Inkjet            Laser

 

IMPACT PRINTERS: 

These printers print characters by striking an ink ribbon against the paper. 

Advantages 

a. These printers enable the user to produce carbon copies. 

b. They are cheap. 

Disadvantages 

a. Impact printers are slow. 

b. They offer poor print quality, especially in case of graphics. 

c. They produce noise. 

d. They print only using the standard font. 

 

DOT MATRIX PRINTER: 

1. A dot matrix printer prints characters and images of all types as a pattern of dots. 

2. This printer has a print head that consists of pins representing the character or image. 

3. The print head runs back and forth or up and down motion on the page and prints by striking 

an ink-soaked ribbon against the paper. 

4. The speed of these printers varies in the range of 50-500 characters per second.  

Advantages: 

a. These printers can produce carbon copies. 

b. These printers offer lowest printing cost per page and are very cheap. 

 Disadvantages: 

a. This type of printer creates a lot of noise. 

b. These printers can only print lower resolution graphics, with limited quality. 

c. These printers are very slow and have poor print quality. 

 

DAISY WHEEL PRINTER: 

1. A daisy wheel printer uses impact printing technology to generate high-quality output. 

2. The print head of daisy wheel printer is a circular wheel, about 3 inches in diameter with arms 

or spokes. 
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3. To print a character, the wheel is rotated in such a way that the character to be printed is 

positioned just in front of the printer ribbon. 

4. The key benefit of using a daisy wheel printer is that the print quality is high. 

 

LINE PRINTER 

1. A line printer is a high speed impact printer in which one typed line is printed at a time. 

2. The speed of line printer varies from 600-1200 lines or 10-20 pages per minute. 

3. Band printer is the commonly used variant of line printer. Band Printer: 

a. A Band printer is an impact printer with a printing mechanism that uses a metal loop or 

band to produce typed characters. 

b. The main advantage of using band printer is its high speed. 

c. These printers can print 2000 lines per minute. 

 

NON IMPACT PRINTERS: 

1. In these printers the printing head do not strike the paper. 

2. They offer better print quality, faster printing, and prints high level graphics. 

3. These printers use either solid or liquid cartridge-based ink, which is either sprayed or electro 

statically drawn onto the page. 

Advantages: 

                These printers are noiseless and can print text in different fonts. 

Disadvantages: 

a. These printers are expensive. 

b. The ink cartridges used by these printers are also costly. 

 

INKJET PRINTER: 

1. The print head of inkjet printers has several tiny nozzles, also called jets. 

2. When the paper moves past the print head, the nozzles spray ink onto it, forming characters 

and images. 

3. An inkjet printer can produce 100 to several hundred pages before the ink cartridges must be 

replaced depending on the nature of the hard copy. 

4. The color inkjet printers have succeeded in making color printing an affordable option for 

home users. 

 

LASER PRINTER: 

1. A laser printer is a non impact printer that works at very high speed and produce high quality 

of text and graphics. 

a. A laser beam draws the document on a drum using electrical charges. 

b. After the drum is charged, it is rolled in a toner. 

c. The toner sticks to the charged image on the drum. 

d. The toner is transferred onto a piece of paper and fused to the paper with heat and pressure. 

e. After the document is printed, the electrical charge is removed from the drum and the 

excess toner is collected. 

 

PLOTTERS: 

1. A plotter is a printing device that is usually used to print vector graphics with high print 

quality. 

2. They are widely used to draw maps, in scientific applications, and in CAD, CAM, and CAE. 

3. Architects use plotters to draw blueprints of the structures. 
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4. A plotter is basically a printer that interprets commands from a computer to make line 

drawings on paper with one or more automated pens. 

a. Drum Plotter 

@ In Drum plotters, the paper on which the design is to be printed is placed over a drum. 

@ These plotters consist of one or more pens that can make multicolor drawings. 

b. Flatbed Plotter 

@ In this, the paper is spread on the flat rectangular surface of the plotter, and the pen is 

moved over it. 

@ These are less expensive. 

 

MEMORY 

 
• Memory is a storage area in the computer which is used to store data and programs temporarily 

or permanently. 

• Computer memory can be divided into two groups. 

➢ Primary Memory 

➢ Secondary Memory 

• To execute a program, all the instructions or data that has to be used by CPU has to be loaded 

into main memory/primary memory/volatile memory. 

• The Secondary Memory stores data or instructions permanently, even when the power is 

turned off. It is cheap and store large volume of data. 

 

MEMORY HIERARCHY 

CPU Registers 

↓ 

Level 1 Cache 

↓ 

Level 2 Cache 

  ↓ 

Level 3 Cache 

↓ 

Primary Memory 

↓ 

Hard Disk 

↓ 

Optical Disk 

↓ 

Magnetic Tape 

CPU REGISTERS: 

1. CPU registers or processor registers are located in the processor and they are directly accessed 

by the CPU or processor. 

2. Each register can store a word of data which is either 32 bit or 64 bit. 

3. Registers are fast memory among the types of computer storages. 

 

1. What is a  CACHE MEMORY? 

2. Cache Memory is the intermediate form of storage between registers and RAM. 

3. The CPU uses cache memory to store instructions and data that are repeatedly required to 

execute programs. 
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4. Cache memory is basically a portion of memory that is made up of high speed static RAM 

which is more faster than dynamic RAM. 

 

5. Cache Memory is divided into number of levels based on location of cache inside the CPU. 
➢ Level-1 Cache:-Internal cache located inside the microprocessor. 

➢ Level-2 Cache:-Located on motherboard, outside microprocessor. 

➢ Level-3 Cache:-An extra cache – Large size – Slower Cache 

6. The CPU first checks whether the data or instructions available in cache memory. 

7. If it is not present in cache memory then CPU reads the data or instructions from the main 

memory and it place same copy of data or instructions into cache memory. 

 

2. What is a PRIMARY MEMORY? Explain its types? 

1. Primary Memory is the only type of memory that is accessed by the CPU. 

2. CPU continuously reads instructions stored in the primary memory and execute them. 

3. Any data that is to be operated by the CPU also stored in primary memory. 

4. As long as the continuous power is supplied to the computer the data or instructions present in 

primary memory are available. If the power is off then data or instructions present in primary 

memory will be lost. 

5. Primary Memory is also known as Main Memory / Temporary Memory / Volatile Memory. 

6. Main memory is divided into two types. 

a. RAM – Random Access Memory 

b. ROM – Read Only Memory 

 

RAM: 

1. RAM is a volatile storage within the computer that is typically used to store information 

temporarily. 

2. Information stored in RAM accessed by processor. 

3. RAM contains information related to applications that are currently being executed by the 

processor. 

4. There are two types of RAM. 

a. SRAM – Static RAM 

b. DRAM – Dynamic RAM 

Static RAM 
• This is a type of RAM that holds the data without an external refresh. 

• Static RAM is faster and more reliable than dynamic RAM. 

• Static RAM can be used as Cache Memory. 

• Static RAM occupies more space and more expensive. 

• This is most common type of memory used in PC.  

Dynamic RAM  
• It requires more refreshment than static RAM to hold the instruction. 

• It is slower than SRAM. 

• It is cheap and can hold more data. 

ROM: 

1. ROM refers to computer memory chip that contain permanent information or data. 

2. Data will be available in ROM even after the computer turned off. 

3. Most computers contain a small amount of ROM that stores critical programs such as Basic 

Input Output System (BIOS). 

4. ROM memory is slower than RAM. 

5. ROM is divided into several types. 
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PROM – PROGRAMMABLE READ ONLY MEMORY 
•      It is also called one time programmable ROM used to store permanent information. 

• ROM can be written for programmed by using a special device called PROM programmer. 

EPROM – ERASABLE PROM 
•      It is a type of ROM that can be erased and reprogrammed. 

•      The EPROM can be erased by exposing the chip by ultraviolet light. 

EEPROM – ELECTRICALLY EPROM 
• The contents in the EEPROM can be erased electrically and re-written electrically. 

• The process of writing data to EEPROM is called Flashing. 

• The Flash Memory is also a type of EEPROM which content can be erased by using 

software programs. 

 

3. What is a SECONDARY MEMORY? Explain its types? Or Explain SECONDARY 

STORAGE DEVICES? 

Secondary storage also known as external memory or auxiliary memory differs from main 

memory, in which contents not directly accessed by the CPU. 

The secondary storage device can store the data when the computer is turned off. 

MAGNETIC TAPE: 

Magnetic tapes are mass storage devices capable of storing large volume of data. 

1. These storage devices are basically used as sequential access storage devices. 

2. Magnetic tapes are available in the form of cassettes, reels and cartridges. 

3. Storage capacity of magnetic tape depends on length of the tape and density of tape. 

4. Data is represented in the form of non-magnetized and magnetized spots, where the presence 

of the spot represent 1 and absence represent 0. 

 

FLOPPY DISK: 

1. Floppy Disks are data storage devices that consist of thin magnetic storage medium to store the 

information. 

2. The storage capacity of floppy disk is very similar to as compared to CD and Flash drive. 

3. Floppy Disks were used in the mid 1970s to 2000. 

4. It is used to store software information or textual information. 

5. All 3.5 inch floppy disks contain 80 sectors 18 tracks per sector and can store 512 bytes per 

track. 2 X 80 X 18 X 512 bytes = 1.44MB 

 

HARD DISK: 

1. The hard disk is a part of computer that stores all the programs and information permanently. 

2. The hard disk provides relatively quick access to the large amount of information stored on an 

electromagnetically charged surface. 

3. A hard disk is basically a set of disks that has data recorded electromagnetically in circles 

known as tracks. 

4. Tracks are further divided into number of sectors. 

5. Data is actually stored on the surface of the platters in sectors and tracks. 

6. The performance of hard disk depends on its access time, which is the time required to read or 

write on the disk. 

7. Access time is a combination of following three components. 

8. Seek Time is the time taken to position the read/write head over the appropriate track. 

9. Rotational Time is the time taken to bring the target sector under the read/write head. 

10. Transfer Time is the time required to transfer the data to disk. 
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11. The sum of seek time and rotational delay is also known as latency. 

Note: 

Magnetic Tapes, Floppy disk and hard disk are also known as off-line storage.

OPTICAL DEVICES: 

1. Optical storage refers to storing data on an optically readable medium. 

2. Optical storage devices are most widely used devices to store information. 

3. The most optical devices are CD-ROM, DVD-ROM, CD-R, CD-RW. CD-ROM: 

CD-ROM 

1. Compact Disk Read Only Memory, is a type of optical disk that uses laser technology to read 

and write data onto the disk. 

2. A CD-ROM can store a large amount of data, but once the information is stored on it, it 

becomes permanent and cannot be altered. 

3. CDs are easily portable from one computer to another and therefore used to transfer data from 

one computer to another. 

DVD 

1. Digital Video Disk or Digital Versatile Disk(DVD) is a high capacity optical disk with storage 

capacity ranging from 4.7 GB to 17 GB. 

2. A standard DVD can store seven times more data than a CD because of its multi-layer storage. 

3. DVDs are widely used to store large databases, movies, music, complex software etc. 

CD-R: 

1. Compact Disk Recordable is a blank disk that is used to store information. 

2. The process of writing data on the optical disk is called burning. 

3. However once data is written on the disk it cannot be changed. 

4. Users can use it to store their databases, software, projects, assignments etc. 

 

 CD-RW: 

1. Compact Disk rewritable is a new generation of erasable optical disk. 

2. The user can write and over write data on the CD-RW disk multiple times. 

3. Both CD-R and CD-RW can be used for taking backup of important data. 

 

USB FLASH DRIVES: 

                     USB flash drives are removable, rewritable, and are physically much smaller drives. 

USB devices are a good substitute for floppy disks and CD-ROMs as they are smaller, faster, have 

thousands of times more capacity, and more durable and reliable. 

Operating Systems can read and write to flash drives without installing device drivers.
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SOFTWARE 

 

 

 

                                                       COMPUTER SYSTEM 

 

 

 

  

                                              HARDWARE                 SOFTWARE 

  

 

 

 

 

 
• Computer Hardware, which is constituted by the physical components of a computer. 

• Computer Software, which tells the hardware what to do and how to do it. 

 

SOFTWARE: 

Software is a program or set of programs which is used to perform a particular task. The main 

objective of the software is to enhance the capabilities of the hardware. 

Computer software can be broadly classified into two groups: application software and system 

software. 

 

SYSTEM SOFTWARE: 

1. System software or system package are set of one or more programs that are basically designed 

to control the operations of a computer system. 
• Operating System 

• Language Translators 

• System Utilities 

2. System Software is a collection of programs that enable the users to efficiently interact with the 

hardware components. 

3. System software controls and manages the hardware and is machine dependent.  

Operating System: The main goal of an operating system is to make the computer system 

convenient and efficient to use. 

Language Translators: The main goal of language translators is to convert the high-level 

programming languages into machine level or machine understandable. Assembler, Interpreter, 

compiler are the examples for language translators. 

System Utilities: Utility software is used to analyze, configure, optimize, and maintain computer 

system. Utility programs may be requested by application programs during execution. 

 

APPLICATION SOFTWARE: 

1. Application software is a type of computer software that employs the capabilities of a computer 

directly to perform a user-defined task. 

2. Application software tells the computer how to accomplish specific tasks, such as word 

processing or drawing, for the use. Some of the major categories of application software are 

a. Word processing software for creating text-based document. 

SYSTEM SOFTWARE 

                

APPLICATION 

 SOFTWARE 
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b. Spreadsheets for creating numeric-based documents such as budgets or balance sheets. 

c. Database Management software for building and manipulating large sets of data, such as 

names, addresses and phone numbers etc. 

d. Presentation programs for creating and presenting electronic slide shows. 

e. Graphics programs for designing illustrations. 

f. Multimedia authoring applications for building digital movie. 

g. Entertainment and education software. 

h. Web design tools and web browsers. 

i. Games for single player and multiple players.

 

COMMERCIAL SOFTWARE: 

1. Commercial software is any software or program that is designed and developed for licensing or 

sale to end user. 

2. Off-the-shelf software programs such as games or those sold in computer specialty stores or even 

music stores are some examples of commercial software. 

3. Microsoft products such as Microsoft Windows operating system and MS Office are some of the 

most well known examples of commercial softwares. 

 

OPEN SOURCE SOFTWARES: 

        Open source software refers to software that is developed, tested, or improved through public 

collaboration and distributed with the idea that must be shared with others. 

FREE WARE SOFTWARE: 

1. Freeware is programming that is offered at no cost and is a common class in most operating 

systems. 

2. The least restrictive no-cost programs are un copyrighted programs that are in the public domain. 

FIRMWARE: 

1. Firmware is the set of programs that is stored on a computer or other hardware device’s 

Read Only Memory that provides instruction on how that device should operate. 

2. Firmware cannot be changed or deleted by an end-user without the aid of special programs and 

remains on that device whether or not it is on or off. 

3. Without firmware, a hardware device would be non functional. Without firmware as backbone, no 

software can run. 

4. Firmware does not disappear when hardware is powered off. 

MIDDLEWARE: 

1. Middleware is the software that facilitates exchange of data between two application programs 

within the same environment, or across different hardware and network environment. 

2. The basic types of middleware are 

a. Communication middleware 

b. Database middleware 

c. System middleware 

3. Middleware often sits between the operating system and application on different servers and 

simplifies the development of applications that leverage services from other applications. 

PUBLIC DOMAIN SOFTWARE: 

1. Public domain software refers to software that is not limited by having a copyright. It can be freely 

used, copied or altered because no one owns the right to restrict its use. 

2. Public domain software is the only type in most cases to which no limitations apply. 

3. Mostly, it is free and is available along with the source code. Users can download it and start 

working immediately.



                                                                                                                                      
                                                                                                                                   COMPUTER FUNDAMENTALS AND PHOTOSHOP 

29 
 

 

WINDOWS BASICS: 

 

Start Menu: 

 

1. In the bottom, left corner of the windows desktop, you will see a small blue circle with a multi-

colored flag inside called Start Button. 

2. It is used to launch a Start menu that can be used to launch applications, open documents, 

change system setup, search for files and folders, and log off, restart, and shut down your computer. 

 

 

 

 

Computer: 

My Computer is a section of Microsoft Windows first found in Windows 95 and included with 

all later versions that allows you to explore and manage the contents of your computer drives. The 

picture below shows examples of the My Computer icon in Microsoft Windows XP, Vista and 

Windows 7, as well as the "This PC" icon in Windows 8 and in Windows 10. Although the name has 

changed, "This PC" still has the same functionality as "My Computer". 

 

Desktop: 
• Desktop refers to the environment, which is a Graphical User Interface that allows for 

interaction between the user and the operating system. 

• Desktop is a utility that allows users to manage applications. 

• Desktop is a system of organization of icons on a screen. It was first introduced in Windows 95 

and has been included in every version of windows. 

Documents: 

Documents are Microsoft Windows folders that store computer documents and other files 

associated with programs on your computer. For example, when saving a file in Microsoft Word, the 

default folder is My Documents. Saving all of your personal files into the My Documents folder makes 

them easier to backup and locate. 

Microsoft has changed “My Documents” to “Documents” in the most recent versions of windows. 

Pictures: 

             Pictures is a folder in the Microsoft Windows operating system that is used to store picture 

files. By default, when any picture is created or added to a Windows computer, they are saved in the 

My Pictures folder. In later versions of Windows, My Pictures is just called as Pictures.

Music: 

Music is a folder in the Microsoft Windows operating system that is used to store Music files. 

By default, when any music is added to a Windows computer, they are saved in the My Music folder. 

In later versions of Windows, My Music is just called as Music 

Videos: 

Videos is a folder in the Microsoft Windows operating system that is used to store Video files. 

By default, when any video is created or added to a Windows computer, they are saved in the Videos 

folder. 

Recycle Bin: 

• Recycle Bin is a location where deleted files are temporarily stored in every version of 

Microsoft Windows since Windows 95. 

• The Recycling Bin allows users to recover files that have been deleted in Windows. It can be 

found on the Desktop. 

http://www.computerhope.com/jargon/w/win95.htm
http://www.computerhope.com/jargon/d/drive.htm
http://www.computerhope.com/jargon/x/xp.htm
http://www.computerhope.com/jargon/v/vista.htm
http://www.computerhope.com/jargon/w/windows7.htm
http://www.computerhope.com/jargon/w/windows8.htm
http://www.computerhope.com/jargon/w/windows-10.htm
http://www.computerhope.com/jargon/w/windows.htm
http://www.computerhope.com/jargon/w/word.htm
http://www.computerhope.com/jargon/w/word.htm
http://www.computerhope.com/jargon/f/folder.htm
http://www.computerhope.com/jargon/d/delete.htm
http://www.computerhope.com/jargon/w/windows.htm
http://www.computerhope.com/jargon/r/recover.htm
http://www.computerhope.com/jargon/d/desktop.htm
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Taskbar: 

• A bar located at the bottom of the screen first introduced with Microsoft Windows 95and found 

in all the versions of Windows that followed. 

• The Taskbar allows the user to locate and launch programs through the Start button or view any 

program that is currently open. 

• It also allows them to check the date and time, items running in the background through the 

System tray, and with subsequent versions of the Windows operating system, the Quick 

Launch. 

Control Panel: 

• The Control Panel is a section of Microsoft Windows that enables a user to change various 

computer hardware and software features. 

• Settings for the mouse, display, sound, network, and keyboard represent just a few examples of 

what may be modified in the Control Panel.

http://www.computerhope.com/win95.htm
http://www.computerhope.com/jargon/s/start.htm
http://www.computerhope.com/jargon/n/notiarea.htm
http://www.computerhope.com/jargon/q/quiclaun.htm
http://www.computerhope.com/jargon/w/windows.htm
http://www.computerhope.com/jargon/m/mouse.htm
http://www.computerhope.com/jargon/d/display.htm
http://www.computerhope.com/jargon/s/sound.htm
http://www.computerhope.com/jargon/network.htm
http://www.computerhope.com/jargon/k/keyboard.htm
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UNIT-III 

INTRODUCTION TO ADOBE PHOTOSHOP 

 

INTRODUCTION: 

1. What is a Photoshop? 

 

1. Adobe Photoshop is an image editing software, used for creating, editing, and retouching up, and 

special effects to photographs. 

2. If you want to perform the above operation in manual it takes hours or days but by using 

Photoshop it takes few  minutes 

3. Image editing is the process of taking an image and changing it pixel by pixel. 

4. By using Photoshop you can manipulate thousands of different colored pixels which together make 

up an image. 

5. You can change the brightness, contrast and colors of you images, and combining several images. 

 

GETTING STARTED WITH PHOTOSHOP 

 

2. Explain the Photoshop application Window? 

 

1. On the Desktop double click the Adobe Photoshop icon to start Adobe Photoshop. 

2. If you didn’t see the Photoshop icon on your desktop, choose 

Start →All Programs → Adobe Photoshop 7.0. Then it will launch Photoshop Window. 
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The Adobe Photoshop work area includes menus, toolbars, and palettes that give you quick access to a 

variety of tools and options for editing and adding elements to your image. You can also add commands 

and filters to the menus by installing third-party software known as plug-ins. 

1. The default workspace in Photoshop consists of the menu bar and options bar at the top of the screen, 

the Tool Box on the left, and several open palettes on the right. 

2. When you have documents open, one or more image windows also appear, and you can display them 

at the same time using the tabbed interface. 

3. The Photoshop user interface is very similar to the one in Adobe Illustrator, Adobe InDesign, and 

Adobe Flash. So learning how to use tools and palettes in one application means the you’ll know how 

to use them in the others. 

  

MENU BAR: 

1. The menu bar is a collection of menus, present at the top of the Photoshop window. 

2. Each menu is a collection of commands displayed as dropdown menu. 

 

OPTIONS BAR: 

1. Options bar is a collection of options displayed right below the menu bar. 

2. Options bar displays the options for the currently-selected tool. 

 

IMAGE WINDOW: 

1. Image window displays the current image. The name of the image will be displayed at the top edge of 

the image window called image title bar. 

2. If rulers are turned on they appear at the top and left edges of the image window. Left ruler is called 

vertical ruler and top ruler is called horizontal ruler. 

3. To display or hide rulers choose keyboard short cut key Ctrl+R or select View →Rulers. 

4. Rulers show the size of your image. To change the unit of measurement double click on ruler or go to 

Preferences (Edit→Preferences→Units & Rulers…). 

 

TOOL BOX: 

1. Tool box is a collection of tools that works with images in Photoshop. 

2. You can select only one tool at any given time. 

3. To select a tool, click on the its icon in the tool box by using mouse or use keyboard short cut key 

relevant to that tool. 

 

STATUS BAR: 

1. The status bar will be displayed at the bottom of the Photoshop window. 

2. Status bar provides information about your current view and other information. 

PALETTES: 

 

1. Palettes enable you to perform a wide variety of tasks in Photoshop. 

2. To display or hide particular palette go to the window menu and choose a palette name. 

3. Palettes are usually organizes into groups. You can easily move a palette group by dragging its blue 

bar that is displayed at the top of the group. 

4. To shrink a palette group double click on its blue bar, to hide a palette group click its close button. 

5. You can drag the tabs of palettes to move them around or to combine them into other group. 
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GUIDES & GRIDS: 

1. Guides appear as lines that float over the entire image and do not print when printed. You can 

remove, move or lock a guide to avoid accidentally moving it. 

2. A Grid appears by default as non printing lines but can also be displayed as dots. The Grid is useful 

for laying out elements properly on the image window. 

3. Choose view→Show→Grid/Guide to show or hide a grid or guide 

 

. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.      How to CREATE A NEW PHOTOSHOP FILE? 

1. To create a new document in Photoshop goto File menu and select New or press keyboard short cut 

key Ctrl+N 

2. It will launch new dialog box as shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Name: 

The Name filed is a text box where you can add a name to your new document. The name 

should be helps to identify the file. If you didn’t add a name it will take default name as Untitled-1. 
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  Preset: 

         The preset field is used to choose your document size on a provided preset or you can create your 

own custom size. 

 

        Size: 

1. If you choose Custom as your Preset, then you will didn’t see this option. 

2. You need to provide width and height values if you choose Custom as your Preset value. 

3. If you select U.S.Paper as Preset value you will see common U.S.Paper sizes such as Letter, Legal and 

Tabloid sizes. 

4. Use pre-determined sizes of Preset values if you are unsure of a good size for your document. 

 

      Width & Height: 

1. If you didn’t select a Preset value and choose custom size, then this is where you can type in your 

desired document width and height. 

2. You may change the units by clicking the dropdown menus beside the width and height values. 

            

       Resolution: 

1. Resolution is the key factor that determines the quality of the image and refers to the number of pixels 

per inch of an image. 

There are three types of media. 

a. Print Media  300 dpi 

b. Multi Media  200 dpi 

c. Web Media  100 or 72 dpi 

 

       Color Mode: 

1. Color mode allows you to choose what mode and bit you wish to use for your new document. 

2. CMYK (Cyan, Magenta, Yellow, Black) refers to print colors and is generally used for images that 

will be printed. 

3. RGB (Red, Green, Blue) refers to the dot colors and is intended for the use of web, video, or any 

digitally displayed image. 

 

       Background contents: 

1. This allows you to determine the color of your Background layer. 

2. You can choose White or Transparent will make your layer respectively white or transparent. 

3. Choosing background color will change the layer color to your selected background color. 

 

       Color Profile: 

If you are using a color-managed workflow or want to use a color profile of a specific device or color 

space, you may select that profile from this dropdown. 

 

        Pixel Aspect Ratio: 

The pixel aspect ratio is useful for those who are creating graphics to be used for video work that is not 

HD or does not use square pixel. 

 

       Image size: 

Image size refers to the file size of your new document. This number is measures in bytes, kilo bytes, 

mega bytes and giga bytes. 
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4. Give the steps for saving a document in Photoshop? 

1. Go to file menu and select save option. 

2. It will display ―Save As‖ dialog box. 

 

 

 

 

 

 

 

 

 

 

 

 

3. In the save as dialog box first select the location where the document will be save in your 

computer. 

4. Type the name of the file name. 

5. Choose format for your image such as JPEG / TIFF / Photoshop, etc. 

6. After using required options in the dialog box press ―SAVE‖ push button. 

7. Photoshop file will be saved. 

 

5. Explain Tool box in Photoshop? 

The toolbox contains selection tools, painting and editing tools, foreground and background 

color selection boxes, and viewing tools. 

Rectangular Marquee Tool (M): 

Use this tool to make selections on your image, in a rectangular shape. This changes the area 

of your image that is affected by other tools or actions to be within the defined shape. Holding 

the [Shift] key while dragging your selection, restricts the shape to a perfect square. Holding 

the [Alt] key while dragging sets the centre of the rectangle to where your cursor started. 

 

Move Tool (V): 

 

Use this tool to, well, move things. Usually you use it to move a Layer around after it has 

been placed. Hold the [Shift] key to limit the movements to vertical/horizontal. 

 

Polygon Lasso Tool (L): 

Use this to draw selections in whatever shape you would like. To close the selection, either 

click on the beginning point, or just double-click. When holding the [Ctrl] key, you‘ll see the 

cursor change, and the next time you click, it will close your selection. 

 

Magic Wand Tool (W): 

Use this to select a color range. It will select the block of color, or transparency, based on 

wherever you click. In the Options Bar at the top, you can change the Tolerance to make 

your selections more/less precise. 
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Polygon Lasso Tool (L): 

Use this to draw selections in whatever shape you would like. To close the selection, either 

click on the beginning point, or just double-click. When holding the [Ctrl] key, you‘ll see the 

cursor change, and the next time you click, it will close your selection. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Crop Tool (C): 

The Crop Tool works similarly to the Rectangular Marquee tool (see above if you have no 

short-term memory). The difference is when you press the [Enter/Return] key; it crops your 

image to the size of the box. Any information that was on the outside of the box is now 

gone. Not permanently, you can still undo. 

Slice Tool (K): 

This is used mostly for building websites, or splitting up one image into smaller ones when 

saving out. It‘s kind of an advanced tool, and since you‘re in here for the basics, we‘ll kind 

of skip over it. 

 

Healing Brush Tool (J): 

You can use this tool to repair scratches and specs and stuff like that on images. It works like 

the Brush tool. You choose your cursor size, then holding the [Alt] key, you select a 

nice/clean area of your image. Let go of the [Alt] key and paint over the bad area. It basically 

copies the info from the first area to the second, in the form of the Brush tool. 

Brush Tool (B): 

It paints one your image, in whatever color you have selected, and whatever size you have 

selected. There are a lot of options for it, but this is basic, so you don‘t get to learn them. 

 

Clone Stamp Tool (S): 

This is very similar to the Healing Brush Tool. You use it the exact same way, except this 

tool doesn‘t blend at the end. It‘s a direct copy of the information from the first selected area 

to the second. 
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History Brush Tool (H): 

This tool works just like the Brush Tool except the information that it paints with is from the 

original state of your image. The History Brush tool paints with the information from 

whatever History state is selected. 

 

Eraser Tool (E): 

This is the anti-Brush tool. It works like an eraser and erases whatever information wherever 

you click and drag it. If you‘re on a Layer, it will erase the information transparent. If you 

are on the background layer, it erases with whatever secondary color you have selected. 

 

Gradient Tool (G): 

You can use this to make a gradation of colors. Gradation doesn‘t appear to be a word, but it 

makes sense anyway. It creates a blending of your foreground color and background color 

when you click and drag it. Like a gradient. 

 

Blur Tool (R): 

 

The Blur tool is cool. It makes things blurry. Click and drag to make things blurry. The more 

you click and drag, the blurrier things get. 

 

Dodge Tool (O): 

 

This tool isn‘t as crappy as the car brand. It‘s actually used to lighten whatever area you use 

it on. As long as it is not absolute black. Absolute black won‘t lighten. 

 

Path Selection Tool (A): 

 

You use this tool when working with paths. Since this is all about the basics, I won‘t go into 

details. It‘s related to the Pen Tool though. 

 

 

Horizontal Type Tool (T): 

 

It makes type. You can click a single point, and start typing right away. There are a lot of 

options for the Type Tool. Just play around, it‘s fairly straight-forward. 

 

Pen Tool (P): 

 

It‘s for creating paths, in which you would use the Path Selection Tool to select the path. 

You use the tool by clicking to add a point. If you click and drag, it will change the shape of 

your path, allowing you to bend and shape the path for accurate selections and such. 

 

 

Rectangle Tool (U): 

 

By default it draws a Shape Layer in the form of a rectangle. It fills the rectangle with 

whatever foreground color you have selected. It‘s pretty complicated; don‘t hurt yourself 

with this one. 
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Notes Tool (N): 

Like post-it notes, but digital. You can use this tool to add small little note boxes to your 

image. These are useful if you‘re very forgetful or if you‘re sharing your Photoshop file 

with someone else. 

 

Eyedropper Tool (I): 

 

This tool works by changing your foreground color to whatever color you click on. Holding 

the [Alt] key will change your background color. 

 

Hand Tool (T): 

It‘s for moving your entire image within a window. So if you‘re zoomed in and your image 

area is larger than the window, you can use the Hand Tool to navigate around your image. 

Just click and drag. You can get to this tool at any time when using any other tool by 

pressing and holding the [Spacebar]. 

Zoom Tool (Z): 

It allows you to zoom into your image. Hold the [Alt] key to zoom out. Holding the [Shift] 

key will zoom all of the windows you have open at the same time. Double-click on the 

Zoom Tool in the palette to go back to 100% view. 

 

Background colour: 

 

These are your color boxes. Foreground (in the front) and Background (in the back). Click 

on either one to bring up the color select dialog box. 

 

 

6. Explain IMAGE FILE FORMATS? 

                                        You can save the files in DNG format, JPEG, TIFF and PSD. All of these 

formats can be used to save RGB and CMYK color modes. All of these formats except DNG are also 

available in the Photoshop Save and Save As dialog boxes.DNG-Adobe Digital Negative format 

contains raw image data from a digital camera and metadata that defines what the image and data 

means. It an industry-wide standard format for raw image data. 

1. JPEG-Joint Photographic Expert Group file format is commonly used to display photographs. Higher 

resolution JPEG files may be used for other purposes, including high quality printing. The greater the 

compression, the lower the image quality. 

2. TIFF-Tagged Image File Format is used to exchange files between applications and computer 

platforms. TIFF is a flexible format supported by virtually all paint, image-editing and page layout 

applications. All desktop scanners can produce TIFF images. 

3. PSD-Photoshop Document format is the Photoshop native file format. Because of tight integration 

between Adobe Products you can directly import PSD files and preserve many Photoshop features. 

5. GIF-Graphic Interchange Format used to display limited color graphics on the web. It is a compressed 

format that reduces the file size of images, only support limited colors.                           

6. EPS-Encapsulated Post Script is a common file format used in print production, most graphics software 

programs support EPS format.                                                                                                                        

7. PNG-Portable Network Graphics is an alternative to GIF for displaying images in Web. It uses lossless 

compression. 
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7. Explain SCREEN MODES in Photoshop? 

                                    A screen mode controls how much of the interface is displayed on screen, ranging 

from a standard mode that displays the entire interface to a full screen mode that hides everything but the 

image itself. 

To select different screen modes press key F from the keyboard. You will see three options. 

1. Standard Screen Mode 

2. Full Screen Mode with Menu bar 

3. Full Screen Mode 

Standard Screen Mode: 

1. Standard screen mode is the default screen mode in Photoshop. 

2. It display the entire interface including Tool bar on left side, palettes on the right side, menu bar and 

options bar at the top of Photoshop Window, scroll bars and other information. 

3. If you want your image to be fit on screen size you need to zoom the image it leads to blocking our 

view especially on smaller displays running at lower screen resolutions. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Full Screen Mode with Menu Bar: 

 

1. If you want to give yourself a bit more room to work, you can switch to the second of 

Photoshop’s three screen modes known as Full Screen Mode with Menu Bar. 

2. You can select screen mode by pressing F key through keyboard or you can select screen mode option 

from view menu and select required screen mode. 

3. Another way is to select required screen mode from tool bar. 

4. This screen mode hides any interface elements that were part of the document window itself like 

image window title bar, scroll bars and zoom level etc. 

5. If you open multiple images in separate tabbed documents, only the active document remains visible. 

The others are hidden from view. 

6. All the interface elements remain same as standard screen mode. 

Full Screen Mode: 

1. To fully maximize your work area, switch to the third of Photoshop’s three screen modes known as 

Full Screen Mode. 

2. You can select it from tool bar or by pressing F key from keyboard or from Full screen mode option 

from view→screen mode. 
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3. If you select this mode for first time it will prompt a dialog box explaining the basics of how full 

screen mode works. 

4. In this mode the interface is completely hidden, leaving just the image itself visible, turning your 

entire screen into work area. 

SAVING FILES: 

1. Adobe Photoshop allows you to save your files in a variety of file formats, which makes it possible 

to use your images in many different ways. 

2. Photoshop allows you to save your files more than ten unique file formats. 

Save in TIFF: 

a. Choose File→Save As, choose TIFF from the Format menu and select save. 

b. Choose Bit depth as 32-bit only. 

Save in JPEG: 

a. You can save CMYK, RGB, and grayscale images in JPEG. 

b. Choose File→Save As, choose JPEG from the Format menu and select save. 

c. You can also save an image as one or more JPEGs using File→Export→Save for Web. 

d. JPEG supports only 8-bit images. If you select higher bit value Photoshop automatically 

lowers the bit depth. 

Save in PNG: 

a. You can save RGB, Indexed Color, Grayscale, and Bitmap mode images in PNG format. 

b. Choose File→Save As, choose PNG from the Format menu and select save. 

c. Select an Interlace option. 

d. If you select none, it displays the image in a browser only when download is completed. 

e. If you select Interlaced, it display low resolution version of image in browser as the file 

download. 

Save in GIF: 

a. You can save RGB, Indexed Color, Grayscale, and Bitmap mode images directly in GIF 

format. The image is automatically converted into Indexed Color mode. 

b. Choose File→Save As, choose GIF from the Format menu and select save. 

c. For RGB images specify the conversion options and select a row order for the GIF file. 

d. If you select normal it displays the image only in a browser when download completed. 

Save in EPS: 

a. Virtually all page-layout, word processing and graphics applications accept imported or 

placed EPS (Encapsulated Post Script) files. 

b. To print this kind of files use a post script printer. 

c. Choose File→Save As, choose EPS from the Format menu and select save. 

 

 8.    How to reverting files in Photoshop? 

The word revert means to return to something earlier or to go back. While changing an image in 

the Photoshop, do you want to cancel the previous step and get the image into the previous state then you 

can use revert option in the file menu. 

Follow the below steps to know how to use revert option: 

1. Open an image 
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2. Make changes in the original image. 

 

 

 

 

 

 

 

3. To revert (kept the image in the previous state), then click revert option in the file 

menu. 

4. You can see that the last action you have used on the image will be reverted. 

5. You can use revert option until you reached the image in original stage. 

 

 

 

 

 

 

 

 

    9. How to close files in Photoshop? 

To close the Photoshop document, follow the below steps: 

1. To go file menu and select ‗close‘option. 

2. It displays the following dialog box. 

 

 

 

 

 

 

3. The above dialog box means Photoshop don‘t lets you close the Photoshop file until saving the 

changes made by you. 

4. If you want to close the document with changes made by you then press ‗yes‘push button. 

5. If you want to close the document without changes made by you then press ‗no‘push button. 

6. To close this dialog box then press ‗cancel‘button. 
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UNIT-IV 

IMAGES & TOOL BOX 

 

Working with Images: 

1. How to open an image in Photoshop? 

Loading an Image into Photoshop: 

We can load an image into Photoshop in three different ways. 

1. File → Open 

2. By using Keyboard short cut key Ctrl + O 

3. By double clicking on workspace 

                               By performing any one of the above three actions you will get Open dialog box. From the 

open dialog box select image location and select an image you want to load. 

 

2. Explain Image size and Resolution in Photoshop? 

Resolution is a number of pixels on a printed area of an image. The higher the resolution, the more pixels 

there are on the page, the better is the quality of the image. 

However, high resolution increases the size of the image. The standard resolution for printed images is 150-

300, for web images – 72-100. 

You may need high resolution images for printing. To change the image resolution in Adobe Photoshop 

follow the instructions. 

1. Select the command Image Size from the Image menu. 

2. Select the option Resample Image, if you want to keep image dimensions. 

If you want to keep the total amount of pixels (Pixel Dimensions), you should uncheck this option. 

In this case the width and the height will change in such a way that the total amount of pixels will 

stay the same. 

3. Enter a new value for resolution into the field Resolution which defines how many pixels per inch 

your image will have. 

4. Select OK. Then your image height and width will be changed according to the new values. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Size and resolution are inversely related.Changes in one effect changes in the other. 

3. Explain Image Editing in Photoshop? 

Cropping: 

1. Cropping is one of the most basic editing techniques that can improve your images. 

2. Cropping helps to bring out the most important features in your image and focus the viewer’s 

attention on these features. 
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3. Cropping also allows you to make your image a standard photo size. 

Resizing: 

1. Resizing in Photoshop can help you print your images in standard photo size, resize and preserve the 

high quality of digital photos, and enlarge small images to a poster size. 

Correcting: 

1. Digital cameras tend to cause various problems, such as “red eye” or “hot spots”, if you use flash, or 

underexposure, if you don’t. 

2. In Photoshop, you can correct these problems, as well as adjust the overall color of your digital 

photo. 

Color Adjustment: 

Color adjustment options in Photoshop help you to make your digital photos look more natural. 

Sharpening/Softening: 

1. If your digital photos are slightly out of focus, you can use the basic sharpening technique to make 

your images look crisper. 

2. Sometimes you might not want objects or people in your photos look too sharp, in this case you can 

use a softening technique. 

 

4. Explain various Color Modes in Photoshop? 

A color mode determines the color model used to display and print images.There are various types of 

color modes through which one can work in Photoshop. RGB Color Model: 

1. One of the most prominent color modes in Photoshop and the other graphic software is the RGB 

Color Mode. 

2. RGB refers to Red(R), Green(G) and Blue(B) which are also known as primary colors. 

3. RGB is a standard color model, the exact range of colors represented can vary, depending on the 

application or display device. 

4. RGB images use three colors or channels to reproduce colors on screen. 

 

CMYK Color Model: 

1. CMYK refers to Cyan(C), Magenta(M), Yellow(Y) and Black(K) which are also known as 

secondary colors. These are formed by mixing the primary colors. 

2. CMYK is a standard color model, the exact range of colors represented can vary, depending on the 

press and printing conditions. 

3. CMYK color scheme is generally used when the image or graphic created is to be printed on paper.  

 

GRAYSCALE Model: 

1. Grayscale mode is used when the images to be created are in black and white. 

2. You can convert both bitmap and color images to grayscale. 

3. To convert a color image to a high quality grayscale image, Photoshop discards all color information 

in the original image. 

 

LAB Color Model: 

1. LAB color model consists of a luminance or lightness component (L) and two chromatic 

components: 

“A” component (from green to red) and “B” component (from blue to yellow). 

2. LAB color model is the intermediate color model, Photoshop uses when converting from one color 

mode to another. 

3. LAB color model is designed to be device independent, creating consistent color regardless of the 

device used to create or output the image. 

4. Luminance =100 represents white color and Luminance=0 represents black color. 
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5.  Explain Color Adjustments or Color Manipulations? 

You can choose from the following color adjustment commands. 

1. Adjust Levels Auto: Quickly corrects the color balance in an image. You can select this option from 

Image→Adjustments→AutoLevels. 

2. Levels Command: Adjust color balance by setting the pixel distribution for individual color 

channels. You can select this option from Image→Adjustments→Levels. 

3. Curves Command: Provides control point adjustments for individual channels. 

 

 

 

 

 

 

 

 

 

 

You can select this option from Image→Adjustments→Curves. 

4. Color Balance Command: Changes the overall mixture of colors in an image. This method is used 

based on the principle of Complementary Colors. 

If Cyan cast is more, then drag the slider towards Red. 

If the Green cast is more, then drag the slider towards Magenta. If the Blue cast is more, then drag 

the slider towards Yellow. 

You can select this option from Image→Adjustments→Color Balance. 

 

 

 

 

 

 

 

 

 

 

 

 

5. Hue/Saturation Command: Adjust the hue, saturation, and lightness values of the entire image or 

of individual color components. 

Image shade or some selective area shade can be changed by using Hue/Saturation option. By 

changing the Hue slider one can change shade of colors. 

By changing the Saturation slider one can change color percentage. 
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You can select this option from Image→Adjustments→Hue/Saturation. 

6. Match Color Command: Matches the color from one photo to another photo, from one layer to 

another layer, and from a selection in an image to another selection in the same image or a different 

image. 

You can select this option from Image→Adjustments→Match Color. 

7. Replace Color Command: Replaces specified colors in an image with new color values. You can 

select this option from Image→Adjustments→Replace Color. 

 

 

 

 

 

 

 

 

 

 

 

8. Selective Color Command: Adjusts the amount of process colors in an image with new 

color values.You can select this option from Image→Adjustments→Selective Color. Change the 

sliders Cyan, Magenta, Yellow, Black to change the selected color. 

 

 

 

 

 

 

 

 

 

9. Channel Mixer Command: Modifies a color channel and makes color adjustments not easily done 

with other color adjustment tools. 

You can select this option from Image→Adjustments→Channel Mixer. 
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6. Explain Zooming & Panning an Image in Photoshop? 

ZOOMING: 

           We can get the information about current zoom level in the bottom left corner of the document 

window. 

Here we can change the zoom level by simply clicking inside the box and typing in a new one. 

Zoom using View Menu Commands: 

1. Photoshop View menu offers different zooming options. 

2. We find standard Zoom In and Zoom Out commands in View menu. 

3. We also find the Fit on Screen command, which tells Photoshop to zoom to whatever level it needs 

to fit the entire image on the screen at once. 

4. Actual Pixel command which zoom the image to a fill 100% view size. 

Zoom using the Zoom Tool: 

1. The easiest and most popular way to zoom in and zoom out of images in Photoshop is with the Zoom 

Tool. 

2. It is the tool with the magnifying glass icon near the bottom of the tool bar. 

 

3. Select Zoom Tool by clicking on tool icon or by pressing Z keyboard short cut key. 

4. Then just click on the area of the image that you want to zoom in. 

Zooming using Keyboard Shortcut Keys: 

1. The faster and more convenient way to use Zoom Tool is with the Keyboard Shortcut. 

2. First you need to select the Zoom In using Ctrl + Spacebar on your keyboard. This will activate 

Zoom In mode. 

3. You need to hold the key and click on image, it will increase the Zoom level. 

4. To Zoom out, hold down Alt + spacebar and click on the image to Zoom out. 

 

PANNING: 

The problem with zooming is that we can only see some part of an image. The rest of the image can’t 

be viewed in document. We need a way to drag the image around inside the document window. This is 

known as panning an image and this can be achieved by using Hand Tool. 

7. Explain Rulers? 

1. Rulers are used to find the dimensions of an image. 

2. You can activate rulers by selecting Rulers option from View Menu or by using Keyboard short key 

Ctrl + R. 

3. You can change the ruler units by double clicking on the ruler. If you double click on ruler it will 

open a dialog box as shown below. 
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8. Explain Guides and grids? 

Guides: 

                  Guides and the grid help you position images or elements precisely. Guides appear as nonprinting 

lines that float over the image. You can move and remove guides. You can also lock them so that you don‘t 

move them by accident. 

1. To use guides, go to view menu and select rulers option 

2. Rulers will appear in your image. 

3. To set horizontal ruler, then move your mouse pointer to horizontal ruler. 

4. Click the mouse left button and control button on the horizontal ruler. 

5. Drag your mouse. 

6. A horizontal guide will appear. 
7. For vertical guide move your mouse pointer to vertical ruler. 

8.Click the mouse left button and control button on the vertical ruler. 

9.Drag your mouse. 

10.A vertical guide will appear. 

Grid: 

The grid is useful for laying out elements symmetrically. The grid appears by default as nonprinting lines 

but can also be displayed as dots. To use grids, go to view menu and select show option, a sub menu will 

appears, in the sub menu select grid option, grids will automatically appears in your image. 

 

 

 

 

 

 

 

 

 

9. Explain the Concept of CROPPING & STRAIGHTENING AN IMAGE in Photoshop? 

There are several ways to crop images in Adobe Photoshop. 

1. Cropping with Crop Tool 

2. Cropping to a specific size 

3. Cropping with the Marquee Tool 

 

CROPPING WITH CROP TOOL: 

                        The Crop Tool allows you to make a precise selection of an image you wish to edit. To Crop 

with the Crop Tool, follow these steps. 

1. Open the image you wish to crop. 

2. Select the Crop Tool from the Toolbox. 

3. Click on your image once and drag the mouse out to make a cropping border. 

4. Resize the border by dragging the squares at the sides and corners till you are satisfied with the way 

your image looks. 

5. You can also rotate your cropping border. Move the cursor outside the border, you will see how it 

turns into a double-headed arrow. Drag the arrows in the directions you wish to rotate your selection. 

6. Once you are completely satisfied with your cropped image, press ENTER. 

 

CROPPING TO A SPECIFIC SIZE: 

                         If you wish to print your digital photos on standard size photo paper, you will have to crop 

your images to a specific size, such as 8X10. To Crop an image to a specific size, do the following steps. 
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1. Open the image you wish to Crop. 

2. Select the Crop Tool from the Toolbox. 

3. In the Options bar, specify the values for Width and Height. 

4. Click in your image and drag the cropping border. Notice that the border is constrained – you cannot 

make it wider or longer than the specified values. 

5. Once you are completely satisfied with your cropped image, press ENTER. 

 

CROPPING WITH THE MARQUEE TOOL: 

                      If you need just a simple crop, you can use the Marquee Tool and a menu command. To crop 

with the Marquee Tool, follow the steps below: 

1. Open the image you wish to crop. 

 

2. Select the Rectangular Marquee Tool from the Toolbox. 

3. Click in your image and drag the mouse to draw a marquee around the area you wish to crop. 

4. In the main menu, go to Image→Crop. The image will be immediately cropped. 

 

10. Explain how to MAKE SELECTIONS in Photoshop? 

You can make selections in Photoshop by using the following tools. 

1. Rectangular Marquee Tool 

2. Elliptical Marquee Tool 

3. Lasso Tool 

4. Polygonal Lasso Tool 

5. Magnetic Lasso Tool 

6. Magic Wand Tool 

 

 

 

 

 

 

Rectangular Marquee Tool: 

 

1. This Tool is used to select rectangle and square selections. 

2. To select a rectangle or square area in an image select the Rectangular Marquee Tool from Marquee 

Tool. 

3. Drag the required area for selection. Use Shift key for multiple selections in a single image. 

4. A dotted rectangular/square line will be displayed around the selection. 

 

Elliptical Marquee Tool: 

1. This Tool is used to select elliptical and circular selections. 

2. To select an elliptical or circular area in an image select the Elliptical Marquee Tool from Marquee 

Tool. 

Drag the required area for selection. Use Shift key for multiple selections in a single image. 

3. A dotted elliptical/circular line will be displayed around the selection. 

 

Lasso Tool: 

1. This Tool is used to select freehand selection. 

2. Select the Lasso Tool from the Tool bar. Then click on a starting point. 

3. Move the mouse along the required area and remember that you should not release the mouse button. 
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4. Your selection will end at your starting point. Then you can release the mouse button. 

 

Polygonal Lasso Tool: 

1. This Tool is also used to select freehand selection. 

2. The difference between Lasso Tool and Polygonal Lasso Tool is you can release the mouse button 

while selection is going on in Polygonal Lasso Tool where as in Lasso Tool you can not release the 

mouse button. 

3. Click on a starting point. Move the cursor to the next point not far from the starting point and click 

again. This will draw a straight line between the two points. 

4. Move the mouse along the required area. Your selection will end at your starting point. 

 

Magnetic Lasso Tool: 

1. This Tool is also used to select freehand selection. 

2. When you use Magnetic Lasso Tool you do not need to perform mouse click all the time. 

3. Just click at the beginning of the selection and then roll over the mouse pointer on the image for 

selection. 

4. Finally bring the mouse pointer to the starting point and click on it. Then required area of an image 

will be selected. 

 

Magic Wand Tool: 

 

1. This Tool is used to select a consistently colored area. 

2. You can set Tolerance in the Options bar of the Magic Wand Tool. 

3. Select the Magic Wand Tool from the Toolbar by clicking on the icon. 

4. Bring the mouse pointer to a particular color in the image that must be included in the selection and 

click on it. 

5. It includes colors of the image similar to the color of the selected color according to the specified 

Tolerance. 

11. Explain PENTOOL in detail? 

Photoshop provides multiple Pen tools to suit your use cases and creative style: 

1. The standard Pen tool lets you draw straight segments and curves with great precision. 

2. The Freeform Pen tool lets you draw paths as if you were drawing with pencil on a piece of paper.  

3. The Magnetic Pen options let you draw a path that snaps to the edges of the defined areas in your 

image.  

               When you use the standard Pen tool, the following options are available in the options bar: 

➢ Auto Add/Delete, which lets you add an anchor point when you click a line segment or delete an 

anchor point when you click it. 

➢ Rubber Band, which lets you preview path segments as you move the pointer between clicks. To 

access this option, click the pop-up menu to the right of the Custom Shape icon. 

1. Draw straight line segments 

                 The simplest path you can draw with the standard Pen tool is a straight line, made by clicking the 

Pen tool to create two anchor points. By continuing to click, you create a path made of straight line 

segments connected by corner points. 
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Clicking the Pen tool creates straight segments. 

 

1. Select the Pen tool. 

2. Position the Pen tool where you want the straight segment to begin, and click to define the first anchor 

point (do not drag). 

3. Click again where you want the segment to end (Shift-click to constrain the angle of the segment to a 

multiple of 45°). 

4. Continue clicking to set anchor points for additional straight segments. 

The last anchor point you add always appears as a solid square, indicating that it is selected. Previously 

defined anchor points become hollow, and deselected, as you add more anchor points. 

5.  Complete the path by doing one of the following: 

➢ To close the path, position the Pen tool over the first (hollow) anchor point. A small circle 

appears next to the Pen tool pointer  when it is positioned correctly. Click or drag to close the 

path. 

➢ To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere away from 

all objects. 

To leave the path open, you can also select a different tool. 

Draw curves with the standard Pen tool 

                                       You create a curve by adding an anchor point where a curve changes direction, and 

dragging the direction lines that shape the curve. The length and slope of the direction lines determine 

the shape of the curve. 

1. Select the Pen tool. 

2. Position the Pen tool where you want the curve to begin, and hold down the mouse button.The first 

anchor point appears, and the Pen tool pointer changes to an arrowhead. 

3. Drag to set the slope of the curve segment you’re creating, and then release the mouse button.Extend 

the direction line about one third of the distance to the next anchor point you plan to draw. Hold 

down the Shift key to constrain the tool to multiples of 45°. 

 Drawing the first point in a curve 
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A. Positioning Pen tool B. Starting to drag (mouse button pressed) C. Dragging to extend direction 

lines  

 

1. Position the Pen tool where you want the curve segment to end, and do one of the following: 

• To create a C-shaped curve, drag in a direction opposite to the previous direction line. Then 

release the mouse button. 

 
Drawing the second point in a curve 

 

• To create an S-shaped curve, drag in the same direction as the previous direction line. Then 

release the mouse button. 

 

Drawing an S curve 

 

 Continue dragging the Pen tool from different locations to create a series of smooth curves. Note that 

you are placing anchor points at the beginning and end of each curve, not at the tip of the curve. 

 Complete the path by doing one of the following: 

• To close the path, position the Pen tool over the first (hollow) anchor point. A small circle 

appears next to the Pen tool pointer  when it is positioned correctly. Click or drag to close the 

path. 

• To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere away from 

all objects or select a different tool. 

 

2.DRAW WITH FREEFORM TOOL 

The Freeform Pen tool lets you draw as if you were drawing with a pencil on paper. Anchor points are added 

automatically as you draw. You do not determine where the points are positioned, but you can adjust them 

once the path is complete. To draw with greater precision, use the Pen tool. 

1. Select the Freeform Pen tool . 
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2. To control how sensitive the final path is to the movement of your mouse or stylus, click the inverted 

arrow next to the shape buttons in the options bar, and enter a value between 0.5 and 10.0 pixels for Curve 

Fit. A higher value creates a simpler path with fewer anchor points. 

3. Drag the pointer in the image. As you drag, a path trails behind the pointer. When you release the mouse, 

a work path is created. 

4. To continue the existing freehand path, position the pen pointer on an end point of the path, and drag. 

5. To complete the path, release the mouse. To create a closed path, drag the line to the initial point of the 

path (a circle appears next to the pointer when it is aligned). 

3. DRAW USING THE MAGNETIC PENTOOL OPTIONS 

                                   The Magnetic Pen is an option of the Freeform Pen tool that lets you draw a path that 

snaps to the edges of defined areas in your image. You can define the range and sensitivity of the snapping 

behavior, as well as the complexity of the resulting path. The Magnetic Pen and Magnetic Lasso tools share 

many of the same options. 

➢ To convert the Freeform Pen tool to the Magnetic Pen tool , select Magnetic in the options bar, or 

click the inverted arrow next to the shape buttons in the options bar, select Magnetic, and set the 

following: 

• For Width, enter a pixel value between 1 and 256. The Magnetic Pen detects edges only within the 

specified distance from the pointer. 

• For Contrast, enter a percentage value between 1 and 100 to specify the contrast required between 

pixels for that area to be considered an edge. Use a higher value for low-contrast images. 

• For Frequency, enter a value between 0 and 100 to specify the rate at which the Pen sets anchor 

points. A higher value anchors the path in place more quickly. 

• If you are working with a stylus tablet, select or deselect Pen Pressure. When this option is selected, 

an increase in pen pressure causes the width to decrease. 

 Click in the image to set the first fastening point. 

 To draw a freehand segment, move the pointer or drag along the edge you want to trace. 

The most recent segment of the border remains active. As you move the pointer, the active segment snaps to 

the strongest edge in the image, connecting the pointer to the last fastening point.  

 
Click to add fastening points, and continue tracing. 

 

 If the border doesn’t snap to the desired edge, click once to add a fastening point manually and to 

keep the border from moving. Continue to trace the edge and add fastening points as needed. If you make a 

mistake, press Delete to remove the last fastening point. 

  

➢ Complete the path: 

• Hold down Alt (Windows) or Option (Mac OS), and double-click to close the path with a straight 

segment. 
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12. Explain how to save and load selections in Photoshop? 

             Selections are areas within the canvas that you set apart from the rest which you can apply special 

effects to or otherwise modify, copy, cut, flip, move, rotate or scale. Typical reasons to make selections 

include 

• Editing a portion of your canvas 

• Creating a mask or layer 

• Cropping 

• Applying filters and Special effects to portions of your image. 

 

Save a Selection to a New Channel 

1. Select the area or areas of the image you want to isolate. 

2. Click the save selection button at the bottom of the channels panel. A new channel appears, named 

according to the sequence in which it was created. 

 

Save a Selection to a new or existing channel 

1. Use a selection tool to select the area or areas of the image you want to isolate. 

2. Choose Select > Save Selections. 

3. Specify the following in the Save Selection dialog box, and click OK. 

• Document: Chooses a destination image for the selection. 

• Channel: Chooses a destination channel for the selection. 

4. If you are saving the selection as a new channel, type a name for the channel in the Name text box. 

5. If you are saving the selection to an existing channel, select how to combine the selections. 

• Replace Channel: Replaces the current selection in the channel. 

• Add to Channel: Adds the selection to the current channel contents. 

• Subtract from Channel: Deletes the selection from the channel contents. 

• Intersect with Channel: Keeps the areas of the new selection that intersect with the channel 

contents. 

You can select the channel from the channels panel to see the saved selection displayed in gray scale. 

 

Load a Saved Selection: 

1. Choose Select > Load Selection. 

2. Specify the source options in the Load Selection dialog box. 

• Document: Chooses the source to load. 

• Channel: Chooses the channel containing the selection you want to load. 

• Invert: Selects the non-selected areas. 

3. Select an operation option to specify how to combine the selections if the image already has a 

selection. 

• New Selection: Adds the loaded selection. 

• Add to Selection: Adds the loaded selection to any existing selections in the image. 

• Subtract from Selection: Subtracts the loaded selection from existing selections in the image. 

• Intersect With Selections: Save a selection from an area intersected by the loaded selection and 

existing selections in the image. 
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13. Explain Eraser Tools in Photoshop? 

                         The Eraser tools in Photoshop elements let you erase areas of your image. The eraser tools 

are: The Regular Eraser, The Background Eraser and the Magic Eraser. 

 The Regular Eraser Tool 

 

The Regular Eraser tool enables you to erase areas on your image to either your background color or, if 

you are working on a layer, a transparent background. There are several eraser options to specify on the 

options bar: 

• Brush Presets: Click the drop-down panel to access the Brush presets. Choose the brush of your 

choice. Additional brush libraries are available on the Brushes pop-up menu. 

• Size: Click the down-pointing arrow to access the size slider. Choose a brush size between 1 and 

2500 pixels. 

• Mode:  Select from Brush, pencil, and Block. When you select Block ,you are stuck with one size(a 

16-x-16-pixel tip) and can’t select other preset brushes. 

• Opacity: Specify a percentage of transparency for your erased areas. The lower the opacity setting, 

the less it erases. Opacity Is not available in Block mode. 

 

The Background Eraser Tool 

          The Background Eraser tool erases to transparency on a layer. If you use this tool on an image with 

only a background, Elements converts the background into a layer. The rundown on the Background Eraser 

option are: 

• Brush Preset Picker: This option provides settings to customize the size and appearance of your 

brush tip. The Size and Tolerance settings at the bottom are for pressure-sensitive drawing tablets. 

• Limits: Discontiguous erases all similarly colored pixels wherever they appear in the image 

.Contiguous erases all similarly colored pixels that are adjacent to those under the hot spot. 

• Tolerance: The percentage determines how similar the colors have to be to that of the color under 

the hot spot before elements erases them. A higher value picks up more colors, whereas a lower value picks 

up fewer colors. 

 

 
 

The magic Eraser Tool 

         The magic Eraser tool is a combination Eraser and Magic Wand tool. It selects and erasers similarly 

colored pixels simultaneously. If you are working on an image with just a background, Elements converts 

the background into layer. The magic Eraser shares many options with the other erasers. Here are the unique 

options: 

• Anti-Alias: Creates a slightly soft edges around the transparent area. 

• Sample All layers: Samples colors using data from all visible layers but erases pixels on the active 

layer only. 

 

14. Working with Text Tool: 

Text can be added to an image or can be created for use as an image by itself. The following actions will 

be performed with text tool. 
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• Adding Text 

• Deleting Text 

• Positioning Text 

• Enhancing Text 

 

ADDING TEXT: 

1. Adding text can be done in two ways: you may add text to an existing selected layer or if no layer is 

selected you may add text to the image and a new layer will be automatically created. 

2. To add text select Horizontal or Vertical Type Tool from the Text Tool and type the text you want to 

display on the image. 

3. You can specify the text size, color and style in options bar. 

 

DELETING TEXT: 

1. If you want to delete a text form the image then select the layer that contains the text you want to 

delete. 

2. Then delete layer by right clicking and selecting delete layer option or by selecting delete icon from 

the layers panel or by selecting delete layer sub-option from the Delete option that is available in Layer 

Menu. 

 

POSITIONING TEXT: 

1. To position the text select the layer that containing the text you want to move. 

2. Select move tool from the tool bar and select the layer and drag the layer to the required position. 

3. To move the text pixel by pixel, use the arrow keys. 

 

ENHANCING TEXT: 

1. You can enhance your text by using many special artistic effects such as drop shadowing, bevel and 

emboss, and color overlay. 

2. You can get these effects by right clicking on the text layer and select Blending options. 

3. From this you can apply different kind of styles to the Text. 

 

15. Explain Paint with the brush tool or pencil tool? 

                                 Adobe photoshop provides several tools for painting and editing mage color. The 

Brush tool and the pencil tool work like traditional drawing tools applying color with brush strokes. The 

Brush tool creates soft strokes of color. The pencil tool creates soft strokes of color. The Pencil tool creates 

hard-edged lines. 

1. Choose a foreground color. (Choose colors in the toolbox) 

2. Select the Brush tool or Pencil tool. 

3. Choose a brush from the Brush presets panel. See select a preset brush. 

4. Set tool options for mode, opacity, and so on, in the options bar. 

5. Do one or more of the following. 

• Click and drag in the image to paint. 

• To draw a straight line, click a starting point in the image. Then hold down shift, and click an ending 

point. 

• When using the Brush tool as an airbrush, hold down the mouse button without dragging to build up 

color. 
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16. Explain Levels and Curves adjustments in Photoshop? 

                     Two of Photoshop’s most important image editing tools-the Levels and Curves adjustments. 

CURVES  

          In general, curves are a bit more user friendly, and will allow to make more dramatic changes than 

levels. With the ability to change things drastically comes the ability to either really mess an image up, or 

make it great. 

Uses of Curves  

1. Adjusting the colors of highlights, midtones and shadows. 

2. Adjusting very specific values (Using the Hand). 

3. Creating Vignettes (Pull RGB up in center slightly). 

4. In composing, often it will need to change colors, lights and darks to make an image fit. 

LEVELS 

Levels are perfect for large global adjustments such as making the lights of an entire image a little less 

bright. They are a bit more subtle than curves. 

Uses of Levels 

1. Making subtle changes. 

2. Adding slight color to highlights and shadows. 

3. Making white levels slightly darker so things don’t look blown out. 

 

17. Explain in detail about Seeing color accurately? 

        You can select a color from 

▪ Color picker dialog box. 

▪ Colors Panel 

▪ Swatches Panel 

It is not possible to select the exact color of an image. By using above three methods you can select a color. 

But you cannot select an exact color from any of the above three methods. 

To select a color exactly Photoshop provides two kinds of Tools. 
• Eyedropper Tool 

• Color Sampler Tool 

EYEDROPPER TOOL: 
▪ By using Eyedropper tool one can select a particular color from an image. 

▪ Select Eyedropper tool from the tool bar. 

▪ Click on a color in the image to pick a color. 

▪ Then your foreground color will be changed to the selected color. 

COLOR SAMPLER TOOL: 
▪ By using Color Sampler Tool one can find the color percentages of a color. 

▪ Select Color Sampler Tool from the tool bar. 

▪ Click on a color in the image. 

▪ Then the Info panel displays the color percentage (i.e., RGB or CMYK) values. 

 

18. Explain PATCH TOOL? 

    The patch tool is used to remove unwanted image elements. The Content-Aware option in the patch 

tool synthesizes nearby content for seamless blending with the surrounding content. The patch tool retouches 

image using sampled pixels or pattern. It works as a combination of the Healing Brush with the Lasso Tool. 

There are 2 methods to retouch using sampled pixels. 
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Method 1: 

▪ In the Toolbox, select the Patch Tool. 

▪ Drag in (select) a damaged area with the patch tool. 

▪ On the Options bar, choose the source mode. 

▪ Drag the selection (cursor inside of selection) on to a repair-source area(movie). 

Method 2:   

▪ Drag in a repair-source area with the Patch Tool. 

▪ On the Options bar, choose the Destination mode. 

▪ Drag the selection (cursor inside of selection) onto a damaged area (movie). 

TO RETOUCH WITH A PATTERN, USE METHOD3: 

▪ Drag in a damaged area with the patch Tool. 

▪ In the Pattern Picker, choose a pattern (movie). 

▪ Click the use Pattern button on the Options bar. 

 

19. READING YOUR PALETTES: 

             Palette: A palette is a group of tools used to edit and manipulate your image. Photoshop contains 

over twenty palettes that can be shown or hidden by using the WINDOW menu and selecting the palette you 

wish to reveal. 

 

Colors Palette: 

1. By using colors palette you can select and change your  

background colors that will be used with brushes and fills. 

2. To change the color, select either the foreground 

Or background color box in the Color palette by clicking on it. 

 

Swatches Palette: 

1. By using Swatches palette you can select a particular color for  

background and foreground colors. 

2. To select a color simply click on a color. 

3. Swatches palette contains two options. They  Create new  

Swatch of foreground color and Delete swatch. 

4. “Create new swatch of foreground color” is used to create a new 

swatch with current foreground color and “Delete Swatch” is used to 

delete a color from the swatches palette. 

 

Navigator Palette: 

 

1. Navigator palette will display the currently displayed image  

with different options. 

2. Navigator Palette displays different zoom options include zoom 

 field to enter a zoom level, zoom out icon, zoom slider and zoom in  

icons. 

3. By using Navigator Palette you change the zoom level of an 

 image. 
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History Palette: 

1. The History palette stores and displays each action 

 Performed allowing you jump to any recent stage of  

the image alteration. 

2. The History palette can store up to 20 stages.  

However, you can always go back to the first stage 

   For example opening the document. 

3. It is important to know that once you click on any of 

 the previous stages, all the changes that were made 

 after it will be lost. 

 

 

20. Explain about DUST AND SCRATCHES? 

    Healing Brush Tool: 

1. Healing Brush Tool is used to Corrects small blemishes in Scanned Photos. 

2. Select the Tool form the tool bar and hold down the ALT key and click on the base color you need to 

heal. 

3. Then click over the blemish to remove the blemish. 

 

Clone Stamp Tool: 

1. Takes a sample of an image and applies over another image or part if the same image. 

2. Select the tool from tool bar. Hold down the ALT key and click on a certain point of the document 

where you want to start your copy point. 

3. Place your mouse over whatever part of the new document you want the picture to go to. 

4. Drag the mouse across the page to copy the picture. 

5. Clone stamp tool is the best weapon again dust and scratches. 

 

SMOOTHING SKIN: 

▪ You can smooth the hard edges of a selection by anti-aliasing or feathering. 

▪ Anti-aliasing smoothes the jagged edges of a selection by softening the color transition between 

edge pixels and background pixels. 

▪ Anti-aliasing is useful when cutting, copying and pasting selections to create composite images. 

▪ You can select anti-aliasing with lasso, polygonal lasso, magnetic lasso, elliptical marquee, and 

magic wand tools. 

▪ Select a selection tool from tool bar and select anti-aliasing in the options bar and make selection. 

 

13) Explain in detail about Advanced Retouching? 

The following tools are used for advanced retouching in 

Photoshop.  

1. Clone Stamp Tool 6. Smudge Tool 

2. Pattern Stamp Tool 7. Blur Tool 

3. Healing Brush Tool 8. Sharpen Tool 

4. Patch Tool 9. Dodge Tool and Burn Tool 

5. Color Replacement Tool 10. Sponge Tool 

 

1. Takes a sample of an image and applies over another image, or a part of the same image. 

2. Select the tool. 
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3. Hold down the ALT key and click on a certain point of the document where you want to start your 

copy point. 

4. Then, put your mouse over whatever part of the new document you want the picture to go to. 

5. Hold down the mouse button and drag the mouse across the page to copy the picture. 

 

Healing Brush Tool: 

1. Corrects small blemishes in scanned photos. 

2. Select the tool. 

3. Hold down the ALT key and left-click on the base color you need to heal. 

4. Then click over the blemish. 

 

 

Blur Tool: 

1. Blurs the sharp edges of an image. 

2. Select an area where you wish to apply the tool. 

3. Click the tool button, choose the Brush, Mode, and Strength. 

4. Drag the brush along the edges. 

 

Dodge Tool: 

1. Lightens areas in an image. 

2. Select the area where you wish to apply the tool. 

3. Choose the Brush, Range, and Exposure. 

4. Click on the spots you wish to highlight. 

 

Sponge Tool: 

1. Convert the color photo into Black and White. 

2. Select the tool. 

3. Increase the tool size by using] key. 

4. Then drag over the image. 

 

 

 

 

 



                                                                                                                                      
                                                                                                                                   COMPUTER FUNDAMENTALS AND PHOTOSHOP 

60 
 

 

UNIT V 

WORKING WITH LAYERS 

1. What is a Layer? What are the advantages of a Layer? Explain Layer Palette? 

LAYER: A layer is the term used to describe the different levels at which you can place an object or 

image file. 

Advantages of Layers: 

1. You can separate parts of the image and edit them without affecting other parts of the image. 

2. You can use layers as guides or references without including them in the final image. 

3. You can safely import new images to add to the composition and you can do whatever you like 

without damaging the original image. 

4. You can create multiple versions of layers and experiment with different effects. 

5. You can apply filters and effects to layers independently. 

 

Layers Palette: 

Photoshop’s layers panel is a powerful tool that allows you to do many special things to your layered 

composition 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Blend options: 

Change these to change the way that the selected layer blends with the layers underneath it. Best suited 

when compositing and adding special effects. Use Shift + or Shift – to select blend options through 

keyboard. 

 

Opacity: 

Used to mix the layers. 0=transparent and 100=full opaque. Use keyboard numerical keys to instantly 

set opacity to multiples of 10, or adjust the slider for an exact opacity value. 
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Visibility: 

Show or hides the selected layer. The eye symbol besides the layer name indicates that the layer is 

visible. Click on the eye symbol to hide the layer. Click on it again to show the layer. 

 

Fill Opacity: 

Adjusts the amount of opacity of the pixels only, any layer styles and other layers wont effected and 

remain 100% opaque. 

 

Lock all: 

Selecting this option enables the layer is totally protected from any editing. 

 

Lock Position: 

Selecting this option enables the position of the layer is locked. You cannot move the layer but you can 

edit the layer. 

 

Lock Image Pixels: 

Selecting this enables you cannot draw on this layer. 

 

Layer Styles: 

Special effects applied to your image layer. Small “f” icon in the layer palette indicates layer styles. 

When you select this option it will display several options. At a particular time you can select multiple 

styles. 

 

Layer Mask: 

This option enables you to add a layer mask to the currently selected layer. Allows you to paint away 

parts of your layer without damaging your original image. 

 

Add Adjustment Layer: 

The best way to apply image adjustments. You can select these options from layers menu adjustment 

layer option also. By using these options you can change the color or tone of an image. 

 

New Layer set: 

This option enables you to put layer into a folder. You choose multiple layers and press Ctrl+G to put 

them in a group. 

 

Create New Layer: 

By selecting this option you can create a new layer. Drag an existing layer into this icon to create a 

duplicate of that layer. 

 

Delete Layer: 

Drag layer into this icon to remove it or select the layer and then press this icon to get the same result. 

2.Explain working with layers? 

            When working with images divided into layers, each layer operates independently with its own 

contents. This allows you to change one layer without effecting the other layers or the background of the 

image. When layered together, the contents of each layer combine to create a composite image 

• Creating Layers 

• Deleting layers 
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• Retrieving Deleted layers 

• Renaming Layers 

• Changing Layer Opacity 

 

1. CREATING LAYERS 

              Photoshop allows you to create multiple layers in an image .Each  layer  is assigned a default 

name, and the default opacity is set to 100%.You can create layers using the New Layer Dialog box or the 

Layers Palette. 

Creating Layers: Dialog Box Option 

Using the dialog box method, you can create a new layer and change the layer name, opacity, color, and 

mode. 

1. From the Layer menu, select New >> Layer... 

OR 

Press CTRL + SHIFT+ N 

OR 

Press ALT + CREATE A NEW LAYER on the layers palette 

The New Layer dialog box appears. 

 
 

2. In the Name text box, type the desired name. 

3. OPTIONAL: To change the layer opacity, in the opacity textbox, type the desired percentage of 

opacity. 

4. OPTIONAL: to color-code the layer, the color pull down list, select the desired color. 

5. OPTIONAL: To change the layer mode, from the mode pull down list, select the desired mode. 

6. Click OK  

The new layer appears on the layers palette. 

 

Creating Layers: layers palette Option 

1. From the Layers palette, click CREATE A NEW LAYER. 

The new layer appears on the Layers palette. 

 

2. DELETING LAYERS 

                   If you no longer need a layer, or wish to replace a layer, you can delete it. Layers can be 

deleted by using the menu option, right click option, or button option. 

Deleting Layers: Menu Option 

1. From the Layers palette, select the layer you want to delete. 

2. From the Layer menu, select Delete layer. 

3. Click YES 
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The layer is deleted  

 

Deleting Option: Right Click Option 

1. From the Layers Palette, right click the layers you want to  

Delete>>select Delete Layer 

A confirmation dialog box appears. 

2. Click YES 

The layer is deleted 

Deleting Layers: Button Option 

1. From the layers palette, select the layer you want to delete 

2. Click the Delete Layer button 

A confirmation dialog box appears. 

3. Click YES 

The layer is deleted. 

 

2. RETRIEVING DELETED LAYERS 

   If you delete a layer in error, it is best to retrieve the layer immediately so that you do not lose any 

changes that have been made to the image since the layer was deleted. 

Retrieving Deleted Layers: Undo option 

1. From the Edit menu, select Undo delete Layer 

OR 

Press CTRL + Z 

The deleted layer reappears. 

Retrieving Deleted Layers: Step Backward option 

You can use this option to retrieve a deleted layer, but you will lose any changes that you have made to 

the image since the layer was deleted 

1. From the Edit menu, select Step Backward 

OR 

Press CTRL + ALT + Z 

The most recent change to the image is erased. 

2. Repeat until the layer reappears. 

4. RENAMING LAYERS 

    Since Photoshop assigns default names to layers, you may find it helpful to rename them. 

RENAMING LAYERS: LAYER PROPERTIES DIALOG BOX 

1. Select the layer you want to rename. 
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2. From the layer menu, select Layer Properties.. 

OR 

From the Layers palette, right click the layer you wish to rename >>select Layer properties. 

The layer Properties dialog box appears. 

 

3. In the Name text box, type an appropriate name for the layer 

4. Click OK 

The Layers new name appears on the Layers palette. 

RENAMING LAYERS: Mouse Option 

1. Double click the name of the layer you wish to rename  

   A text box appears around the layer name. 

2. Type the new layer name. 

3. Press ENTER 

The layer’s new name appears on the Layers Palette. 

5. CHANGING LAYER OPACITY  

                     You can set a layer’s opacity at any value from 0-100%. A layer with opacity of 0% is 

completely transparent; a layer with an opacity of 100% is completely opaque. 

You can change the opacity when you create a layer or anytime thereafter. To change the opacity of an 

existing layer. 

1. Select the layer whose opacity you wish to change. 

2. From the Layers palette, in the Opacity text box, type the desired percentage of opacity. 

OR 

Click the arrow and adjust the opacity slide bar. 

The Layers opacity is adjusted. 

3. Explain Advanced Layer Options? 

              Although layers are constructed individually it is helpful to rearrange and link layers when 

creating more advanced images. You can merge and flatten layers so that they function collaboratively.  

• Rearranging layers 

• Linking layers 
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• Merging layers 

• Flattening layers 

 

1. REARRANGING LAYERS 

    Layers are arranged with in the layers palette with the top most layers on the layers palette being the 

topmost layer of the image. Rearranging layers can reveal and hide visible shapes. The BACKGROUND 

LAYERS cannot be moved. 

         OPTION                      ACTION                              KEYBOARD COMMAND 

Bring to Front         Sends layer to top most position                    shift +ctrl+] 

Bring Forward         Sends layer up one position                           ctrl+] 

Send Backward       Sends layer down one position                       ctrl+ [ 

Send to Back          Sends layer to bottom most position               shift +ctrl+ [ 

                                                   

 
 

Rearranging layers: Drag-and-Drop option 

1. From the LAYERS palette, select the layer you wish to move. 

2. Click and drag the layer to the desired position. 

3. Release the layer 

The layer is now in the new position. 

Rearranging Layers: Menu options: 

1. From the LAYERS palette, select the layer you wish to move. 

2. From the LAYER menu, select ARRANGE >> DESIRED OPTION. 

Your layer is moved accordingly. 

 

 

 

 

 

 

Rearranging layers: Keyboard Option 

1. From the LAYERS palette, select the layer you wish to move. 

2. Press the keyboard command for the desired option the layer moves to the selected position. Confirm 

the new layer placement by checking the layer position on the LAYER palette. 

 

Bring to Front                      shift+ctrl+] 
Bring forward                               ctrl+] 
Send Backward                             ctrl+[ 
Send to Back                        shift+ctrl+[ 
Reverse 
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2.  LINKING LAYERS 

            If you want multiple layers to move as a single unit with in the image window, you should link 

them. You must link a minimum of 2 layers, but there is no limit to the number of layers that can be linked 

together. 

1. On the LAYERS palette, press ctrl + select the layer(s) you want to link. 

2. From the LAYER palette, click LINK LAYERS. 

3. A link icon appears next to layer names, indicating that the layers are linked. 

Moving Linked Layers in an Image 

1. From the LAYER palette, select the linked layer you want to move. 

2. From the Toolbox, select the move tool  

3. Within the image window ,click and drag to the new location 

Unlinking Layers 

1. From the LAYERS palette, select the layer you want to unlink. 

2. From the LAYERS palette, select LINK LAYERS. 

The link icon disappears and the layer is no longer linked. 

                        
 

3. MERGING LAYERS 

                                             Merging layers combine layers together so they no longer function 

individually.Images saved with individual layers occupy a lot of file space; Merging layers compresses 

your image so it takes up less file space. 

 

 Merging Linked Layers 

                Merging linked layers allows you to determine which layers will be merged into one layer 

and which remain independent. 

1. From the LAYER menu, select SELECT LINKED LAYERS. 

2. From the LAYER menu, select MERGE LAYERS. 

(OR) 

Press ctrl+E 

The selected linked layers combine to form a single layer. 

 

Merging Visible Layers 

You can also merge visible layers. Visible layers are identified by the VISIBILITY icon, which appears 

in the left column of the layers palette. 

1. On the LAYERS palette, hide the layers you do not wish to merge. 

2. Select one of the remaining visible layers. 

3. From the layer menu, Select MERGE VISIBLE 
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                                  All of the visible layers on the LAYERS palette are merged into a single layer. The 

hidden layers are preserved as independent layers. 

                                    
 

4. FLATTENING LAYERS 

 Flattening layers will compress your image so that it takes up less file space, it is different from 

merging in that it discards hidden layers, combines visible layers into single layer, and removes 

transparent areas from an image. 

1. Make sure that all the layers you wish to flatten are visible on the layers palette. 

2. From the LAYER menu, select FLATTEN IMAGE. 

                If there are hidden layers in the image, a dialog box appears confirming your request to 

discard hidden layers. 

3. Click OK 

    The visible layers are now flattened and hidden layers have been discarded. 

 

4. Explain the concept of Adjustment layers? 

                                  An adjustment layer applies color and tonal adjustments to your image without 

permanently changing pixel values. For example, rather than making a Levels or Curves adjustment 

directly to your image, you can create a Levels or Curves adjustment layer. The color and tonal 

adjustments are stored in the adjustment layer and apply to all the layers below it; you can correct multiple 

layers by making a single adjustment, rather than adjusting each layer separately. You can discard your 

changes and restore the original image at any time. 

Fill layers let you fill a layer with a solid color, a gradient, or a pattern. Unlike adjustment layers, fill 

layers do not affect the layers underneath them. 

Adjustment layers provide the following advantages: 

• Nondestructive edits. You can try different settings and re-edit the adjustment layer at any time. 

You can also reduce the effect of the adjustment by lowering the opacity of the layer. 

• Selective editing. Paint on the adjustment layer’s image mask to apply an adjustment to part of an 

image. Later you can control which parts of the image are adjusted by re-editing the layer mask. You can 

vary the adjustment by painting on the mask with different tones of gray. 

• Ability to apply adjustments to multiple images. Copy and paste adjustment layers between images 

to apply the same color and tonal adjustments. 

Adjustment layers have many of the same characteristics as other layers. You can adjust their opacity 

and blending mode, and you can group them to apply the adjustment to specific layers. Likewise, you can 

turn their visibility on and off to apply or preview the effect. 
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Original (left); adjustment layer applied to barn only (center), which brings out detail in the barn; and 

adjustment layer applied to entire image (right), which lightens the entire image and pixelates the clouds 

5. What is Opacity? 

The opacity level is a feature in adobe photoshop which allows you to adjust the opacity of a layer. It is 

scaled on a measure of 0-100, with 0 being 100% transparent and 100 being 100% opaque. 

                  A layer’s overall opacity determines to what degree it reveals the beneath it. A layer with 

1%opacity appears nearly transparent, whereas one with 100%opacity appears completely opaque. 

In addition to overall opacity, which affects layer styles and blending modes applied to a layer, you can 

specify fill opacity. Fill opacity affects only pixels, shapes, or text on a layer without affecting the opacity 

of layer effects such as drop shadows. 

1. In the layers panel, select one or more layers or groups. 

2. Change the opacity and Fill values. (If you selected a group, only opacity is available.) 

  6) Explain Layer styles? 

Layer styles let you quickly apply effects to an entire layer. When you apply a style to a layer, a style 

icon appears to the right of the layer’s name in the layers panel. Layer styles are linked to the layer 

contents. When you move or edit the contents of the layer, the effects are modified correspondingly. 

                        Once you choose Layer > Layer Style >Style settings, you can edit the settings of a 

layer’s style or apply other style settings available in the dialog box. 

 

1. Lighting Angle: Specifies the lighting angle at which the effect is applied to the layer. 

2. Drop Shadow: Specifies the distance of a drop shadow from the layers content. You can also set the 

size and opacity with the sliders. 

3. Glow (Outer): Specifies the size of a glow that emanates from the outside edges of the layer’s 

content. You can also set the opacity with the slider. 

4. Glow (Inner): Specifies the size of a glow that emanates from the inside edges of the layer’s 

content. You can also set the opacity with the slider. 

5. Bevel Size: Specifies the size of beveling along the inside edges of the layer’s content. 

6. Bevel Direction: Specifies the direction of the bevel, either up or down. 

7. Stroke Size: Specifies the size of the stroke. 

8. Stroke Opacity: Specifies the opacity of the stroke. 

 

7. Explain Layer Effects? 

Styles can be built with the following effects. 

1. Drop Shadow: Creates a shadow behind the layers contents. 

2. Inner Shadow: Creates a shadow on top of the layers contents. 

3. Outer Glow: Creates a glow behind the layers contents. Cannot be distanced like the drop shadow. 

4. Inner Glow: Creates a glow on top of the layers contents. Again, cannot be distanced like the inner 

shadow. 
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5. Bevel and Emboss: Used to create unique highlight and shadow effects on a layers contents. 

6. Satin: Gives the layer contents a satin-like, glossy appearance. 

7. Color Overlay: Fills the layer contents with a solid color. 

8. Gradient Overlay: Fills the layer contents with a gradient. 

9. Pattern Overlay: Fills the layer contents with a pattern. 

 10. Stroke: Creates an outline on layer contents using a solid color, gradient, or      pattern.  

   

FILTERS 

➢ What is Filter? 

1. A Filter is a collection of special tools that are used to clean up or retouch your photos and to apply 

special effects. 

2. To use a filter select the appropriate submenu command from the Filter menu. 

3. To apply a filter to an entire layer, make sure that the layer is active or selected. 

4. To apply a filter to an area of layer, select the area. 

 

1. Explain the concepts of Filter Menu? 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Artistic Filter: 

Artistic Filter is used to simulate the effect of using artistic equipment and media such as colored 

pencils water colors etc.                        

Blur Filter:           

     Blur Filter is used to blur the image. The sub-options provide a wide variety of blur options include 

Blur, Blur More, Radial Blur, Lens Blur etc. 

Brush Stroke Filter: 

Brush Stroke Filter is similar to the Artistic Filter. From the sub options you can select wide variety of 

Brush Stroke options.                                       

Distort Filter: 

The Distort Filter warps and disrupts the image in a different often extreme ways. The sub options 

include Diffuse Glow, Glass and Ocean Ripple etc. 

Pixelate Filter: 

The items on the Pixelate sub menu distort the colors of the image by grouping area of nearby pixels 

together into large blocks or dividing portions of the image into various shapes and sizes. 
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Render: 

Render Filter allows sophisticated 3D manipulations and lighting effects. 

Sharpen: 

Sharpen Filter is used for photo repair. It emphasizes the outlines of objects as determined by sharp 

differences in color or intensity.         

Sketch: 

This is another filter designed to simulate artistic drawing techniques and media. Most of the items in 

the sub-menu rely heavily on the foreground and background colors. 

Stylize: 

This filter is used to distorts the image colors in extreme ways. It is very useful when designing patterns 

and logos. 

Texture: 

This filter is used to apply a three Dimensional or other texture to the image. 

Video: 

This Filter is applied to the videos not to the still images. 

Digimarc: 

This Filter is used to embed or read a watermark to signal that the image is your copyrighted property. 

 

2. Explain BLUR FILTER? 

Blurs can be accessed from the Filter menu. We have 14 different options available in Photoshop CS6. 

1. Average Blur:-Selecting this option will create a color that is the average of all the colors in your 

image by averaging the color value of neighboring pixels. 

2. Blur and Blur More:-The Blur Filter will look for significant color transition or edges. There are 

no controls available for this Filter. Blur More is a way that you can create a more blurry image once you 

applied Blur Filter. 

 

 

 

 

 

 

 

 

 

 

3. Gaussian Blur:-The Gaussian Blur Filter will blur an image or selected area by an adjustable 

amount based upon a weighted average. The end result of a Gaussian Blur is a hazy effect. 

 

4. Lens Blur:-Using the Lens Blur Filter gives the illusion of a narrow depth of field on your image. 

This Blur worked based upon a depth map. 

 

5. Motion Blur:-The Motion Blur Filter applies a specific Blur in a specific direction with a specific 

intensity to your image. A dialog box with a little wheel will be opened when you select this Filter. 

 

6. Radial Blur:-A Radial Blur Filter will simulate either zooming in or rotating a camera. The Radial 

Blur is little different form previous Blur. 
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7. Smart Blur:-The Smart Blur smoothes out grain and noise patterns between edges. If you select a 

particularly grainy image, this filter can help you smooth it out. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Explain ARTISTIC FILTERS? 

          Filters from the Artistic submenu help you achieve painterly and artistic effects for a fine arts or 

commercial project. All the Artistic filters can be applied through the Filter Gallery. 

Colored Pencil 

            Draws an image using colored pencils on a solid background. Edges are retained and given a 

rough crosshatch appearance; the solid background color shows through the smoother areas. 

Cutout 

            Makes an image appear as though it were constructed from roughly cut pieces of colored paper. 

High-contrast images appear as if in silhouette, and colored images are built up from several layers of 

colored paper. 

Dry Brush 

           Paints the edges of the image using a dry brush technique (between oil and watercolor). The filter 

simplifies an image by reducing its range of colors to areas of common color. 

Film Grain 

           Applies an even pattern to the shadow tones and midtones. A smoother, more saturated pattern is 

added to the lighter areas. This filter is useful for eliminating banding in blends and visually unifying 

elements from various sources. 

Fresco 

          Paints an image in a coarse style using short, rounded, and hastily applied daubs. 

Neon Glow 

         Adds various types of glows to the objects in an image. This filter is useful for colorizing an image 

while softening its look. To select a glow color, click the glow box, and select a color from the Color Picker. 

Paint Daubs 

         Lets you choose from various brush sizes (from 1 to 50) and types for a painterly effect. Brush 

types include Simple, Light Rough, Dark Rough, Wide Sharp, Wide Blurry, and Sparkle. 

Palette Knife 

         Reduces detail in an image to give the effect of a thinly painted canvas that reveals the texture 

underneath. 

Plastic Wrap 

         Coats the image in shiny plastic, accentuating the surface detail. 
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Poster Edges 

          Reduces the number of colors in an image according to the posterization option you set, and finds 

the edges of the image and draws black lines on them. Large broad areas have simple shading, and fine dark 

detail is distributed throughout the image. 

Rough Pastels 

         Applies strokes of pastel chalk on a textured background. In areas of bright color, the chalk appears 

thick with little texture; in darker areas, the chalk appears scraped off to reveal the texture. 

Smudge Stick 

              Softens an image using short diagonal strokes to smudge or smear the darker areas. Lighter areas 

become brighter and lose detail. 

Sponge 

             Creates images with highly textured areas of contrasting color, simulating the effect of sponge 

painting. 

Underpainting 

             Paints the image on a textured background, and then paints the final image over it. 

Watercolor 

             Paints the image in a watercolor style using a medium brush loaded with water and color, 

simplifying details. Where significant tonal changes occur at the edges, the filter saturates the color. 

4. Explain Brush Stroke filters? 

Like the Artistic filters, the Brush Stroke filters give a painterly or fine-arts look using different brush 

and ink stroke effects. Some of the filters add grain, paint, noise, edge detail, or texture. All the Brush 

Stroke filters can be applied through the Filter Gallery. 

Accented Edges 

          Accentuates the edges of an image. When the edge brightness control is set to a high value, the 

accents resemble white chalk; when set to a low value, the accents resemble black ink. 

Angled Strokes 

          Repaints an image using diagonal strokes, with lighter and darker areas painted in strokes going in 

opposite directions. 

Crosshatch 

          Preserves the details and features of the original image while adding texture and roughening the 

edges of the colored areas with simulated pencil hatching. The Strength option (with values from 1 to 3) 

determines the number of hatching passes. 

Dark Strokes 

         Paints dark areas with short, tight, dark strokes, and lighter areas with long, white strokes. 

Ink Outlines 

        Redraws an image with fine narrow lines over the original details, in pen-and-ink style. 

Spatter 

         Replicates the effect of a spatter airbrush. Increasing the options simplifies the overall effect. 

Sprayed Strokes 

      Repaints an image, using its dominant colors, with angled, sprayed strokes of color. 

Sumi-e 

             Paints an image in Japanese style, as if with a fully saturated brush applied to rice paper. Sumi-e 

creates soft, blurred edges with rich, inky blacks. 
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5.  Explain Distort Filters? 

The Distort filters geometrically distort an image, creating 3D or other reshaping effects. The Diffuse 

Glow, Glass, and Ocean Ripple filters can be applied through the Filter Gallery. 

Diffuse Glow 

         Renders an image as though it were viewed through a soft diffusion filter. The filter adds see-

through white noise, with the glow fading from the center of a selection. 

Displace 

        Uses an image, called a displacement map, to determine how to distort a selection. For example, 

using a parabola-shaped displacement map, you can create an image that appears to be printed on a cloth 

held up by its corners. 

Glass 

       Makes an image appear as if it were being viewed through different types of glass. You can choose a 

glass effect or create your own glass surface as a Photoshop file and apply it. You can adjust scaling, 

distortion, and smoothness settings. When using surface controls with a file, follow the instructions for the 

Displace filter. 

Ocean Ripple 

      Adds randomly spaced ripples to the surface of the image so that it appears to be underwater. 

Pinch 

     Squeezes a selection. A positive value up to 100% shifts a selection toward its center; a negative value 

up to – 100% shifts a selection outward. 

Polar Coordinates 

    Converts a selection from its rectangular to polar coordinates, and vice versa, according to a selected 

option. You can use this filter to create a cylinder anamorphosis—an art form popular in the 18th century—

in which the distorted image appears normal when viewed in a mirrored cylinder. 

Ripple 

    Creates an undulating pattern on a selection, like ripples on the surface of a pond. For greater control, 

use the Wave filter. Options include the number and size of ripples. 

Shear 

      Distorts an image along a curve. Specify the curve by dragging the line in the box. You can adjust 

any point along the curve. Click Default to change the curve back to a straight line. In addition, you choose 

how to treat undistorted areas. 

Spherize 

      Gives objects a 3D effect by wrapping a selection around a spherical shape, distorting the image and 

stretching it to fit the selected curve. 

Twirl 

      Rotates a selection more sharply in the center than at the edges. Specifying an angle produces a twirl 

pattern. 

Wave 

       Works much as the Ripple filter does, but with greater control. Options include the number of wave 

generators, wavelength (distance from one wave crest to the next), height of the wave, and wave type: Sine 

(rolling), Triangle, or Square. The Randomize option applies random values. You can also define 

undistorted areas. 

Zigzag 

Distorts a selection radially, depending on the radius of the pixels in your selection. The Ridges option 

sets the number of direction reversals of the zigzag from the center of the selection to its edge. You also 

specify how to displace the pixels: Pond Ripples displaces pixels to the upper-left or lower right, Out From 

Center displaces pixels toward or away from the center of the selection, and Around Center rotates pixels 

around the center. 
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6.  Explain Noise Filters? 

The Noise filters add or remove noise, or pixels with randomly distributed color levels. This helps to 

blend a selection into the surrounding pixels. Noise filters can create unusual textures or remove problem 

areas, such as dust and scratches. 

Add Noise 

           Applies random pixels to an image, simulating the effect of shooting pictures on high-speed film. 

You can also use the Add Noise filter to reduce banding in feathered selections or graduated fills or to give a 

more realistic look to heavily retouched areas. Options for noise distribution include Uniform and Gaussian. 

Uniform distributes color values of noise using random numbers between 0 and plus or minus the specified 

value, creating a subtle effect. Gaussian distributes color values of noise along a bell-shaped curve, creating 

a speckled effect. The Monochromatic option applies the filter to only the tonal elements in the image 

without changing the colors. 

Despeckle 

     Detects the edges in an image (areas where significant color changes occur) and blurs all of the 

selection except those edges. This blurring removes noise while preserving detail. 

Dust & Scratches 

    Reduces noise by changing dissimilar pixels. To achieve a balance between sharpening the image and 

hiding defects, try various combinations of Radius and Threshold settings. Or apply the filter to selected 

areas in the image. 

 

Median 

     Reduces noise in an image by blending the brightness of pixels within a selection. The filter searches 

the radius of a pixel selection for pixels of similar brightness, discarding pixels that differ too much from 

adjacent pixels, and replaces the center pixel with the median brightness value of the searched pixels. This 

filter is useful for eliminating or reducing the effect of motion on an image. 

Reduce Noise 

          Reduces noise while preserving edges based on user settings affecting the overall image or individual 

channels.  

 

7. Explain Pixelate Filters 

The filters in the Pixelate submenu sharply define a selection by clumping pixels of similar color values 

in cells. 

Color Halftone 

           Simulates the effect of using an enlarged halftone screen on each channel of the image. For each 

channel, the filter divides the image into rectangles and replaces each rectangle with a circle. The circle size 

is proportional to the brightness of the rectangle.  

 

Crystallize 

        Clumps pixels into a solid color in a polygon shape. 

Facet 

         Clumps pixels of solid or similar colors into blocks of like-colored pixels. You can use this filter to 

make a scanned image look hand-painted or to make a realistic image resemble an abstract painting. 
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Fragment 

        Creates four copies of the pixels in the selection, averages them, and offsets them from each other. 

Mezzotint 

        Converts an image to a random pattern of black-and-white areas or of fully saturated colors in a 

color image. To use the filter, choose a dot pattern from the Type menu in the Mezzotint dialog box. 

Mosaic 

Clumps pixels into square blocks. The pixels in a given block are the same color, and the colors of the 

blocks represent the colors in the selection. 

Pointillize 

Breaks up the color in an image into randomly placed dots, as in a pointillist painting, and uses the 

background color as a canvas area between the dots. 

 

8. Explain SHARPEN FILTERS? 

The Sharpen filters focus blurred images by increasing the contrast of adjacent pixels. 

Sharpen and Sharpen More 

             Focus a selection and improve its clarity. The Sharpen More filter applies a stronger sharpening 

effect than does the Sharpen filter. 

Sharpen Edges and Unsharp Mask 

             Find the areas in the image where significant color changes occur and sharpen them. The Sharpen 

Edges filter sharpens only edges while preserving the overall smoothness of the image. Use this filter to 

sharpen edges without specifying an amount. For professional color correction, use the Unsharp Mask filter 

to adjust the contrast of edge detail and produce a lighter and darker line on each side of the edge. This 

process emphasizes the edge and creates the illusion of a sharper image. 

Smart Sharpen 

           Sharpens an image by letting you set the sharpening algorithm or control the amount of sharpening 

that occurs in shadows and highlights.  

 

9. Explain about Lighting effects? 

                      The Lighting effects filter lets you produce myriad lighting effects on RGB images. You 

can also use textures from grayscale files to produce 3D-like effects and save your own styles for use in 

other images.  

1. We can use lighting effects to get professional and beautiful effects on Photographs. 

2. Open an image in Photoshop. 

3. To apply light effects goto Filter→Render→Light Effect 

4. You will find Light Effects dialog box as shown above. 

5. You can change the style, Light type, intensity, Focus etc. 

6. You can change the light size by dragging the direction points. 

7. You can move the light to anywhere in the image by using the move pointer available in the 

middle of the light. 
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MENUS 

A menu is a collection of options. Menus are probably the most familiar interface elements. 

File Menu: 

File Menu contains all the options related to a file, with a few extras including Import, which deals with 

scanning, and Save for Web, reverting etc. 

 

Edit Menu: 

Edit Menu is a collection of options used to edit photos, and contains extra options like Fill, Stroke and 

other image-altering functions. 

 

Image Menu: 

Options available in the Image Menu effect a whole image, for the most part. In this you will find color 

adjustments, size adjustments, and any other changes you need to make globally when working with a 

Photoshop File. 

 

Layer Menu: 

The layer menu is similar to the image menu, but it contains options that effect only current or selected 

layer. Most of the options available in Image Menu are also available in Layer Menu. 

 

Select Menu: 

The select menu deals with selections you make. Selecting the specific parts of an image and altering 

the selected part is a difficult part of working. This menu gives you some options regarding selections, 

including the ability to save a selections, reserve them, or add to them. 

 

Filter Menu: 

Filter Menu is a collection of Filters that comes with Photoshop. You can add more Filters through 

Plug-Ins from the internet and add them to the Filter Menu. The Filter Menu allows you to apply filters to 

any part of your image 
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View Menu: 

The view Menu is used to change the view settings. You can use this to show and display guidelines on 

the image, and to zoom in and out, among other things. 

 

Window Menu: 

The Window Menu allows you to toggle back and forth between hide and show for each 

Interface element. 

 

Help Menu: 

The Help Menu contains two features: resize image and export transparent image. Help Menu is used to 

get any information about Photoshop. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


