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Unit-I: MS-Excel 
 

Features of Ms-Excel, Parts of MS-Excel window, entering and editing data in worksheet, number formatting in excel, 

different cell references, how to enter and edit formula in excel, auto fill and custom fill, printing options. 

………………………………………………………………………………………………………………………………………………………………………………… 
 

1Q.Features of Ms-Excel 

Microsoft excel is an integrated electronic spread sheet program developed by Microsoft 

corporation.It includes the following features. 

Autocalc: This feature is very useful to sum a group of numbers is selected them. Their sum will 

automatically appear in the status area. 

Auto complete: Excel now intelligence to anticipate what you are going to type! Based upon 

entries you’ve already made, AutoComplete will try to figure out what you intended to type, 

once you’ve entered few letters. 

Autocorrect: Excel can support automatically correct mistakes.  

Better Drag-and-Drop: Do you want to move a group of cells? Excel’s drag and drop feature lets 

you reposition selected portion of your spreadsheet by simply dragging them with your mouse. 

Cell tips and Scroll Tips: To help you get around better with mouse, Excel now includes scroll tips. 

When you click and drag a scroll bar, a small window tells you what row or column you are 

heading for. 

Number Formatting: It’s easy to format numbers with excel’s new number formatting feature. 

Select your numbers and choose cells command from format menu. 

Templates and Template wizard: Excel’s template facility has been greatly enhanced. You can 

choose from a variety of elegantly designed templates for your home or business. You can even 

have a template wizard link your worksheets to a database. 

Shared Lists: you can now have worksheets that are shared simultaneously over a network. 
 
Conditional Formatting:Conditional formatting helps users to quickly focus on important aspects 
of a spreadsheet or to highlight errors and to identify important patterns in data.  

Sorting and Filtering:Excel spreadsheets help us make sense of large amounts of data. To make it 
easier to find what you need, you can reorder the data or pick out just the data you need, based 
on parameters you set within Excel. Sorting and filtering your data will save you time and make 
your spreadsheet more effective. 

Excel Charts:Excel charts help you communicate insights & information with ease. By choosing 
your charts wisely and formatting them cleanly, you can convey a lot. 
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2Q.Parts of MS-Excel window:office 2007 and its parts 

 
office 2000 and its parts: 
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Quick Access Toolbar – Collection of buttons that provide one click access to commonly used 
commands such as Save, Undo or Redo. You can also customize this according to your 
preference. 

Title Bar – A bar the display the name of active workbook 
Ribbon – The main set of commands and controls organized task in Tabs and groups, you can 
also customize the ribbon according to your preference. 
Column Headings – The letters that appear along the top of the worksheet to identify the 
different columns in the worksheet. 
Worksheet Window – A window that displays an Excel worksheet, basically this is where you 
work all the tasks. 

  Vertical Scroll Bar – Scroll bar to use when you want to scroll vertically through the  
   Worksheet window.             
Horizontal Scroll Bar – Scroll bar to use when you want to scroll horizontally through the 
worksheet window.  
Zoom Controls – Used for magnifying and shrinking of the active worksheet. 
View Shortcuts – Buttons used to change how the worksheet content is displayed. Normal, 
Page Layout or Page Break Preview. 
Sheet Tabs – Tabs the display the name of the worksheet in the workbook, by default its name 
sheet 1, sheet 2, etc. You can rename this to any name the best represent to your sheet. 
Sheet Tab Scrolling Buttons – Buttons to scroll the sheet tabs in the workbook 

   Row Headings – The number that appears on the left of the worksheet window to identify the   
   Different rows. 
Select All Button – A button that selects all the cells in the active worksheet 
Active Cell – The cell selected in the active worksheet 
Name Box – A box that displays the cell reference of the active cell 
Formula Bar – A bar that displays the value or formula entered in the active cell 
Office Button/File Tab – It provides access to workbook level features and program settings. 
You will notice that in Excel 2007 there is a circle. 

Note: 
 
Important terms 
 

 A workbook is made up of three worksheets. 

 
 The worksheets are labeled Sheet1, Sheet2, and Sheet3. 

 
 Each Excel worksheet is made up of columns and rows. 

 
 In order to access a worksheet, click the tab that says Sheet#. 
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3Q.Entering and editing data in worksheet 

You have several options when you want to enter data manually in Excel. You can enter data in 

one cell, in several cells at the same time, or on more than one worksheet at the same time. The 

data that you enter can be numbers, text, dates, or times. You can format the data in a variety of 

ways. And, there are several settings that you can adjust to make data entry easier for you. 

 
Enter text or a number in a cell 

1. On the worksheet, click a cell. 

2. Type the numbers or text that you want to enter, and then press Enter or Tab. 

To enter data on a new line within a cell, enter a line break by pressing 

Alt+Enter Editing text or a number in a cell 

1. Double click the cell containing the data you want to edit. 

2. Make any changes to the cell contents. 

3. Press enter key. The change will accept. To cancel your changes, press Ese key. 
 
Change the width of a column 

a. Click the cell for which you want to change the column width. 

b. On the Home tab, in the Cells group, click Format 

c. Under Cell Size, do one of the following: 

 To fit all text in the cell, click AutoFit Column Width. 

 To specify a larger column width, click Column Width, and then type the width 

that you want in the Column width box. 

 
If there are multiple lines of text in  a cell, some of the text might not be displayed the way that 

you  want.  You can display multiple lines of text inside a cell by wrapping the text. 

 
Wrap text in a cell 

a. Click the cell in which you want to wrap the text. 

b. On the Home tab, in the Alignment group, click Wrap Text. 
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4Q.how to enter and edit formula in excel 

A formula performs calculations or other actions on the data in your worksheet. A formula always 
starts with an equal sign (=), which can be followed by numbers, math operators (like a + or - sign 
for addition or subtraction), and built-in Excel functions, which can really expand the power of a 

Formula.  

 

For Example, in the above worksheet, the formula = B5+C5+D+ adds the contents 10+20+30 and 

produce the results. One can enter and edit formula in two ways. 

1. Directly into cell by double clicking where the formula wants. 

2. At formula bar after selection of required cell. 

To edit an existing formula 
 

 Click on the cell which contains the formula or results 

 Click in formula bar make necessary changes. 

 Press enter key or click on check mark. 
 

5Q.Number Formatting in excel 
It is very common to enter various types of numbers for various applications. In Excel, you can use 

number formats to change the appearance of numbers, including dates and times, without 

changing the number behind the appearance. The number format does not affect the actual cell 

value, it changes the appearance only. 

1. Select the cell or cells which contain numbers. 

2. On the home tab, under Number group click on down arrow mark. 
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Right click your mouse; from the short hand menu select format cell option. 

 
 

 

 

 

 

3. It launches Formula cells window. Click on Number tab. 

4. It lists all categories of number formatting like general, number, currency, 

accounting, date, time, and percentage. 

5. Select the suitable format and its sub options, click ok button. 

6. The numbers in the selected cells will display as per new format. 

6Q. Referencing cells 
A cell reference refers to a cell or a range of cells on a worksheet and can be used in a formula so 

that Microsoft Office Excel can find the values or data that you want that formula to calculate. There 

are three types of cell references. 

Relative references :A  relative cell reference  in a formula, such  as A1, is based  on  the  relative  

position of the cell that contains the formula and the cell the reference refers to. If the  position  of  

the  cell  that  contains the formula changes, the reference is changed. If you copy or fill the formula 

across rows or down columns, the reference automatically adjusts. By default, new formulas  use  

relative  references.  For example, if you copy or fill a relative reference in cell B2 to cell B3, it 

automatically adjusts from =A1 to =A2. 
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Absolute references:An absolute cell reference in a formula, such as $A$1, always refer to a cell 

in a  specific location. If the position of the cell that contains the formula changes,  the absolute 

reference   remains the same. If you copy or fill the formula across rows or down columns, the 

absolute reference does not adjust. By default, new formulas use relative references, so you may 

need to switch them to absolute references. For example, if you copy or fill an absolute reference 

in cell B2 to cell B3, it stays the same in   both cells: =$A$1. 

 

Mixed references A mixed reference has either an absolute column and relative row, or 

absolute row and relative column. An absolute column reference takes the form $A1, $B1, 

and so on. An absolute row reference takes the form A$1, B$1, and so on. If the position of 

the cell that contains the formula changes, the relative reference is changed, and the 

absolute reference does not change. If you copy or fill the formula across rows or down 

columns, the relative reference automatically adjusts, and the absolute reference does not 

adjust. For example, if you copy or fill a mixed reference from cell A2 to B3, it adjusts from 

=A$1 to =B$1. 

 

 
 

7Q.What is circular cell reference? 
A formula in a cell that directly or indirectly refers to its own cell is called a circular reference. 
This is not possible. 
1. For example, the formula in cell A3 below directly refers to its own cell. This is not possible. 

Excel returns a 0 if you accept this circular reference. 
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How to resolve circular cell reference? 
A formula in a cell that directly or indirectly refers to its own cell is called a circular reference 

.This causes the formula to use its result in the calculation, which can create errors. When a 

workbook contains a circular reference, Excel cannot automatically perform calculations. You 

can use error checking in Excel to locate circular references in a formula, and then remove 

them. 

To find your circular references, on the Formulas tab, in the Formula Auditing group, click the 

down arrow next to Error Checking. 
 

Click Circular References. 

 

8Q.Auto fill and custom fill 

Autofill is one of the feature present in the ms excel. When you’re typing a day, month, year 

and number the automatic series will be appeared by dragging it. This feature is called 

Autofill. For Example if your typed “Jan” and then dragged then it displays months form” Jan 

to dec” like. 
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     How excel displays the exact series? 
     All the lists such as days, months are predefined in the excel list command. When you dragged it this        

     Command it executed. Here the default list commands series. 

    Custom List in Excel: 
    We can also create a list that is displayed like auto fill in the order we define is known as the      

customer fill. In office 2003: 
 It can be achieved as by selecting the custom list option under the options in the tools menu. That is select     
Tools-options-from the options dialog box-custom list. you can see the window like above. In the List 
entries box type the list order what you want and click on Add. Then your list is added to previous list and 
you can use it as auto fill. 

  Creating a list in Office 2007 takes a few extra clicks: 
1. Enter the values and then select the list. 
2. Click the Microsoft Office button 
3. Click Excel Options (at the bottom right). 
4. Click Popular. 
5. In the Top Options for Working with Excel section, click Edit Custom Lists. 
6. Click Import. 
7. Click OK twice. 
8. Select a blank cell, enter the first item in the list, and then expand the fill handle to complete the list. 
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     9Q.Printing options 

   Use print preview to change many default print settings and see what you’ll print. Also, select a specific range of  
cells to print, and print a table in a worksheet. 

  Print a part of a worksheet: 

1.Click the worksheet, and select the range of data that you want to print. 

     2.Click FILE > Print. You can also press Ctrl+P. 

     3.Under Settings, click the arrow next to Print Active Sheets and select Print Selected Table. 

4.Click the Print button. If a worksheet has defined print areas, Excel will print only those print areas. If you   don’t   
want to print only a defined print area, check the Ignore print area box. 

      Print an Excel table: 

      1.Click a cell within the table to enable the table. 

      2.Click FILE > Print. You can also press Ctrl+P. 

      3.Under Settings, click the arrow next to Print Active Sheets and select Selected Table. 

     4.Click the Print button 

     Print gridlines in a worksheet 

     1.Select the worksheet or worksheets that you want to print. 

     2.On the PAGE LAYOUT tab, in the Sheet Options group, check the Print box under Gridlines. 

     3.Click FILE > Print. You can also press Ctrl+P. 
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Unit-II 

Formatting options: Different formatting options, change row height, formulae and functions 

Functions: Meaning and advantages of functions, different types of functions available in Excel. 

………………………………………………………………………………………………………… 
 

Change row height 
1Q.Explain the following in MS Excel. 

1. Inserting rows and columns 

2. Deleting rows and columns 

3. Changing row height and column width 

4. Hiding and unhide rows and columns 
 

Ans: 
 

1. Inserting Rows/Columns 
You can insert blank cells above or to the left of the active cell on a worksheet. When you insert blank cells, 

Excel shifts other cells in the same column down or cells in the same row to the right to accommodate the 

new cells. Similarly, you can insert rows above a selected row and columns to the left of a selected column. 

You can also delete cells, rows, and columns. 

    To Inserting Rows: 

1. To insert a single row, select either the whole row or a cell in the row above which you want to insert 

the new row. For example, to insert a new row above row 5, click a cell in row 5. 

2. Right-click the selected cells and then click Insert. 
     On the Home tab, in the Cells group, click the arrow under Insert, and then click Insert Sheet Rows. 

 

          To Inserting Columns: 

1. To insert a single column, select the column or a cell in the column immediately to the right of where 

you want to insert the new column. For example, to insert a new column to the left of column B, click a 

cell in column B. 

2. Right-click the selected cells and then click Insert 

3. On the Home tab, in the Cells group, click the arrow under Insert, and then click Insert Sheet Columns..
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2. Deleting Rows / Columns 
1. Select the cells, rows, or columns that you want to delete. 

2. On the Home tab, in the Cells group, click the arrow next to Delete, and then do one of the following: 

 To delete selected cells, click Delete Cells. 

 To delete selected rows, click Delete Sheet Rows. 

 To delete selected columns, click Delete Sheet Columns. 

3. Changing column widths and row heights 
    to   change column widths 

1. Select the column or columns that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

3. Under Cell Size, click Column Width. 

4. In the Column width box, type the value that you want. 
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To Change Row Height 

1. Select the row or rows that you want to change. 

2. On the Home tab, in the Cells group, click Format. 

3. Under Cell Size, click Row Height. 

4. In the Row height box, type the value that you want. 

 
4. Hide or unhide columns and Rows 

 
Hide or unhide columns in your spreadsheet to show just the data that you need to see or print. 

          Hide columns 

1. Select one or more columns, and then press Ctrl to select additional columns that aren't adjacent. 

2. Right-click the selected columns, and then select Hide.
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      Unhide columns 

1. Select the adjacent columns for the hidden columns. 

2. Right-click the selected columns, and then select Unhide. 
 

If you enjoy working with the ribbon, you can hide rows in this way: 

1. Go to the Home tab > Cells group, and click the Format button. 

2. Under Visibility, point to Hide & Unhide, and then select Hide Rows. 

 

Alternatively, you can click Home tab >Format > Row Height… and type 0 in the Row Height box. 

Different formatting options 

 

    2Q.Explain about Number Formatting in Excel. 
 

Number Formatting: 
 

It is very common to enter various types of numbers for various applications. In Excel, you can use number 

formats to change the appearance of numbers, including dates and times, without changing the number 

behind the appearance. The number format does not affect the actual cell value, it changes the appearance 

only. 
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1. Select the cell or cells which contain numbers. 

2. On the home tab, under Number group click on down arrow mark. 

Or Right click your mouse; from the short hand menu select format cell option. 

 
3. It launches Formula cells window. Click on Number tab. 

4. It lists all categories of number formatting like general, number, currency, accounting, date, time, and 

percentage. 

5. Select the suitable format and its sub options, click ok button. 

6. The numbers in the selected cells will display as per new format. 

 

3Q.Write short note on Auto format in Microsoft Excel. 

Ans: 

In auto format, you have numbers of pre-designed formats which you can apply on your data instantly. 

All you have to do just select a format and click OK to apply. It’s simple and easy. 

In all the pre-designed formats you have all the important components of formatting, like: 

 Number formatting

 Borders

 Fonts Style

 Patterns and Background color

 Text Alignment
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 Column and Row size
 

Where to Find Auto Format Option? 

 

If you check Excel 2003 version, auto format option is there on the menu. But, with the release of 2007 with 

ribbon this option is not available in any of the tabs. 

 

That doesn’t mean you can’t use it in earlier versions. It’s still there, but hidden. So, to use it in the Excel 

versions like 2007, 2010, 2013, and 2016 you need to add it to your Excel’ 

 

Click on the Office Button 

Then at the bottom click on excel option. It will show the following option and then click customized option. 

 

From “choose commands from” select “commands not in the Ribbon”. Then find “Auto Format” and click on 

Add. Then it will add to quick access tool bar. 

 



19  

 

How to Use Auto Format? 

 

 Select any of the cells from your data.

 Go to quick access toolbar and click on auto format button.
 Now, you have a window, where you have different data formats.
 Select one of them and click OK.

 
 Once you click OK, it will instantly apply your chosen format on the data

4Q.Explain various formatting options in Microsoft 

Excel (OR) What are formatting functions on Excel 

sheet? Explain. (OR) Explain the formatting features 

in Excel. 

 
Ans: 

 

The Font Group 

 
A) Bold, Italicize and Underline Text 
To bold text in Microsoft Excel: 

1. Select the cell or cells in which you wish to bold the text. 
2. On the HOME tab, in the Font group, click the Bold command. 
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To italicize text in Microsoft Excel: 

1. Select the cell or cells in which you wish to italicize the text. 

2. On the HOME tab, in the Font group, click the Italic command. 

 
To underline text in Microsoft Excel: 

1. Select the cell or cells in which you wish to underline the text. 

2. On the HOME tab, in the Font group, click the Underline command. 

 
B) Add Borders to Cells 

To add borders to cells in Microsoft Excel: 

1. Select the cell or cells to which you wish to add borders. 

2. On the HOME tab, in the Font group, click the arrow to the right of the Borders command. 

 
 

3.Select the type of border you wish to add from the drop down menu: 

    C)Change Text and Cell Colors 

To change the color of text in cells in Microsoft Excel: 

1. Select the cell or cells in which you wish to change the color of the text. 

2. On the HOME tab, in the Font group, click the arrow to the right of the Font Color command. 
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    To change the fill (i.e., background) color of cells in Microsoft Excel: 

 
1. Select the cell or cells in which you wish to change the fill color. 
2. On the HOME tab, in the Font group, click the arrow to the right of the Fill Color command. 

 
 

 

 

 

  

 

 

 

 
 

 

 

 

 

     3. Select a color from the drop down menu

3. Select a color from the drop down 
menu: 
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D)Set Font and Font Size 

To change the font of text or numbers in cells in Microsoft Excel: 
1.Select the cell or cells in which you wish to change the font. 
2.On the HOME tab, in the Font group, click the arrow to the right of the Font command. 

 
 

To change the size of the font of text or numbers in cells in Microsoft Excel: 

 
1. Select the cell or cells in which you wish to change the font size. 
2. On the HOME tab, in the Font group, click the arrow to the right of the Font Size command. 

3. Select a font from the drop down 
menu: 
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5Q.Explain Formulae and functions 

 
 Formula is an expression that calculates the value of a cell. 

For example, =A2+A2+A3+A4 is a formula that adds up the values in cells A2 to A4. 

 Function is a predefined formula already available in Excel. Functions perform 

specific calculations in a particular order based on the specified values, called 

arguments, or parameters. 

 

For example, instead of specifying each value to be summed like in the above formula, 

you can use the SUM Function to add up a range of cells: =SUM (A2:A4) 

 

You can find all available Excel functions in the Function Library on the Formulas tab: 

                                                                  Meaning and advantages of functions 
Advantages of Functions 

 

1. One of the key benefits of using excel functions is that they help simplify your formulas. 

3. Select a font size from the drop down 
menu: 
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2. Another key benefit of using functions is that they help you accomplish tasks that 

would be difficult with standard formulas. 

3. Functions can also help save time by helping you automate tasks that would 

take you hours to accomplish manually. 

Parts of Function: 

A function is a predefined formula that performs calculations using values indicated in a 

particular order. To use functions correctly, you’ll need to be aware of the different parts of a 

function. 

The specific way in which a function is written is referred to as syntax. The syntax for a function is: 
 
 

Average function: 

For example, the function =AVERAGE(B1:B9) would calculate the average of the values in the 

cell range B1:B9. This function contains only one argument. 
 

6Q.Different types of functions available in Excel 
Microsoft’s Excel program, widely used in business, comes with many built-in functions that 

perform mathematical and logical operations on spreadsheet data. 

In Excel, functions are simple formulas you type into a spreadsheet cell; they operate on 

numbers, text and other kinds of data. Functions enable you to perform calculations ranging 

from simple arithmetic to complex scientific, statistical and financial equations 

Mathematical Functions: 
 

SUM - Adds up all the values in a range 
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SUMIF - Adds all the values in a range that meet 

specific criteria  

ROUND - Round a number to a specified number 

of digits  

ROUNDUP - Round a number up to a specified 

number of digits 

ROUNDDOWN - Round a number down to a specified number of digits 

 
CEILING - Round a number up to a multiple 

of significance  

FLOOR - Round a number down to a multiple 

of significance  

Statistical Functions: 

COUNT - Counts all the values in a range 
 

AVERAGE - Calculates the average number from a range of values 
 

MAX - Finds the maximum value 

in a range 

 MIN - Finds the minimum value 

in a range  

COUNTA - Counts all non-empty 

cells in a range  

COUNTBLANK - Counts all blank 

cells in a range 

COUNTIF - Counts all the cells in a range that meet specific criteria 
 

LARGE - Return a value dependent upon its ranking in a range of values in descending order 
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SMALL - Return a value dependent upon its ranking in a range of values in ascending order 
 

 

 Text Functions 

 

LEN - Returns the length, in number of characters, of the contents of a cell 
 

REPT - Repeats a character a specified number of times 

 
TRIM - Remove unwanted spaces from cells 

 
LEFT - Extracts a specific number of characters from the 

start of a cell  

RIGHT - Extracts a specific number of characters from the 

end of a cell  

MID - Extracts a specific number of characters from the 

middle of a cell  

UPPER - Converts the contents of a cell to uppercase 

LOWER - Converts the contents of a cell to lowercase 
 

PROPER - Converts the contents of a cell to proper case 

 
REPLACE - Replace existing characters in a cell with a different set of 

characters  

Financial Functions 

PMT - Calculates loan repayments based on constant payments and a constant interest rate 
 

RATE - Returns the interest rate per period of a loan or investment 
 

PV - Returns the present value of an investment based on a constant interest rate and payments 

 
FV - Returns the future value of an investment based on constant payments and a constant interest 
rate 

 
IPMT - Calculates the interest paid during a period of a loan 
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or investment  

 

 

Lookup and Reference Functions: 
 

VLOOKUP - Looks vertically down a list to find a record and returns information related to that 

record  

HLOOKUP - Looks horizontally across a list to find a record and returns information related to 

that record 

 MATCH - Returns the position of a value in a list 

INDEX - Returns an item from a specific position in a list 
 

INDIRECT - Allows you to use a cell reference entered as a text string 
 

OFFSET - Returns a value from a cell, or range of cells that are a specified number of rows and 
columns from another cell 

 
CHOOSE - Returns a value from a list of values based on a specified position 

 
ADDRESS - Returns a text representation of a cell address from specified row and column numbers 

 
Logical Functions 

 

IF - Tests a condition and takes an alternative action depending on the result 
 

AND - Test up to 30 conditions using logical And 
 

OR - Test up to 30 conditions using logical Or 
 

IFERROR - Performs a specified action if a formula evaluates to an error, and displays the formula 
result if not Date & Time Functions 

 
TODAY - Returns the current date 

 
NOW - Returns the current date and time 

 
DATE - Returns the sequential serial number for the specified date and formats the 

result as a date  

DAY - Returns the day corresponding to a date represented by a number between 1 
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and 31 

 MONTH - Returns the month corresponding to a date represented by a number 

between 1 and 12 

YEAR - Returns the year corresponding to a date represented by a number in the range 1900 to 
9999 

 
WORKDAY - Returns the date a specified number of workings days before or after a date 

 
WEEKDAY - Returns the day of the week corresponding to a specified date 
 

DATE AND TIME FUNCTIONS: 

   Get the Current Date: 

To calculate the the current date, use the TODAY function. It will automatically update, if you open the 
workbook on a different day. 

=TODAY() 

NOTE: To enter the current date as a static value, that will not update, use the shortcut key: Ctrl + ; 

 

 

Get Year, Month, Week or Day Number:If a cell contains a date and time, you can use the following functions 
to extract the year, month number, or day number from the date. In this example, the date is in cell A2. 

Year: =YEAR(A2) 

Month: =MONTH(A2) 

Week: = WEEKNUM(A2) 

Day: = DAY(A2) 

NOTE: If the result looks like a date, instead of a number, change the cell's number format to General 
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Get Month or Day Name: 

If a cell contains a date, you can extract parts of that date as text. For example, show the month name, 
or the weekday name of the date. In this example, the date is in cell A2. 

Month Name (short): =TEXT(A2,"mmm") 

Month Name (long): =TEXT(A2,"mmmm") 

Weekday Name (short): =TEXT(A2,"ddd") 

Weekday Name (long): =TEXT(A2,"dddd") 

 

 

Function 

 

Description 

DATE function Returns the serial number of a particular date 

DATEDIF 

function 

Calculates the number of days, months, or years between two dates. This function 

is useful in formulas where you need to calculate an age. 

DATEVALUE 

function 

Converts a date in the form of text to a serial number 

DAY function Converts a serial number to a day of the month 

   

DAYS360 

function 

Calculates the number of days between two dates based on a 360-day year 

EDATE function Returns the serial number of the date that is the indicated number of months 

before or after the start date 

EOMONTH 

function 

Returns the serial number of the last day of the month before or after a specified 

number of months 

HOUR function Converts a serial number to an hour 

 

https://support.office.com/en-us/article/date-function-e36c0c8c-4104-49da-ab83-82328b832349
https://support.office.com/en-us/article/datedif-function-25dba1a4-2812-480b-84dd-8b32a451b35c
https://support.office.com/en-us/article/datedif-function-25dba1a4-2812-480b-84dd-8b32a451b35c
https://support.office.com/en-us/article/datevalue-function-df8b07d4-7761-4a93-bc33-b7471bbff252
https://support.office.com/en-us/article/datevalue-function-df8b07d4-7761-4a93-bc33-b7471bbff252
https://support.office.com/en-us/article/day-function-8a7d1cbb-6c7d-4ba1-8aea-25c134d03101
https://support.office.com/en-us/article/days360-function-b9a509fd-49ef-407e-94df-0cbda5718c2a
https://support.office.com/en-us/article/days360-function-b9a509fd-49ef-407e-94df-0cbda5718c2a
https://support.office.com/en-us/article/edate-function-3c920eb2-6e66-44e7-a1f5-753ae47ee4f5
https://support.office.com/en-us/article/eomonth-function-7314ffa1-2bc9-4005-9d66-f49db127d628
https://support.office.com/en-us/article/eomonth-function-7314ffa1-2bc9-4005-9d66-f49db127d628
https://support.office.com/en-us/article/hour-function-a3afa879-86cb-4339-b1b5-2dd2d7310ac7
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Excel Engineering Functions 

Converting Between Units of Measurement 

CONVERT 

 
Converts a number from one measurement system to another 

 
 
Converting Between Bases 

BIN2DEC 

 
Converts a binary number to a decimal 

BIN2HEX 

 
Converts a binary number to hexadecimal 

BIN2OCT 

 
Converts a binary number to octal 

DEC2BIN  

 
Converts a decimal number to binary 

DEC2HEX 

 
Converts a decimal number to hexadecimal 

DEC2OCT 

 
Converts a decimal number to octal 

HEX2BIN  

 
Converts a hexadecimal number to binary 

HEX2DEC 

 
Converts a hexadecimal number to a decimal 

HEX2OCT 

 
Converts a hexadecimal number to octal 

OCT2BIN  

 
Converts octal number to binary 

OCT2DEC 

 
Converts octal number to a decimal 

OCT2HEX 

 
Converts octal number to hexadecimal 

 

 
Information function in excel: 
 

The Microsoft Excel INFO function returns information about the operating environment. 

The INFO function is a built-in function in Excel that is categorized as an Information Function. It can 

be used as a worksheet function (WS) in Excel. As a worksheet function, the INFO function can be 

entered as part of a formula in a cell of a worksheet. 

Syntax 

The syntax for the INFO function in Microsoft Excel is: 

       INFO( type ) 

 

Data base functions 

The 12 database functions let you find and perform calculations on specific pieces of data in 

a database. All of the database functions search a specified database for records that match 

specified criteria. Some of the database functions then perform calculations on data in a 

specified field of the matching records. 

The following are the database functions. 

https://www.excelfunctions.net/excel-convert-function.html
https://www.excelfunctions.net/excel-bin2dec-function.html
https://www.excelfunctions.net/excel-bin2hex-function.html
https://www.excelfunctions.net/excel-bin2oct-function.html
https://www.excelfunctions.net/excel-dec2bin-function.html
https://www.excelfunctions.net/excel-dec2hex-function.html
https://www.excelfunctions.net/excel-dec2oct-function.html
https://www.excelfunctions.net/excel-hex2bin-function.html
https://www.excelfunctions.net/excel-hex2dec-function.html
https://www.excelfunctions.net/excel-hex2oct-function.html
https://www.excelfunctions.net/excel-oct2bin-function.html
https://www.excelfunctions.net/excel-oct2dec-function.html
https://www.excelfunctions.net/excel-oct2hex-function.html
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DAVERAGE DGET  DPRODUCT DSUM 

DCOUNT DMAX  DSTDEV  DVAR 

DCOUNTA DMIN  DSTDEVP  DVARP 

 

 

7Q.The Different Types of Operators in Excel 

Type Character Operation Example 

Arithmetic + (plus sign) Addition =A2+B3 

 – (minus 
sign) 

Subtraction or negation =A3–A2 or –C4 

 * (asterisk) Multiplication =A2*B3 

 / Division =B3/A2 

 % Percent (dividing by 100) =B3% 

 ^ Exponentiation =A2^3 

Comparison = Equal to =A2=B3 

 > Greater than =B3>A2 

 < Less than =A2<B3 

 >= Greater than or equal to =B3>=A2 

 <= Less than or equal to =A2<=B3 

Text & Concatenates (connects) entries to produce one 
continuous 
entry 

=A2&” “&B3t 

Reference : (colon) Range operator that includes =SUM(C4:D17) 

http://www.mit.edu/~mbarker/formula1/f1help/03-a-f67.htm#47362
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f80.htm#49052
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f87.htm#49194
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f90.htm#49326
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f71.htm#48965
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f82.htm#49113
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f88.htm#49238
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f92.htm#69606
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f72.htm#49016
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f83.htm#49150
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f89.htm#49282
http://www.mit.edu/~mbarker/formula1/f1help/03-a-f93.htm#49414
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 , (comma) Union operator that combines multiple references into 
one 
reference 

=SUM(A2,C4:D17,B3) 

 

Unit-III: Charts: Different types of charts, Parts of chart, chart creation using wizard, chart 

operations, data maps, graphs, data sorting, filtering. Excel sub totals, scenarios, what-if 
analysis. 

Macro: Meaning and advantages of Macros, creation, editing and deletion of macros - Creating a 
macro, how to run, how to delete a macro 

 

1Q.explain different types of charts in excel? 

 Ans: Excel has several different types of charts, allowing you to choose the one that best fits your 

data. In order to use charts effectively, you'll need to understand how different charts are used. 

Types of Charts: 

 Column charts use vertical bars to represent data. They can work with many different 

types of data, but they're most frequently used for comparing information. 

 Line charts are ideal for showing trends. The data points are connected with lines, 

making it easy to see whether values are increasing or decreasing over time. 

 Pie charts make it easy to compare proportions. Each value is shown as a slice of the 

pie, so it's easy to see which values make up the percentage of a whole. 

 Bar charts work just like Column charts, but they use horizontal bars instead of vertical bars. 

 Area charts are similar to line charts, except that the areas under the lines are filled in. 

 Surface charts allow you to display data across a 3D landscape. They work best with large 

data sets, allowing you to see a variety of information at the same time. 
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 2Q.Explain parts of chart? 

Ans:An excel chart comprises of many parts as shown in the figure 

 

 

chart area:chart area is an entire area that is reserved for accommodating the chart and other 

parts such as legends,title etc. 

plot area:plot area is a part of chart area,which contains the chart. 
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Y-axis:it is a vertical line whose length and segments represent different values.Y-axis used to 

show the different variations of different identities. 

X-axis:A horizontal line on which you show the variation of another intervals of values. 

Y-axis title:Y-axis titles identifies the values that have been shown on y-axis 

X-axis title:X-axis titles conveys the full details of the x-axis values 

Grid lines:grid lines are the lines that can be thought as an extension of thick marks. 

Data series:data series is a collection of related values that are plotted on a chart. 

Data point:it represents one value of the data series 

Data label:data label is some piece of text,which is written near data point to highlight some 

aspect of it. 

Chart title:chart title is the text written in chart area,which identifies the chart. 

Legends:legends are some sort of labels that identifies different series that have been plotted in 

the chart. 

 

3Q.Explain chart creation using wizard? 

• To create a chart with the Chart Wizard: 

– Select the data you want to chart, which will be your data source 

– Click the Chart Wizard button on the standard toolbar  

– In the first step of the chart wizard, select the chart type and sub-

type 

– In the second step of the Chart Wizard, make any additions or 

modifications to the chart's data source  

– In the third step, make any modifications to the chart's appearance 

– In the fourth and final step, specify the location for the chart, then 

click the OK button 
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4Q.Explain chart operations? 

Ans: Create a Chart: 
To create a line chart, execute the following steps. 

1. Select the range A1:D7. 

 

2. On the Insert tab, in the Charts group, click the Line symbol. 
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3.Click Line with Markers. 

 

Result: 

 
Change Chart Type: 
You can easily change to a different type of chart at any time. 

1.Select the chart. 

2.On the Design tab, in the Type group, click Change Chart Type. 

 

3.On the left side, click Column chart. 

4. Click OK. 
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Switch Row/Column: 
If you want to display the animals (instead of the months) on the horizontal axis, execute the following 
steps. 

1. Select the chart. 

2. On the Design tab, in the Data group, click Switch Row/Column. 

 

 

 

 

5Q.what is data maps? 
Data mapping is about relationships. In particular, it is the process of specifying how one information 
set relates, or maps, to another. Consider an information set that includes a list of people and their 
contact information. The list contains name, address, city, province or state, and zip or postal code for 
each person. Also consider a second information set that includes a list of people and their music 
preferences. This list includes listener, artist, album name, and song name for each listener. The lists 
are self-contained, somewhat related, but distinct. 

Suppose that you wanted to create a mailing list of people who like a particular artist. You can't easily 
get this information because there is no direct way to relate one information set to the other. The 
solution is to create a mapping between the name in the first information set and the listener in the 
second information set. The specification of the relationship is called a data mapping. 

6Q.Explain data sorting? 

Ans: As you add more content to a worksheet, organizing that information becomes especially 

important. You can quickly reorganize a worksheet by sorting your data. For example, you could 
organize a list of contact information by last name. Content can be sorted alphabetically, numerically, 
and in many other ways. 
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When sorting data, it's important to first decide if you would like the sort to apply to the entire worksheet or just a 

cell range. 

 Sort sheet organizes all of the data in your worksheet by one column. 

 Sort range sorts the data in a range of cells, which can be helpful when working with a 

sheet that contains several tables. Sorting a range will not affect other content on the 

worksheet. 
 

To sort a sheet : 

In our example, we'll sort a T-shirt order form alphabetically by Last Name (column C). 

1.Select a cell in the column you wish to sort by. In our example, we'll select cell C2. 
 

 

2.Select the Data tab on the Ribbon, then click the Ascending command  to Sort A to 

Z, or the Descending command  to Sort Z to A. In our example, we'll click the 

Ascending command. 
 

 

3.The worksheet will be sorted by the selected column. In our example, the worksheet is 

now sorted by last name. 
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7Q.Explain filtering data? 

If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters can be used to 

narrow down the data in your worksheet, allowing you to view only the information you need. 

To filter data : 

1. In order for filtering to work correctly, your worksheet should include a header row, 

which is used to identify the name of each column. 

2. Select the Data tab, then click the Filter command. 
 

 
3. A drop-down arrow will appear in the header cell for each column. 

4. Click the drop-down arrow for the column you wish to filter. 

5. The Filter menu will appear. 

6. Uncheck the box next to Select All to quickly deselect all data. 

7. Check the boxes next to the data you wish to filter, then click OK. 
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To remove all filters from your worksheet, click the Filter command on the Data tab. 

8Q.Explain excel sub totals? 
The Microsoft Excel SUBTOTAL function returns the subtotal of the numbers in a column in a list or 

database. 

The SUBTOTAL function is a built-in function in Excel that is categorized as a Math/Trig Function. It 

can be used as a worksheet function (WS) in Excel. As a worksheet function, the SUBTOTAL function 

can be entered as part of a formula in a cell of a worksheet. 

Syntax 

The syntax for the SUBTOTAL function in Microsoft Excel is: 

SUBTOTAL( method, range1, [range2, ... range_n] ) 

Parameters or Arguments 

method 
The type of subtotal to create, but be careful which method you select. method can be a value ranging 
from 1 - 11 that includes hidden values or a value ranging from 101 - 111 that ignores hidden values in 
the calculation. 

. 

Value 
Explanation 
(includes 
hidden values) 

1 AVERAGE 

2 COUNT 

3 COUNTA 

4 MAX 

5 MIN 

6 PRODUCT 

7 STDEV  

8 STDEVP  

9 SUM 

10 VAR 

https://www.techonthenet.com/excel/formulas/average.php
https://www.techonthenet.com/excel/formulas/count.php
https://www.techonthenet.com/excel/formulas/counta.php
https://www.techonthenet.com/excel/formulas/max.php
https://www.techonthenet.com/excel/formulas/min.php
https://www.techonthenet.com/excel/formulas/product.php
https://www.techonthenet.com/excel/formulas/stdev.php
https://www.techonthenet.com/excel/formulas/stdevp.php
https://www.techonthenet.com/excel/formulas/sum.php
https://www.techonthenet.com/excel/formulas/var.php
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Value 
Explanation 
(includes 
hidden values) 

11 VARP 

Value 
Explanation 
(ignores 
hidden values) 

101 AVERAGE 

102 COUNT 

103 COUNTA 

104 MAX 

105 MIN 

106 PRODUCT 

107 STDEV  

108 STDEVP  

109 SUM 

110 VAR 

111 VARP 

 

range1, range2, ... range_n 
The ranges of cells that you want to subtotal. 

Returns 

The SUBTOTAL function returns a numeric value. 

Applies To 

 Excel for Office 365, Excel 2019, Excel 2016, Excel 2013, Excel 2011 for Mac, Excel 2010, Excel 2007, 
Excel 2003, Excel XP, Excel 2000 

Type of Function 

 Worksheet function (WS) 

https://www.techonthenet.com/excel/formulas/varp.php
https://www.techonthenet.com/excel/formulas/average.php
https://www.techonthenet.com/excel/formulas/count.php
https://www.techonthenet.com/excel/formulas/counta.php
https://www.techonthenet.com/excel/formulas/max.php
https://www.techonthenet.com/excel/formulas/min.php
https://www.techonthenet.com/excel/formulas/product.php
https://www.techonthenet.com/excel/formulas/stdev.php
https://www.techonthenet.com/excel/formulas/stdevp.php
https://www.techonthenet.com/excel/formulas/sum.php
https://www.techonthenet.com/excel/formulas/var.php
https://www.techonthenet.com/excel/formulas/varp.php
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Example (as Worksheet Function) 

Let's look at some Excel SUBTOTAL function examples and explore how to use the SUBTOTAL function as a 
worksheet function in Microsoft Excel: 

 

Based on the Excel spreadsheet above, the following SUBTOTAL examples would return: 

=SUBTOTAL(1, D2:D5) 

Result: 22.3925 

=SUBTOTAL(2, D2:D5) 

Result: 4 

=SUBTOTAL(3, D2:D5) 

Result: 4 

=SUBTOTAL(4, D2:D5) 

Result: 35.88 

=SUBTOTAL(5, D2:D5) 

Result: 7 

=SUBTOTAL(6, D2:D5) 

Result: 136191.51 

=SUBTOTAL(7, D2:D5) 

Result: 11.91825316 

=SUBTOTAL(8, D2:D5) 

Result: 10.32151 

=SUBTOTAL(9, D2:D5) 

Result: 89.57 
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=SUBTOTAL(10, D2:D5) 

Result: 142.0447583 

=SUBTOTAL(11, D2:D5) 

Result: 106.5335688 

9Q.Explain scenarios what-if analysis? 
Ans:What-If Analysis in Excel allows you to try out different values (scenarios) for formulas. The 
following example helps you master what-if analysis quickly and easily. 
Assume you own a book store and have 100 books in storage. You sell a certain % for the highest price 
of $50 and a certain % for the lower price of $20. 
 

 

 

If you sell 60% for the highest price, cell D10 calculates a total profit of 60 * $50 + 40 * $20 = $3800. 

Create Different Scenarios: 
But what if you sell 70% for the highest price? And what if you sell 80% for the highest price? 
Or 90%, or even 100%? Each different percentage is a different scenario. You can use the 
Scenario Manager to create these scenarios. 

1. On the Data tab, in the Forecast group, click What-If Analysis. 

 

 

 

2. Click Scenario Manager. 
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The Scenario Manager dialog box appears. 

3. Add a scenario by clicking on Add. 

 

4. Type a name (60% highest), select cell C4 (% sold for the highest price) for the Changing cells and 
click on OK. 

 

5. Enter the corresponding value 0.6 and click on OK again. 

 

6. Next, add 4 other scenarios (70%, 80%, 90% and 100%). 

Finally, your Scenario Manager should be consistent with the picture below: 
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10Q.Explain meaning and advantages of macros? 

Meaning and advantages of Macros 

A Macro is a series of commands and functions that are stored in a Microsoft Visual Basic 
module and can be run whenever you need to perform the task. Regularly repeating 
activities can be automated by using macro. 

 

Advantages of Macros: 
Macros offer many advantages to those who choose to use them. They reduce the possibility of 

human error that increases with many, repetitive keystrokes and tasks. Macros reduce the 

amount of time that must be spent performing basic computing tasks, freeing users up for more 

complex problem-solving and idea-generating activities. They also make complex computations 

easier to perform. 
Reduced Typing:The repeated activities can be recorded into a macro and you can play whenever 
you want. 
Save Time:Macros stores number of activities, by executing a single macro you can perform 
complex activities. Reduce Mistakes : It avoids spelling and grammar mistakes, due to less typing 
work. 
Uniformity:The recorded macro can play whenever you want. It performs the stored activities in 
the same stored order. So, it can be used for maintain uniformity. 
Productivity:It can be used to increase the productivity. 
Edit: If you want, you can edit a macro whenever you want to meet your latest requirements. 
Reusability:One macro can be used in another macro. 
Simplicity:Number of actions can be executed by pressing single macro. 

 

11Q.CREATING A MACRO? 

ANS: Creating a Macro: 

1.On the Developer tab, in the Code group, click Record Macro 
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2.Complete the Record Macro dialog box. 

i. In the Macro name box, enter a name for the macro. 
ii. A short cut key can be assigned to run the macro. 

iii. In the Store macro in list, select the workbook where you want to store the macro. 

iv. In the Description box, type a description of the macro, if desired 
 
3.Click OK to start recording and perform the actions that you want to record. 
 
4.When you are finished recording, on the Developer tab, click Stop Recording. You can also 

click the Stop Recording button on the left side of the status bar. 

Running Macro 

1. On the Developer tab, in the Code group, click Macros. 

2. In the Macro name box, select the macro that you want to run. Then click Run 
 

12Q.Editing and deletion of macros 
Macros can be edited in the Visual Basic Editor, which requires expertise with Microsoft Visual 
Basic. For those who are not familiar with Visual Basic, macros can be deleted and then re-
recorded. 
 
To edit a macro in the Visual Basic Editor, 

1. On the Developer tab, in the Code group, click Macros 

2. In the Macro name box, select the macro that you want to edit. Then click Edit 
3. The macro opens in the Visual Basic window and can now be edited. 

 

Deleting a Macro 

1. On the Developer tab, in the Code group, click Macros. 

2. In the Macro name box, select the macro that you want to delete and click Delete 
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Assign a Macro to a Button 

1. Insert / Draw the shape on the worksheet. 

2. Right click on the shape and from the menu click on “Assign Macro”, an assign macro 

dialog box appear. Select required macro and then click on it. 

3. Next time when u click on the shape, the macro will run. 
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                                                             UNIT-4 
 

1Q.Explain features of MS Access? 

Ans:  

1.Ideal for individual users and smaller teams 

2.Easier than client-server database to understand and use 

3.Import and export to other Microsoft Office and other applications 

4.Ready templates for regular users to create and publish data 

5.Allows building and publishing Web databases effortlessly 

6.A user friendly feature ‘Tell Me’ for assistance 

7.Allows developers to create custom solutions using VBA code 

8.Hide/Show option for Ribbon 

9.Allows users to Report View Eliminates Extra Reports 

10.Allows output Reports in PDF format 

2Q.Explain creating a data base? 

Create a Database 
When you start Access, the Getting Started with Microsoft Office Access screen appears. You can use 

this screen to create a database. Within a database, you can do such things as enter data, create reports, 

and retrieve data. You can create a blank database or you can use one of the templates provided by 

Microsoft. For example, the Faculty template creates a faculty database that includes tables,queries, 

forms, and reports related to faculty. 

https://www.educba.com/course/database-basics-2013/
https://www.educba.com/course/excel-vbas-and-macros-basic/
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To use a template to create a database: 

 

1. Start Access. 

2. Click Blank Database. 

3. Type the name you want to give your database in the File Name field. Access will 

automatically append .accdb to the name. 

4. Click the Browse button. The File New Database window appears. 

5. Locate the folder in which you want to store your database. Note that the name of the 

file appears in the File Name field. 

6. Click OK. 

7. Click the Create button. Access creates the database and opens a datasheet with the 

Table Tools available to you 
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3Q.Expain parts of MS access? 
 
The Office Button 
 

When Microsoft Access opens, it displays an interface divided in various sections. The top section displays a long 

bar also called the title bar. 

The title bar starts on the left side with the Office Button . If you position the mouse on it, a tool tip would 

appear: 

 

 

The Quick Access Toolbar 
 

On its right side, the Office Button displays a (short) object called the Quick Access Toolbar  

 . If you want to hide the Quick Access toolbar, you can right-click it and click Remove Quick 

Access Toolbar. 

By default the Quick Access toolbar is equipped with three buttons: Save, Undo, and Redo. 

   Any of these actions would open the Access Options dialog box: 
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To add a command, click it in the middle list and click Add. Once you have selected the desired options, click OK. 

The main or middle area of the top section displays the name of the application: Microsoft Access.  

On the right side of the title bar, there are three system buttons that allow you to minimize, maximize, restore, or 

close Microsoft Access. 

Under the title bar, there is another bar with a Help button on the right side. 

 

The Work Area 
 

The main area of the Microsoft Access interface is divided in three sections. The left side displays a column of 

various links with the top labeled Online Templates. 

The middle section itself is made of two sides. The top part allows you to create a database. The bottom section 

displays some promotional information from Microsoft. 

The right side displays as a column with the top title labeled Open Recent Database with a More button under it. By 

default, the area under the More button is empty: 
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The bottom section of the Microsoft Access interface displays a status bar. 

The Ribbon 

 

 
In Access 2007, you use the Ribbon to issue commands. The Ribbon is located near the top of the Access window, 
below the Quick Access toolbar. At the top of the Ribbon are several tabs; clicking a tab displaysrelated 
command groups. 

 
4Q.Explain data types and properties? 



53  

Here are some of the most common data types you will find used in a typical 

Microsoft Access database. 

Type of Data Description Size 

Short Text 

Text or 
combinations of 
text and numbers, 
including numbers 
that do not require 
calculating (e.g. 
phone numbers). 

Up to 255 characters. 

Long Text 
Lengthy text or 
combinations of 
text and numbers. 

Up to 63, 999 characters. 

Number 
Numeric data used 
in mathematical 
calculations. 

1, 2, 4, or 8 bytes (16 bytes if set to Replication ID). 

Date/Time 
Date and time 
values for the years 
100 through 9999. 

8 bytes 

Currency 

Currency values 
and numeric data 
used in 
mathematical 
calculations 
involving data with 
one to four decimal 
places. 

8 bytes 

AutoNumber 

A unique sequential 
(incremented by 1) 
number or random 
number assigned 
by Microsoft Access 
whenever a new 
record is added to 
a table. 

4 bytes (16 bytes if set to Replication ID). 

Yes/No 

Yes and No values 
and fields that 
contain only one of 
two values 
(Yes/No, 
True/False, or 
On/Off). 

1 bit. 
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Some of the most important field properties to note are: 

Field Size: 
You encountered the Field Size property before, when working with the Number data type. This 
property also exists for the common Text data type. 

Format: 
This property enables you to set the precise manner in which Access displays or prints the data that is 
located in its Tables. As with Field Size, the format available to select depends on the data type of that 
column.  

Input Mask: 
This feature can be useful in data entry situations. Where Format controls how data is displayed, Input 
Mask controls how data is entered into a particular field. Input Mask is available for the following data 
types: Text, Number, Date/Time, and Currency.  
 
Default Value: 
An important database concept, the default value can help save time in the data entry process. 
 

5Q.Explain adding,deleting,renaming the fields in a table? 

To add new tables to an existing database, repeat the following steps for each new table: 

1. Click the Create tab. 

The Create tab’s buttons appear. 

2. Click the Table button on the Ribbon. 

A new table — blank and awaiting the name for the first field — appears. 

3. Build and name the fields for this new table as shown in the previous procedure. 

Save your database periodically as you work. 

4. Continue adding tables, using Steps 1 through 3, for as many tables as you need in the database. 

Renaming Tables in Microsoft Access 

Renaming a table follows from a single, straightforward process: 

1. Right-click the name of the table to be renamed and select Rename. 
2. Enter the desired name. 
3. Press Enter. 

You may need to inspect assets like queries, forms, and other objects to ensure that the name change 
has correctly spread throughout the database. 
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Deleting Tables in Microsoft Access 

Remove a table using one of two methods: 

 Right-click the name of the table and select Delete. 
 Select the name of the table to be deleted, then press the Delete key. 

To practice these actions without damaging existing tables, download some sample databases and 
experiment until you're comfortable manipulating the tables in a database that's important to you. 

6Q.Explain table creation using design view? 

Design View: 

Access provides several ways to view the objects in your database. You can use Design view to 

create or modify an Access table. You can use the View button on the Home tab or the Table 

Design button on the Create tab to change to Design view. 

To use Design view to create a new table: 
 

 
 

1. Activate the Create tab. 

2. Click Table Design in the Tables group. Access changes to Design view and the Table Tools 

become available 

 

https://www.lifewire.com/how-to-databases-4160660
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4.Type the first field name in the Field Name field. 

5.Press the Tab key. 

6.Click the down-arrow that appears when you click in the Data Type field and then select a data 

type. 

7.Click Primary Key if the column you created is a primary key. A small key appears next to the 

field name. 

8.Press the Tab key. 

9.Type a description. The description is optional. 

10Press the Tab key. Access moves to the Field Name field. 

11.Repeat steps 3 through 10 until you have created all of your fields. 

7Q.Explain table wizard? 

MS Access table wizard provides an easy way to create tables. It provides various table templates to 
create business and personal tables. The wizard helps the user to create common types of tables to 
manage mailing lists, recipes, investments and videos collection etc. 

    Create a Table using Table Wizard 

The following procedure is used to create a table using table wizard: 

1. Open Database window. 

2. Click Tables in objects bar. 

3. Double click Create table by using wizard. The Table Wizard will start. 

 

8Q.Expalin data sheet view? 

Ans: Datasheet 

In Access, data is stored in tables. A datasheet displays the information stored in a table in 

columns and rows. The columns are called fields and the rows are called records. You can use a 

datasheet to create a table, enter data, retrieve data, and perform other tasks. 

      An Access database consists of a collection of objects such as reports, queries, forms, tables etc. 
which works together to ensure that your database functions properly. We all create multiple tables in 
our databases to organize and manage our field properly. Users can use Table’s Datasheet View, in 
order to perform actions like changing, inserting, viewing or deleting any piece of data from the Table. 
Basic Features of Datasheet View 
1.Users can look at their data in columns and rows in a datasheet without using any special formatting. 



57  

2.Whenever a user creates a web table, MS Access automatically creates and displays two views which 
the user can start using instantly for data entry. 
3.When a user opens a table in Datasheet View it resembles an MS Excel worksheet, and the user can 
paste or add data in one or multiple fields. 

 
 

9Q.Explain import and link table? 
Importing a table from another Access database: 
To import a table from another Access database, select the External Data tab in the toolbar at the top 
of the screen. Then click on the Access button in the Import group. 

Next, click on the Browse button and find the Access file that contains the tables that you wish to 
import from. In this example, we are selecting the Testing2.accdb file. 

Then select the radio button called "Import tables, queries, forms, reports, macros, and modules into 
the current database" and click on the OK button. 
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Highlight the tables that you wish to import. In this example, we have selected the Suppliers table. 

When you have finished selecting the tables, click on the OK button. 

You have the option now of saving your import steps. Click on the OK button. 

Linking to a table from another Access database 

To link to a table from another Access database, select the EXTERNAL DATA tab in the toolbar at the 
top of the screen. Then click on the Access button in the Import & Link group. 

Next, click on the Browse button and find the Access file that contains the tables that you wish to link 
to. In this example, we are selecting the TechOnTheNet.accdb file. 

Then select the radio button called "Link to the data source by creating a linked table" and click on the 
OK button. 

Highlight the tables that you wish to link to. In this example, we have selected the Suppliers table. 

When you have finished selecting the tables, click on the OK button. 

10Q.Explain form wizard,design view? 

They are two ways to create forms 

1)with wizard 

2)on design view 

    Creating  Forms  using Wizard                                    ,- 

The wizard' asks' detailed questions about the record sources, fields, layout, and' format user wants.  

Step1:In the database window click forms 

Step2:click new button on the database window toolbar 

Step3:In New form dialog box,click the wizard that you want to use.A description of wizard appears 

in left side of dialog box. 
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Step4:click name of the table or other record source that includes the data you want to base your 

form on. 

Creating forms using Design view: 

Step1:In the database window click forms 

Step2:click new button on the database window toolbar 

Step3:In New form dialog box,click the Design view. 

Step4:click name of the table or other record source that includes the data you want to base your 

form on. 

11Q.Explain columnar,tabular,data sheet? 

Form Wizard you can select the layout style of your form. There are four layouts to choose from:  

1. Columnar: aligns all fields in columns 
2. Tabular: creates a form that looks like a table 
3. Datasheet: creates a form that looks like a datasheet 
4. Justified: creates a form where all records are justified to one side 

By selecting on a layout, you can see a preview of it in the preview box on the left-hand side. For this 
example, we will use use a "Columnar" layout. Once you have selected your layour, click Next. 

   
12Q.Explain chart wizard in ms-access? 
You can create charts in Access by using the “Chart Wizard” to add charts to reports. The “Chart 
Wizard” creates charts that represent data from your queries or tables. There are many chart types 
available. Charts appear as controls in reports. To add charts in Access to reports, click the “Create” tab 
in the Ribbon. Then click the “Report Design” button in the “Reports” button group. Unlike other report 
controls, the chart control uses its own data source to show its data. 
 “Chart Wizard” lets you type a title for your chart into the box provided. It also lets you select whether 
or not to add a legend to the chart. Click the “Finish” button to add the chart control to your report. 
Don’t be alarmed if the chart doesn’t display your data in the design view- it won’t. You must switch to 
“Layout View” to see the data in the chart and also resize the chart control until it appears the way you 
want it to in the report. 
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UNIT-5 

     1Q.Explain creating and using select queries? 

    Ans: Basic steps to create a select query 

     You can create a select query by using the Query Wizard or by working in Design view. Some design elements 
are   not available when you use the wizard, but you can add these elements later by using Design view. Although 
the two methods are somewhat different from each other, the basic steps are essentially the same: 

1.Choose the tables or queries that you want to use as sources of data. 

2.Specify the fields that you want to include from the data sources. 

3.Optionally, specify criteria to limit the records that the query returns. 

After you have created a select query, you run it to see the results. To run a select query, you open it in Datasheet 
view. If you save the query, you can reuse it whenever you need, for example, as a data source for a form, report, 
or another query. 

Use the Query Wizard 

1.On the Create tab, in the Queries group, click Query Wizard.  

 

2.In the New Query dialog box, click Simple Query Wizard, and then click OK. 

3.Next, you add fields. You can add up to 255 fields from as many as 32 tables or query. 

2Q.Explain multilevel sorts? 

     Multi-Level Sorting Using Dialog Box 

 When you sort data using the sort dialog box, you get an option to add multiple levels to it. 

  Here are the steps to do  multi-level sorting using the dialog box: 

  1.Select the entire data set that you want to sort. 
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  2.Click the Data tab. 

  3.Click on the Sort Icon (the one shown below). This will open the Sort dialog box.

 

 In the Sort Dialogue box, make the following selections 

 Sort by (Column): Region (this is the first level of sorting) 

 Sort On: Values 

 Order: A to Z 

 4.If your data has headers, ensure that ‘My data has headers’ option is checked. 

o  

 

5.Click on Add Level (this will add another level of sorting options). 

In the second level of sorting, make the following selections: 

1.Then by (Column): Sales 

2.Sort On: Values 

3.Order: Largest to Smallest 

4.Click OK 
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3Q.explain crosstab Queries? 

Ans: Creating Crosstab Queries in Microsoft Access: 

A Microsoft Access crosstab query presents summary information in a compact format that is similar to a spreadsheet. 
These types of queries can present a large amount of summary data in a format that is usually simpler to analyse than 
viewing the information in a database form. Each attribute (field) in a table typically contains a category of data. A 
crosstab query summarizes the data from one or more of these fields that are separated into groups based on one or 
more fields. 

The Microsoft Access Crosstab Query Wizard 

Which ever way you decide to go, you must specify the following three items: 

 Row Heading field: The name of the field selected as the row heading begins the first column in the query results 
datasheet. Each value in this field is displayed in the first column as a row title. 

 Column Heading field: The values in the field selected as the column heading are displayed as headings for the 
remaining columns in the query results datasheet. 

 Value field: The values in the selected field are summarized by the values in the rows and columns. You must 
designate the summary operation to be performed. For example, you might want to sum or average the values in a field. 

Crosstab Query Limitations 

1.To use multiple tables for the crosstab query, you will first need to create a separate query that has the tables required 
in it. The Crosstab Query Wizard will only allow you to select one table or one query for the row and column headings. 
2.You can not specify limiting criteria whilst using the crosstab query wizard. 

4Q.Finding incomplete matches? 

Ans: In Access, there is another very useful wizard and that is Find Unmatched Query Wizard. The Find 
Unmatched Query Wizard creates a query that finds records or rows in one table that have no related records in 

another table. 

As we have already discussed how data joins together in queries, and how most queries are looking for the 

matches between two or more tables. 

 
 This is the default join in Access, for example, if we design a query with two 

tables, tblCustomers and tblOrders, and join those two tables by the CustomerIDs, this query will return only the 

results that match. In other words, the customers who have placed orders. 
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 There are times when we don't want to see the matches, for instance, we may not want to see any customer 

in our database — the customers who have not placed orders as yet. 

 

 This is exactly what the find unmatched query does. 

5Q.showing all records after a Query? 

Ans: To open tables or queries in Query Design view: 
1.Activate the Create tab. 

2.Click the Query Design button in the Other group. The Show Table dialog box appears. 

3.Activate the Tables tab if you want to base your query on tables, activate the Queries tab if you want base your 
query on queries or activate the Both tab if you want to base your query on both tables and queries. 

4.Click to choose the table or query on which you want to base your query. 

5.Click Add. The table appears in the window. 

6.Click to choose the next table or query on which you want to base your query. 

7.Continue clicking tables or queries until you have all the tables and queries you plan to use. 

8.Click Close. Access changes to Query Design view. 

To display all records and all fields: 

 

1.Open a table or query in Query Design view. 
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2.Click the down-arrow in the first field on the Field row and then select the tablename.* option. The table name 
appears on the table line. 
3.Click the Run button. Access retrieves all of the fields and records for the table and displays them in Datasheet 
view. 

6Q.creating and using select query? 

Ans: When you want to select specific data from one or more sources, you can use a select query. A select query helps you 

retrieve only the data that you want, and also helps you combine data from several data sources. 

Basic steps to create a select query: 

1.Choose the tables or queries that you want to use as sources of data. 

2.Specify the fields that you want to include from the data sources. 

3.Optionally, specify criteria to limit the records that the query returns. 

After you have created a select query, you run it to see the results.  

Use the Query Wizard to create a select query 

You can use the Query Wizard to automatically create a select query. When you use the wizard, you have less 
control over the details of the query design, but the query is usually created faster than if you did not use the 
wizard. Moreover, the wizard can catch some simple design mistakes and prompt you to perform a different 
action. 

7Q.what are quries,dynasets and reports? 

Ans: 

Queries:Queries are requests to access information. 

When access responds to a query,that response constitutes a dynaset.A dynamic set of data meeting your query 
criteria. 

Report:reports are paper copies of dynasets.you can also store reports to disk.Access can help create 
reports.There are even wizards for complex print outs like crosstab reports. 

8Q.Explain printing reports? 

Print Report: Print report without seeing the report on the Print Preview. The report will be print immediately 
after clicking a Print Report button. 

1.Click File and then click Print. 
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2.On the Print area of the File options, click the Print option to open the Print dialog box. 

3.Change the page format setup or other print options or printer selection as needed, and then click OK to print  

9Q.Forms and database printing? 

1. Open the database containing the form. 
2. Click Forms Under Objects in the Database window. 
3. Right-click the form you want to convert to a report. 
4. Click Save As. 
5. Click in the Save "Form_Name" To text box and enter a name for your report. 
6. Click the drop-down arrow in the As text box and select Report from the list, then click OK. 
To print the report, click Reports Under Objects in the Database window and then select the report. 

To convert an Access 2007 form to a report, follow these steps: 

1. Open the database containing the form. 
2. Click the name of the form in the Navigation pane. 
3. Click the Microsoft Office button. 
4. Point to Save As and then click Save Object As. 
5. Click in the Save "Form_Name" To text box and enter a name for your report. 
6. Click the drop-down arrow in the As text box and select Report from the list, then click OK. 
To print the report, click Reports in the Navigation pane and then select the report. 

10Q.Explain defining advanced reports? 

Ans: Advanced reports are a combination of three related modules: 

 Custom Queries : Custom query records contain the SQL statement used to pull information from the 
database. 
 Data Formats : Data format records describe how to format and display the results of the related custom 
query. Data formats may also be interrelated to create child/parent combinations of queries. 
 Advanced Reports : Advanced report records serve as headers for the report and may display one or more 
data format. The advanced report record may also be scheduled to be automatically run and emailed to a user 

Creating Advanced Reports:Since a single advanced report consists of records from three different modules, the 
following instructions will step through creating a record within each module and relating those records to 
generate a report. First, a custom query record will be created, then a data format, and finally an advanced 
report record. The fields specific to each module are described prior to each set of creation instructions. 

11Q.How to modify reports manually in access? 

Ans:you can make changes to reports by adding or deleting report sections and controls and by changing their 

properties. 
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1.Begin by switching to the database window.click on the reports tab,and then on the design button. 

2.the design view window is divided in to many reports sections. 

Report header:the report header contains a label with the reports title,and often other controls. 

Page header:page headers contain information that will repeat on every page like column headings. 

Detail section:the detail section contains labels and field controls that specify which data will be printed. 

Group factors:these are used to specify things like subtotals. 

Page footer:the page footer contains text and expressions that print on each page. 

Report footer:the report footer contains items that appear only at the end of a report,like grand totals,or 
instructive text like “please report all errors to manager”. 

12.Explain properties in reports? 

Ans: The Format Properties of a Report 
Caption 
Default View 
Auto Resize  
Auto Center 
Page Header and Page Footer 
Border Style  

The Report’s Data Properties 
Record Source 
Filter  
Filter On Load 
Order By  
Allow Filters  

Other Properties of a Report 
Record Locks  
Date Grouping 
Tag 

13Q.saving report in ms access? 
Saving a Report: 

The final step is to save the report object. 

Note: This can be done at any time during report creation. 

When you click on the ‘Save’ button (icon with disk) in the toolbar at the top of the page, a "Save As" window 

should appear as in the example below: 
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Enter a name for the report and click the ‘OK’ button. 

14Q.Explain flat versus relational? 

Ans: Flat File Database 
A flat file database is a database designed around a single table. The flat file design puts all database information 
in one table, or list, with fields to represent all parameters. A flat file may contain many fields, often, 
with duplicate data that are prone to data corruption. If you decide to merge data  
between two flat files, you need to copy and paste relevant information from one file to the other. 
 
Relational Database 

A relational database, on the other hand, incorporates multiple tables with methods for the tables to work 
together. The relationships between table data can be collated, merged and displayed in database forms. Most 
relational databases offer functionality to share data: 

 Across networks 
 Over the Internet 
 With laptops and other electronic devices, such as palm pilots 
 With other software systems 
 

15Q.Explain types of Relationships? 
Ans: There are 3 types of relationships in relational database design. They are: 
 One-to-One 

 One-to-Many (or Many-to-One) 

 Many-to-Many 
These are explained below. 

One-to-One:A row in table A can have only one matching row in table B, and vice versa. 

 
Example of a one-to-one relationship 

One-to-Many (or Many-to-One):This is the most common relationship type. In this type of relationship, a row in 
table A can have many matching rows in table B, but a row in table B can have only one matching row in table A. 

https://database.guide/what-is-a-relationship/
https://database.guide/what-is-a-row/
https://database.guide/what-is-a-table/
https://database.guide/wp-content/uploads/2016/05/relationship-diagram-one-to-one.png
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 Example of one-to-many relationship. 

Many-to-Many: 

In a many-to-many relationship, a row in table A can have many matching rows in table B, and vice versa. 

A many-to-many relationship could be thought of as two one-to-many relationships, linked by an intermediary 
table. 

The following is an example of a many-to-many relationship: 

 
This is the Relationships tab that is displayed when you create a relationship Microsoft Access. In this case, a 

many-to-many relationship has just been created. The Orders table is a junction table that cross-references the 
Customers table with the Products table. 

 

16Q.Explain viewing Relationships? 

Ans: View table relationships:To view your table relationships, click Relationships on the Database Tools tab. 

The Relationships window opens and displays any existing relationships. If no table relationships have been 
defined and you are opening the Relationships window for the first time, Access prompts you to add a table or 
query to the window. 

Open the Relationships window 

1.Click File, and then click Open. 

https://database.guide/wp-content/uploads/2016/05/relationship-diagram-one-to-many.png
https://database.guide/wp-content/uploads/2016/05/create_a_relationship_in_access_2013_5.png
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2.Select and open the database. 

3.On the Database Tools tab, in the Relationships group, click Relationships. 
If the database contains relationships, the Relationships window appears. If the database does not contain any 
relationships and you are opening the Relationships window for the first time, the Show Table dialog box 
appears. Click Close to close the dialog box. 

4.On the Design tab, in the Relationships group, click All Relationships. 
 
This displays all of the defined relationships in your database. 

     17Q.Defining  Relationships? 

   Defining Table Relationships 

Data from several different tables is related through the use of common fields. A common field is a field existing 

in two or more tables, allowing you to match records from one table with records in the other tables. Once you 

have a way of relating two tables with a common field, your next task is to express the nature of that 

relationship. There are three types of relationships: one-to-one, one-to-many, and many-to-many.  

Define Table Relationships 
  Click the Database Tools tab. 

  Click the Relationships button. 

  If necessary, click the Show Table button to display the Show Table dialog box. 

  Click the Tables tab. 

  Click the table you want. 

  Click Add. 

The table or query you selected appears in the Relationships window. Repeat steps 5 and 6 for each table you 

want to use in a relationship. 

  Click Close. 

  Drag the common field in the first table to the common field in the second table. When you release the 
mouse button, a line appears between the two tables, signifying that they are related. Also, the Edit Relationships 
dialog box opens, in which you can confirm or modify the relationship. 

  Click the Join Type button if you want to specify the join type. Click OK to return to the Edit Relationships 
dialog box. 
    Click Create to create the relationship. 
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                                                                    Click to view larger image 

 

 

19.Returning to the query design? 

 Ans: The Query Design Button 

 

      Click the Query Design button to create a query in Design view. You could also use the Query Wizard button 

next to it to launch the Query Wizard, however, Design view gives you more control over the query. 

Tables to Include in the Query 

javascript:popUp('/content/images/chap3_9780789750471/elementLinks/03fig23_alt.jpg')
javascript:popUp('/content/images/chap3_9780789750471/elementLinks/03fig23_alt.jpg')
https://database.guide/wp-content/uploads/2016/05/how_to_create_a_query_in_access_1.png
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   The Show Table dialog allows you to choose which tables to include in the query. You can also include other queries 

to use within a query. 

    Query Design View: 

 

https://database.guide/wp-content/uploads/2016/05/how_to_create_a_query_in_access_2.png
https://database.guide/wp-content/uploads/2016/05/how_to_create_a_query_in_access_3.png
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     Query Design View allows you to specify the precise criteria for the query. You can choose which tables are shown 

in the results, which fields to use, add filtering criteria, and more. 

    18.Explain creating and deleting relationships? 

Creating relationship: 

1.Open the Relationship Dialog. Click Relationships from the Database Tools tab on the Ribbon. ... 

2.Select the Tables. Select both the Artists and Albums tables from the list and click Add . ... 

3.Create the Relationship. ... 

4.Edit the Relationship. ... 

5.The Relationship. 

Deleting relationships: 

1.On the Database Tools tab, in the Relationshipsgroup, click Relationships. 

2.On the Design tab, in the Relationships group, click All Relationships. ... 

3.Click the relationship line for the relationship that you want to delete. ... 

4.Press the DELETE key. 
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